none
Error sending emails to Internet: Failed to connect. Winsock error code: 10051

    Question

  • Our exchange 2013 CU2 (CAS+MBX, Win2012) was sending emails to Internet using another server (a kerio email server) and outbound internet email was working as expected.

    We have now removed the Kerio server, I also removed the kerio_Send_Connector I was using to send emails to internet and I also changed the email domain in Exchange to be authoritative. I created a new Internet send connector with default values, but the same bad behavior is present.

    Our Exchange 2013 receives emails internally and externally with no problems. The problems are sending emails to Internet. I am suspecting something in the firewall but i need to do some more research.

    If from the same Exchange server I telnet to an Internet email host:25 I do get the smtp banner but as soon as I start typing HELO/EHLO I get disconnected and errors are logged.

    Errors when sending emails to any emails address (this is from an email sent to google, all others are the same):
    ****
    Remote Server at aspmx3.googlemail.com (74.125.136.26) returned '400 4.4.7 Message delayed'
    7/1/14 9:52:44 a. m. - Remote Server at aspmx3.googlemail.com (74.125.136.26) returned '441 4.4.1 Error encountered while communicating with primary target IP address: "Failed to connect. Winsock error code: 10051, Win32 error code: 10051." Attempted failover to alternate host, but that did not succeed. Either there are no alternate hosts, or delivery failed to all alternate hosts. The last endpoint attempted was 74.125.136.26:25'

    ****
    I cannot find any references from such Winsock error that are related to Exchange 2013.

    So far all email is being queued at the Exchange Server 2013. I am afraid to install CU3 and make things worse.

    Thanks for your comments.

    Tuesday, January 07, 2014 7:16 PM

Answers


  • Just check if the receive connector settings are set to fine

    check the send connector properties and see whether it is  set to use DNS to route emails through external DNS/Internal DNS or smart host .

    Do a telnet to external domain like hotmail,yahoo and see  at what transaction you are getting an error

    Enable verbose logging, restart the transport service and check if you get the same error in the verbose logs as well

    Get in touch with the ISP and see if the port 25 for Outbound SMTP is  opened.

    YOu can check if SMTP Proxy is enabled in the firewall. If so disable the SMTP proxy in the firewall and check.
    Good Luck!!

    Please mark as helpful if you find my contribution useful or as an answer if it does answer your question.
    That will encourage me - and others - to take time out to help you.
    Regards,
    Sathish

    Monday, January 13, 2014 5:13 AM

All replies

  • Hi

    Also make sure that your ISP is allowing mail from your exchange server out to the internet.

    Wednesday, January 08, 2014 4:34 AM
  • Hi Erick,

    In addition to Dare's suggestion, I would like to verify if you have made some changes in your router or in the Mailbox server.

    What's more, please run the Get-TransportServer |fl *DNS* cmdlet to check the transport configuration.

    Hope it helps.

    Best regards,
    Amy


    Amy Wang
    TechNet Community Support

    Monday, January 13, 2014 2:32 AM
    Moderator

  • Just check if the receive connector settings are set to fine

    check the send connector properties and see whether it is  set to use DNS to route emails through external DNS/Internal DNS or smart host .

    Do a telnet to external domain like hotmail,yahoo and see  at what transaction you are getting an error

    Enable verbose logging, restart the transport service and check if you get the same error in the verbose logs as well

    Get in touch with the ISP and see if the port 25 for Outbound SMTP is  opened.

    YOu can check if SMTP Proxy is enabled in the firewall. If so disable the SMTP proxy in the firewall and check.
    Good Luck!!

    Please mark as helpful if you find my contribution useful or as an answer if it does answer your question.
    That will encourage me - and others - to take time out to help you.
    Regards,
    Sathish

    Monday, January 13, 2014 5:13 AM