none
Outlook 2007 Signature settings greyed-out

    Question

  • Whilst we have a corporate signature setup, we have recently lost the ability to change / create new ones, with all the settings now greyed out on users' machines.

     

    They are NOT greyed-out in Safe Mode however, and I can create and change to a new one, but on returning to normal mode, we encounter the greyed-out problem again.

     

    I've seen Sue Mosher's post elsewhere about turning off AddIns, but even with all of them unticked/disabled, the greyed-out status remains on re-starting Outlook.

     

    Similary, using the /cleanviews switch fails to resolve, as does /nocustomize, /noextensions, /safe:1, /safe:3, and /safe:4.

     

    I've tried removing and re-adding my Profile too...even with reboot between.

     

    As you might imagine, I have some very frustrated users ringing me....often.

     

    Any suggestions please?

     

    Thanks.

     

    David
    Thursday, June 05, 2008 12:38 PM

Answers

  • Hi,

    This indicates that a third party add-in/application is causing this.

    1.    Removed the 3rd party add-ins from
    HKEY_CURRENT_USER\Software\Microsoft\Office\
    Outlook\Add-ins and
    HKEY_LOCAL_MACHINE\Software\Microsoft\Office\
    Outlook\Add-ins

    2.    Also please try to perform a clean boot to disable third party application.

    Let's perform a Clean Boot. A Clean Boot will allow us to isolate any device drivers or programs that are loading at startup that may be causing a conflict with other device drivers or programs that are installed in your computer.

    1) Run MSCONFIG.EXE. (MSCONFIG is a built-in tool for Windows XP\2003 systems.)

    2) In the Services tab, click "Hide All Microsoft Services" and click "Disable All".

    3) In the Startup tab, click "Disable All". Click OK. (This will temporarily prevent third-party programs from running automatically during start-up.)

    4) Restart the computer. Does the problem still persist?

    If the problem does not occur, it indicates that the problem is related to one application or service we have disabled. You can use the MSCONFIG tool again to re-enable the disabled item one by one to find out the culprit.

    3.    Besides, you can use listdlls to compare the dlls in normal mode and safe mode.

    Listdlls

    http://www.sysinternals.com/utilities/listdlls.html

    Create a folder Listdlls under c drive. Unzip the utility in this folder

    1). Open Outlook

    a. From command prompt, change directory to c:\listdlls

    b. Type listdlls.exe Outlook.exe > Outlooknormal.txt

    It will create output to Outlooknormal.ext


    2). Re-run step a, b to get dll list in safe mode.

    3.Compare to see whether any difference between these txt files.

    More information share with you:

     Description of the Outlook 2003 and Word 2003 post-Service Pack 1 hotfix package: April 28, 2005

    http://support.microsoft.com/kb/898076/en-us

    Hope it helps.

    Xiu

     
    Friday, June 06, 2008 7:25 AM

All replies

  • Hi,

    This indicates that a third party add-in/application is causing this.

    1.    Removed the 3rd party add-ins from
    HKEY_CURRENT_USER\Software\Microsoft\Office\
    Outlook\Add-ins and
    HKEY_LOCAL_MACHINE\Software\Microsoft\Office\
    Outlook\Add-ins

    2.    Also please try to perform a clean boot to disable third party application.

    Let's perform a Clean Boot. A Clean Boot will allow us to isolate any device drivers or programs that are loading at startup that may be causing a conflict with other device drivers or programs that are installed in your computer.

    1) Run MSCONFIG.EXE. (MSCONFIG is a built-in tool for Windows XP\2003 systems.)

    2) In the Services tab, click "Hide All Microsoft Services" and click "Disable All".

    3) In the Startup tab, click "Disable All". Click OK. (This will temporarily prevent third-party programs from running automatically during start-up.)

    4) Restart the computer. Does the problem still persist?

    If the problem does not occur, it indicates that the problem is related to one application or service we have disabled. You can use the MSCONFIG tool again to re-enable the disabled item one by one to find out the culprit.

    3.    Besides, you can use listdlls to compare the dlls in normal mode and safe mode.

    Listdlls

    http://www.sysinternals.com/utilities/listdlls.html

    Create a folder Listdlls under c drive. Unzip the utility in this folder

    1). Open Outlook

    a. From command prompt, change directory to c:\listdlls

    b. Type listdlls.exe Outlook.exe > Outlooknormal.txt

    It will create output to Outlooknormal.ext


    2). Re-run step a, b to get dll list in safe mode.

    3.Compare to see whether any difference between these txt files.

    More information share with you:

     Description of the Outlook 2003 and Word 2003 post-Service Pack 1 hotfix package: April 28, 2005

    http://support.microsoft.com/kb/898076/en-us

    Hope it helps.

    Xiu

     
    Friday, June 06, 2008 7:25 AM
  • A POSSIBLE SOLUTION!!!

    I had the same problem. I have 3 work stations that I run XP w/SP2.  Using Outlook 2007, I could not access the signature settings to apply a signature to emails.  After an hour and a half with a phone up to my ear and a Microsoft technician working on it, I still did not have a solution. (Tomorrow the Escalation Team from Microsoft will call me to have a go at it).

    After hanging up, I continued to research, but found no solution...until...I struck out on my own.

    I found a solution to my problem.  Hopefully, it will solve yours.

    To be honest, it was simpler than I thought.

    Here goes:
    MAKE SURE OUTLOOK 2007 IS CLOSED
    Start - Run - Type in regedit- (follow this path) HKEY_CURRENT_USERS/SOFTWARE/MICROSOFT/OFFICE/12.0/COMMON/MAILSETTINGS - find DisableSignatures in the right hand viewer...if the value under the data column is set to (1)...that is your problem.  Right click on DisableSignatures and select modify.  Change the value to 0 (zero).  Then exit.

    Open Outlook 2007 - tools - options -mail format the signature button should now be available.

    Hope this helps someone.

    Following Morning:
    After speaking with the Escalation Team, he stated that when he researched this problem, he could not find a solution.  He is going to write this one up for the Microsoft Knowledge Base using the information I gave him and should be posted in about a month.
    Wednesday, August 06, 2008 10:43 PM
  • I ran a script in my environment and I had the same problem.
    What the script did is add the following lines

    objShell.RegWrite "HKEY_CURRENT_USER\Software\Microsoft\Office\" & OutlookVersion &"\Common\MailSettings\NewSignature" , "L1-Signatures"
    objShell.RegWrite "HKEY_CURRENT_USER\Software\Microsoft\Office\" & OutlookVersion &"\Common\MailSettings\ReplySignature" , "L1-Signatures"

    Just remove the 2 entries by deleting them.  Do not just clear their values.



    Thursday, September 04, 2008 8:50 AM
  • We are having this exact same problem as described in David's post (Not in safe mode, ...).

    Only 3 out of 20 Terminal Servers have this problem....so far...

    I've tried steps above, with the exception of disabling services, since this is a production environment and we currently don't have a server to spare....

    Their are different addins active, not a conclusive combination on the non-functional servers.
    The DisableSignatures is not present at all.
    The New/ReplySignatures are not present


    Anyone who experienced this proble, solved another way? (Perhaps David?)



    Wednesday, March 25, 2009 9:55 AM
  • I just found this solution and it worked like a charm!  I have several users with this problem, so I made a .reg and pushed it out.    Thanks again!

    David  

    Friday, April 30, 2010 4:59 PM