none
Outlook 2007 error: Your IMAP server closed the connection

    Question

  • Hi there,

    I've set up Exchange 2007 as IMAP and SMTP server.

    on one of the client, we use Outlook 2007 to connect to it:
    Incoming using port 993 SSL
    Outgoing using port 587 TLS

    When we start Outlook 2007, it gave out an error during send/recieve:

    Your IMAP server closed the connection. This can occur if you leave the connection idle for too long.
    Details:
    Connection is closed. 15
        Protocol    :    IMAP
        Server      :    MYSERVER.DOMAIN.COM
        Port         :    993
        Error Code:    0x800CCCDD

    Sending email out is not a problem though.

    I've tried:
    - disable automatic send/recieve
    - extend server timeout to 10 minutes (account settings > change > more settings > advanced)
    - tick the "remember password" check box
    - subscribe only the inbox

    I heard people using Thunderbird and has no such issue but I didn't test this.

    Please help!


    Andrew P.
    Thursday, April 14, 2011 1:21 AM

Answers

  • I finally fixed this problem after two weeks. I noticed Outlook wasn't storing password and I couldn't access Managing Credentials from the User Account page in the control panel. After some reading I suspected I had a corrupted Win7 user profile. I created a new user account and the imap accounts were set up instantly without any flaws. And now my passwords are saved too!
    • Edited by ericwt Sunday, July 01, 2012 6:39 PM
    • Proposed as answer by ScottDAustin Tuesday, August 07, 2012 4:08 PM
    • Marked as answer by p.andrew Wednesday, August 15, 2012 8:01 AM
    Sunday, July 01, 2012 6:38 PM

All replies

  • Hi
       Many users meet this kind of problem. Only two user solve  their problem.
       They offer Get-MailboxFolderStatistics <username> and find out duplicate folder in mailbox created by IMAP like thunderbird. Then they delete them.
       So people who using thunderbird may cause this kind of problem.
        Maybe their cases are useful to you. Link is too long.
       case1  case2

    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Friday, April 15, 2011 2:50 AM
  • I have the same exact problem since yesterday - except I use Gmail as my IMAP and SMTP server - and I get this

    UNAVAILABLE] Temporary System Error
        Protocol:    IMAP
        Server:    imap.gmail.com
        Port:    993
        Error Code:    0x800CCCDD

     

    I have searched EVERYWHERE for an answer!  Please help! - I cannot send or receive email or even open my new messages

    Saturday, April 16, 2011 12:03 PM
  • I used Outlook 2007 and yet I also have this issue (both Outlook and Exchange are MS product???)

    I ran this command on exchange management shell:
    Get-MailboxFolderStatistics username | FL Name

    for my account, I see 2 entries that have the same name:
    - Conversation Action Settings
    - Quick Step Settings

    And when I'm looking at the Event Viewer > Windows Logs > Application, there are several error message regarding duplicate folders:

    Log Name:      Application
    Source:        MSExchangeIMAP4
    Date:          27/08/2010 11:04:27 PM
    Event ID:      2101
    Task Category: (1)
    Level:         Error
    Keywords:      Classic
    User:          N/A
    Computer:      exchangeServer
    Description:
    Duplicate folders "Conversation Action Settings", "Quick Step Settings" were detected in the mailbox for user: userNAME. Therefore the user's connection was disconnected.
    User Action: To resolve this problem, the user should manually delete the duplicate folders by logging on to the mailbox using Outlook Web Access or a MAPI client such as Outlook.

    I was testing the IMAP connection using Outlook 2007 at that time.
    There are other errors for some other people as well with the following folders:
    "Conversation Action Settings", "Quick Step Settings", "RSS Feeds", "Suggested Contacts"

    How/where do I need to delete these folders?


    Andrew P.
    Monday, April 18, 2011 11:50 PM
  • Login onto the user's mailbox using OWA and deleted the four Folders.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Wednesday, April 27, 2011 9:44 AM
  • I log on through OWA but I can't find any folder named: "Conversation Action Settings" or "Quick Step Settings"

    could you tell me where exactly I can view them?


    Andrew P.
    Thursday, April 28, 2011 3:09 AM
  • You may be experiencing this scenario:

    This is likely caused by the end-users leaving their Outlook client open and checking their mail at the same time that their cell-phones are checking for new mail too.

    Here's what I have discovered so far and it's incredible this is still an issue. It MAY be partial to Outlook and the University of Washington's UW-IMAPd which is certainly not a small amount of installations. I've pasted the University of Washington's IT department's response to this issue (see below) and why/what's causing this.

    Can this be fixed??? If it's been fixed or there is an Outlook work around, I'd like to know please?

    I'm certainly exhausted at spending so many of my hours trying to correct and research this issue. If it's not fixed the only alternative for me is to recommend to my customers to NOT use Outlook where there is an (other than Exchange) IMAP server.

    ... Please help?! Thanks!

    Issue (1):

    Certain IMAP clients, including Outlook, have a tendency to open multiple
    IMAP sessions simultaneously to the same mailbox unless it is carefully
    configured (and used!) to avoid this.  The traditional UNIX mailbox format
    is not ameniable to multiple read-write sessions being open
    simultaneously, and each open of a mailbox in this format kills any
    previous session that is open on that mailbox.

    Issue (2):

    Certain IMAP clients, including Outlook, have a tendency to close the
    IMAP session without first issuing a proper LOGOUT command.  This causes a
    "Command stream end of file" in the logs from the IMAP server, which
    misleads people into believing that there is some server-based problem.

    Issue (3):

    Outlook and Outlook Express use the IMAP IDLE extension to go into a mode
    in which the client is alerted to new messages automatically without
    having to transmit a periodic NOOP to cycle the protocol (effectively
    polling the server).  This isn't surprising; Microsoft instigated the
    development of that extension.

    Unfortunately, Outlook and Outlook Express violate a part of the IDLE
    specification which requires that the client end the IDLE within 29
    minutes (and, if appropriate, issue a new IDLE), in order to renew the
    session and avoid the IMAP inactivity autologout which occurs at 30
    minutes of no activity from the client.

    Since Outlook and Outlook Express do not do anything to renew the session,
    it dies at the 30 minute autologout as per the specification.

    As noted above, clients that do not use IDLE typically send a NOOP every
    few minutes, which keeps the session active and avoids the autologout. So
    why not just disable IDLE in the server?  Unfortunately, disabling server
    support for the IDLE extension does not cause Outlook and Outlook Express
    to revert to the NOOP behavior; they just don't send anything at all.

    Microsoft acknowledged the problem in Outlook Express, but since Outlook
    Express is effectively a dead product it is unlikely that it will ever be
    fixed.  I don't know what the plans are to deal with this in Outlook.

    To summarize:

    The problems are entirely at the Outlook end.  The best way to get them
    resolved is to file problem reports with Microsoft.


    William A. Fink

    Wednesday, February 15, 2012 7:44 PM
  • This is pretty much a dead thread now.

    We eventually upgraded Exchange to 2010, and cleaning up lots of things as well.
    Also updated all clients to Outlook 2010 and everything seems to be fine.
    So the solution to my original post, I got none unfortunately.

    For those who have (had) this problem, anyone managed to resolve it?


    Andrew P.

    Wednesday, April 04, 2012 1:11 PM
  • @Will Fink:

    Yes there a solution to this problem but it's a pretty poor one.
    In Outlook go to the section where yo define send / receive groups and disable the scheduled check every X minutes, it 'fixes' the problem (as the imap connection is live) and you'll still get your mail.

    The issue however is that if you have users receiving very large emails every single time they click on the new email they need to wait for it to stream down (in my case, from gmail) which isn't that quick even with 20mbit ADSL2 - a 3 or 4mb email can really make Outlook feel sluggish.    (I admit they need to get the emails anyhow, however if the program is automatically doing it, often it may beat them while they are off browsing / using microsoft word / speaking with colleagues etc)   so the perception is distinctively slower as they are always starting from scratch when clicking on a new, large email (and small for that matter)

    Finally, from what reading I've done, it appears this is due to something called the "NOOP" command being sent by Outlook (you can't stop this) and eventually google gets sick of being hassled by the Outlook client.  (This isn't specific to google from what I can tell, it seems lots of imap servers have this issue with the noop command)

    So there you have it, it's bloody annoying and I can't find a solution to the problem.


    • Edited by scottylans Sunday, May 06, 2012 1:48 AM
    • Proposed as answer by ericwt Sunday, July 01, 2012 6:38 PM
    • Unproposed as answer by ericwt Sunday, July 01, 2012 6:38 PM
    Sunday, May 06, 2012 1:48 AM
  • I finally fixed this problem after two weeks. I noticed Outlook wasn't storing password and I couldn't access Managing Credentials from the User Account page in the control panel. After some reading I suspected I had a corrupted Win7 user profile. I created a new user account and the imap accounts were set up instantly without any flaws. And now my passwords are saved too!
    • Edited by ericwt Sunday, July 01, 2012 6:39 PM
    • Proposed as answer by ScottDAustin Tuesday, August 07, 2012 4:08 PM
    • Marked as answer by p.andrew Wednesday, August 15, 2012 8:01 AM
    Sunday, July 01, 2012 6:38 PM
  • I have been dealing with the same problem:

    UNAVAILABLE] Temporary System Error
        Protocol:    IMAP
        Server:    imap.gmail.com
        Port:    993
        Error Code:    0x800CCCDD

    The cause was probably the same as Eric's, though the conditions were slightly different. Specifically:

    Outlook was no longer storing the password for my Gmail accounts. I added the passwords back via Outlook 2010 Accounts setup, and the problem went away. It does not appear that my Windows user profile is corrupt. I did change my Windows user password recently, which may have contributed to the problem - I can't be sure that the IMAP problem surfaced at the same time. I am running a standalone machine - no domain or AD.

    To any Microsoft tech support or QA people - this is a BUG. There is some set of circumstances under which Outlook loses the password to the IMAP account and rather than prompting the user for the password, it throws the error above. If you manually edit the account and disable "save password", the user is (correctly) prompted for the password.

    Having already spent the better part of two days tracking this down, I'm not inclined to spend any more coming up with the exact repro steps. However, I'll add that this occurred for both of the gmail.com accounts in my Outlook profile, but NOT the aol.com account. All three accounts are setup for SSL on both IMAP & SMTP.

    Tuesday, August 07, 2012 4:08 PM