Error: Your request can't be completed right now. Please try again later.


  • I have MS Exchange 2007 - 2013 CU3 coexistence at two sites connected by VPN link. 

    OWA and Outlook work fine for mailboxes on 2007 server. OWA does not work for mailboxes on 2013 server, however Outlook connects fine to any mailbox on 2013 server.

    Here is what happens with OWA.

    Users (Moved from 2007 or Created on 2013) can log in to OWA and see their mailbox folder structure and messages, but when they click on any email they get "Error: Your request can't be completed right now. Please try again later. " instead of the message body. When they try to create a new message via OWA, GAL lookup does not seem to be working, everyone gets "Error: The message can't be sent because at least one recipient isn't valid."

    I can't see any errors in the application event viewer that get logged during OWA session.

    HTTP Log has the following error codes: 241,242,302,401,403,405,500.

    I am not sure at this point, but I think 405 is the HTTP error that can be associated with errors displayed in OWA

    date                         11/28/2013
    time                         18:01:02
    cs-method                POST
    cs-uri-stem               /owa/service.svc                           
    cs-uri-query              action=GetConversationItems&UA=0 
    s-port                       444 
    cs-username             DOMAIN\chukcha           
    cs(User-Agent)          Mozilla/5.0+(Windows+NT+6.3;+WOW64;+Trident/7.0;+rv:11.0)+like+Gecko
    cs(Referer)               https://EXCHANGE2013/owa/#path=/mail

    Any suggestions on troubleshooting this problem? 

    Thursday, November 28, 2013 6:25 PM


All replies

  • did some additional troubleshooting with network analyzer. the error message that gets logged in IIS logs is not what's being sent to the client.


    POST /owa/service.svc?action=GetConversationItems&UA=0 HTTP/1.1
    Accept: */*
    X-Requested-With: XMLHttpRequest
    Action: GetConversationItems
    Content-Type: application/json; charset=utf-8
    X-OWA-CANARY: X-OWA-CANARY_cookie_is_null_or_empty
    X-OWA-Attempt: 1
    X-OWA-ActionId: -57
    X-OWA-CorrelationId: 8515b843-9c69-4531-8674-f6b5e7809e9e_138566716478556
    X-OWA-ClientBegin: 2013-11-28T19:32:44.785
    Referer: https://EXCHANGE2013/owa/#path=/mail
    Accept-Language: en-US
    Accept-Encoding: gzip, deflate
    User-Agent: Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.1; WOW64; Trident/7.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; .NET4.0C)
    Host: EXCHANGE2013
    Content-Length: 1303
    Connection: Keep-Alive
    Cache-Control: no-cache
    Cookie: X-BackEndCookie .....................REMOVED..........................

    {"__type":"GetConversationItemsJsonRequest:#Exchange","Header":{"__type":"JsonRequestHeaders:#Exchange","RequestServerVersion":"Exchange2012","TimeZoneContext":{"__type":"TimeZoneContext:#Exchange","TimeZoneDefinition":{"__type":"TimeZoneDefinitionType:#Exchange","Id":"Eastern Standard Time"}}},"Body":{"__type":"GetConversationItemsRequest:#Exchange","Conversations":[{"__type":"ConversationRequestType:#Exchange","ConversationId":{"__type":"ItemId:#Exchange","Id":"AAQkADg1MTViODQzLTljNjktNDUzMS04Njc0LWY2YjVlNzgwOWU5ZQAQAHZFTFsN5EeHqAKB00zcFrs="},"SyncState":""}],"ItemShape":{"__type":"ItemResponseShape:#Exchange","BaseShape":"IdOnly","FilterHtmlContent":true,"BlockExternalImagesIfSenderUntrusted":true,"AddBlankTargetToLinks":true,"ClientSupportsIrm":true,"InlineImageUrlTemplate":"data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAEALAAAAAABAAEAAAIBTAA7","MaximumBodySize":2097152,"InlineImageUrlOnLoadTemplate":"InlineImageLoader.GetLoader().Load(this)","InlineImageCustomDataTemplate":"{id}"},"ShapeName":"ItemPartUniqueBody","SortOrder":"DateOrderDescending","MaxItemsToReturn":20,"FoldersToIgnore":[{"__type":"FolderId:#Exchange","ChangeKey":"AQAAAA==","Id":"AAMkADg1MTViODQzLTljNjktNDUzMS04Njc0LWY2YjVlNzgwOWU5ZQAuAAAAAABFVn93oA4MSKtu0usRdmN7AQClJKxCwbCpQq7y7C/rPhKtAAABXjCJAAA="}]}}


    HTTP/1.1 500 Internal Server Error
    Cache-Control: no-cache, no-store
    Pragma: no-cache
    Transfer-Encoding: chunked
    Content-Type: text/html; charset=utf-8
    Expires: -1
    Server: Microsoft-IIS/8.5
    request-id: 230bdffb-ae8f-4d6e-968f-8902b634cc36
    X-CalculatedBETarget: EXCHANGE2013.DOMAIN.local
    X-Content-Type-Options: nosniff
    X-OWA-Version: 15.0.775.32
    X-OWA-Error: Microsoft.Exchange.Data.Storage.TooManyObjectsOpenedException
    X-OWA-CorrelationId: 8515b843-9c69-4531-8674-f6b5e7809e9e_138566716478556
    X-OWA-ClientBegin: 2013-11-28T19:32:44.785
    X-FrontEnd-Begin: 2013-11-28T14:32:44.781
    X-BackEnd-Begin: 2013-11-28T14:32:44.784
    X-FrontEnd-Handler-Begin: 2013-11-28T14:32:44.782
    X-BackEnd-End: 2013-11-28T14:32:44.800
    X-DiagInfo: EXCHANGE2013
    X-BEServer: EXCHANGE2013
    X-UA-Compatible: IE=EmulateIE7
    X-AspNet-Version: 4.0.30319
    Set-Cookie: UC=8c348df144034474a37cbc553448fd87; path=/; secure; HttpOnly
    Set-Cookie: ...................REMOVED..........................
    expires=Thu, 28-Nov-2013 19:42:44 GMT; path=/owa; HttpOnly
    X-FrontEnd-End: 2013-11-28T14:32:44.801
    X-Powered-By: ASP.NET
    X-FEServer: EXCHANGE2013
    Date: Thu, 28 Nov 2013 19:32:44 GMT

    A problem occurred while you were trying to use your mailbox. 

    • Edited by net_tech Thursday, November 28, 2013 7:57 PM
    Thursday, November 28, 2013 7:54 PM
  • searching for Data.Storage.TooManyObjectsOpenedException error took me to this KB (written for Exchange 2010, and may not apply to exchange 2013 installation)

    I did have Event IDs:  9646 in my application event log earlier in the day so I added "Maximum Allowed Service Sessions Per User" and set its value to 32. Restarted exchange services but still could not access mailboxes on 2013 server via OWA

    Thursday, November 28, 2013 8:30 PM
  • Hello,

    I recommend you use Get-throttlingpolicy | fl cmdlet to verify OWAMaxConcurrency value. And please use Set-ThrottlingPolicy cmdlet to set proper value for OWAMaxConcurrency.

    Here is the article for your reference.

    If you have any feedback on our support, please click here

    Cara Chen
    TechNet Community Support

    Friday, November 29, 2013 7:25 AM
  • OwaMaxConcurrency         : 20
    Friday, November 29, 2013 11:02 AM
  • I must have been misdirected by HTTP/1.1 500 Internal Server Error.

    405 is the error thrown to the OWA client by the server, below is the RAW output of the error message which gets translated by OWA as "Error: Your request can't be completed right now. Please try again later."

    HTTP/1.1 405 Method Not Allowed
    Cache-Control: private
    Content-Type: text/html
    Server: Microsoft-IIS/8.5
    request-id: 6b914c43-fa70-442d-a615-2c554cba4c6c
    X-CalculatedBETarget: EXCHANGE2013.DOMAIN.local
    X-Content-Type-Options: nosniff
    X-OWA-Version: 15.0.775.32
    X-OWA-CorrelationId: 8515b843-9c69-4531-8674-f6b5e7809e9e_138572893830234
    X-OWA-ClientBegin: 2013-11-29T12:42:18.302
    X-FrontEnd-Begin: 2013-11-29T07:42:18.331
    X-BackEnd-Begin: 2013-11-29T07:42:18.334
    X-FrontEnd-Handler-Begin: 2013-11-29T07:42:18.332
    X-BackEnd-End: 2013-11-29T07:42:18.335
    X-DiagInfo: EXCHANGE2013
    X-BEServer: EXCHANGE2013
    X-UA-Compatible: IE=EmulateIE7
    X-AspNet-Version: 4.0.30319
    Set-Cookie: X-BackEndCookie=S-1-5-21-2861966845-1785306919-463784245-1126=u56Lnp2ejJqBycebyM7LmpzSx5zMm9LLzpuc0sfGy8zSy8zPnZnNz5vHycadgYHOztDNxtDNz87M387NxcrNxc7H; expires=Fri, 29-Nov-2013 12:52:18 GMT; path=/owa; secure; HttpOnly
    X-FrontEnd-End: 2013-11-29T07:42:18.336
    X-Powered-By: ASP.NET
    X-FEServer: EXCHANGE2013
    Date: Fri, 29 Nov 2013 12:42:18 GMT
    Content-Length: 1293

    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "">
    <html xmlns="">
    <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1"/>
    <title>405 - HTTP verb used to access this page is not allowed.</title>
    <style type="text/css">
    body{margin:0;font-size:.7em;font-family:Verdana, Arial, Helvetica, sans-serif;background:#EEEEEE;}
    fieldset{padding:0 15px 10px 15px;}
    h3{font-size:1.2em;margin:10px 0 0 0;color:#000000;}
    #header{width:96%;margin:0 0 0 0;padding:6px 2% 6px 2%;font-family:"trebuchet MS", Verdana, sans-serif;color:#FFF;
    #content{margin:0 0 0 2%;;}
    <div id="header"><h1>Server Error</h1></div>
    <div id="content">
     <div class="content-container"><fieldset>
      <h2>405 - HTTP verb used to access this page is not allowed.</h2>
      <h3>The page you are looking for cannot be displayed because an invalid method (HTTP verb) was used to attempt access.</h3>

    Friday, November 29, 2013 12:50 PM
  • same issue on an older version of exchange

    following the steps provided by the poster in the thread above didn't fix my 405 error.

    I also had "The parameter NTAuthenticationProviders is not set at this node"

    • Edited by net_tech Friday, November 29, 2013 1:33 PM
    Friday, November 29, 2013 12:57 PM
  • activesync works fine for mailboxes on 2013 server, the issue seems to be only affecting OWA
    Saturday, November 30, 2013 5:15 PM
  • Hoping there is an easier way to resolve this issue than recovery install as suggested here

    Monday, December 02, 2013 5:43 PM
  • Hello,

    Before you recover installation, please check if Exchange 2013 Prerequisites are ok.

    Please try to recreate owa virtual directory to check the result.

    If you have any feedback on our support, please click here

    Cara Chen
    TechNet Community Support

    • Marked as answer by net_tech Wednesday, December 04, 2013 3:58 PM
    Tuesday, December 03, 2013 7:10 AM
  • I ran Get-WindowsFeatures  and compared it to the list of features needed, some of the prerequisites were missing.

    Running PS scripts as indicated in the tech net article resolved my problem.

    Wednesday, December 04, 2013 4:03 PM