none
Autodiscover working in Outlook but not ActiveSync

    Question

  • Autodiscover passes all tests on testexchageconnectivity.com. It works when I am setting up Outlook 2007/2010 clients. It does not work when adding an account on an iPhone. If I manually enter the server address, everything works great. The point is, I'd rather my users not have to ask what our server name is, it should work automatically.

    CAS server has ActiveSync InternalURL listed as https://exch2010.mydomain.local/Microsoft-Server-ActiveSync

    ExternalURL listed as https://mail.mydomain.org/Microsoft-Server-ActiveSync

    Where do I go? Thanks.

    Wednesday, April 11, 2012 8:15 PM

Answers

All replies

  • Can you post the results?

    Also, is the iPhone running the latest firmware/ios?

    What if you test with a windows phone if one is available or another smartphone/iPAD?


    Sukh

    Wednesday, April 11, 2012 8:46 PM
  • iPad is the same issue - I don't have another smartphone to test with at the moment.


    • Edited by thekenney Friday, April 13, 2012 3:41 AM
    Wednesday, April 11, 2012 8:51 PM
  • Do the device logs say anything?

    Also check the IIS logs


    Sukh

    Wednesday, April 11, 2012 9:15 PM
  • The following is logged in IIS logs when attempting to autodiscover from iPhone....

    2012-04-11 21:18:36  POST /Autodiscover/Autodiscover.xml - 443 username Apple-iPhone3C1/902.176 401 1 1326 124
    2012-04-11 21:18:38  POST /Autodiscover/Autodiscover.xml - 443 username Apple-iPhone3C1/902.176 401 1 1326 124
    2012-04-11 21:18:38  POST /Autodiscover/Autodiscover.xml - 80 - Apple-iPhone3C1/902.176 401 0 0 124
    2012-04-11 21:18:38  POST /Autodiscover/Autodiscover.xml - 80 - Apple-iPhone3C1/902.176 401 0 0 124

    I don't get an error or anything from the iPhone, it just prompts for manual entry of the server address.


    • Edited by thekenney Friday, April 13, 2012 3:44 AM
    Wednesday, April 11, 2012 9:26 PM
  • Your email addresses are @thekenney.org I assume?
    Wednesday, April 11, 2012 9:33 PM
  • You're getting a 401 0 0 124

    That dont look right, check vdir config, also are you ussing 443 or 80?

    Are you publishing activesync or direct connection to Exch?


    Sukh

    Wednesday, April 11, 2012 9:39 PM
  • How would I check that?
    Wednesday, April 11, 2012 9:48 PM
  • My settings match those on the previous link you've posted.
    Wednesday, April 11, 2012 10:02 PM
  • Do the same test again where you enter the server details manually and check the IIS logs.


    Sukh

    Wednesday, April 11, 2012 10:50 PM
  • Do you have an  option not to use SSL on the iphone?

    Or when manually specifying the server details do you use SSL or not?


    Sukh

    Wednesday, April 11, 2012 11:20 PM
  • The option to use SSL comes after this step, so isn't relevant. When manually specifying the server, I just put mail.domain.com. Nothing relating to SSL is even presented.
    Wednesday, April 11, 2012 11:33 PM
  • You get a 403 4 which says SSL is required.  The connections seems to have come from port 80

    Can you confirm your ActiveSync External URL, go to EMC>Server Config>Client Access>Exch ActiveSync Tab>External URL?

    Also, go to IIS >Sites>Default Web Site>Autodiscover and check  the SSL settings set here


    Sukh

    Thursday, April 12, 2012 8:11 AM
  • Update! If I specify the domain in the user account, autodiscovery works fine. Domain is an optional field though and for the ease of my users, I'd like to keep this as not required. IIS is rejecting the credentials as no domain is specified. I looked at the Microsoft-Server-ActiveSync Authentication settings in IIS and basic authentication is enabled. Our domain is listed as the default domain and realm is empty. What should I change to get this working?
    Thursday, April 12, 2012 8:36 PM
  • Hi thekenny,

    Buddy i will suggest you please hide your servername and Ip address before posting on technet... It is not a good to share server information on internet.

    1) In iPhone just set your CAS server name to connect Active sync and yes please enable Active sync service for respective mailbox.

    2) Enable SSL on iphone setting.

    3) May i know which verison of iPhone are you using.


    Amit Rawat | MCITP - Exchange 2007/2010| CCNA |MCSE- 2003| Lync 2010|

    Thursday, April 12, 2012 11:58 PM
  • What if you try and use upn as username and test?

    Sukh

    Friday, April 13, 2012 8:56 AM
  • UPN as the username will get autodiscovery working, because it is the same as filling in the optional domain field, but shouldn't be necessary. Our domain is listed in the ActiveSync authentication settings, so it should be carried over. Something is still off.
    Friday, April 13, 2012 5:43 PM
  • I know you can do this with OWA, but I'm not too sure this is possible with activesync without using the UPN.

    Sukh

    Saturday, April 14, 2012 10:46 AM
  • Update! If I specify the domain in the user account, autodiscovery works fine. Domain is an optional field though and for the ease of my users, I'd like to keep this as not required. IIS is rejecting the credentials as no domain is specified. I looked at the Microsoft-Server-ActiveSync Authentication settings in IIS and basic authentication is enabled. Our domain is listed as the default domain and realm is empty. What should I change to get this working?

    Hi,
    In what format (Netbios or FQDN) did you configure the default domain?

    I just configured the same the other week using the Netbios name and that worked just fine. Since then Iphone users doesn't need to add the domain when configure EAS.


    Martina Miskovic

    Saturday, April 14, 2012 12:19 PM
  • Sukh828, It is possible without the UPN. I've seen this done before on Exchange 2010.

    Martina_Miskovic, The domain is specified in the Netbios format. 

    Monday, April 16, 2012 4:40 PM
  • On your deployment you've seen or another deployment?

    I can't find a way to do this and I've never seen this for ActiveSync as mentioned before.


    Sukh

    Tuesday, April 17, 2012 6:45 PM
  • Monday, July 02, 2012 7:20 PM