none
Outlook 2007 - Permission error when trying to access shared calendar

    General discussion

  • Hi All,

    I've spent some time troubleshooting an issue with Outlook 2007 and shared calendars. In the end I called premier support who resolved the issue so I thought I would share my findings in an effort to help someone else that might come across the same issue.

    I'm running Exchange 2007 SP3 RU2 with a mix of Outlook 2007 and Outlook 2010 clients. I had a couple of users on Outlook 2007 complaining they were getting a warning when trying to access shared calendars. All of the shared calendars have been configured so the "default" user’s permission is set to “reviewer” (right click the calendar > permissions > Name “Default” > Permission = reviewer). This allows our users to open the calendar and view all of the appointments for that shared resource. I normally do this using my Outlook 2010 client.

    When the users that had an Outlook 2007 client opened a shared calendar, they were getting a pop-up message from the Outlook icon in the system tray, "You do not have sufficient permission to perform this operation on this object. See the folder contact or your system administrator".

    Also, when users tried to open the appointment (double click) using their Outlook 2007 client, they would get the following message, "Cannot open this item. Cannot open the free/busy information. You do not have sufficient permissions to perform this operation on this object. See the folder contact or your system administrator".

    However, if the calendar was opened in Outlook 2010 it would work fine, no errors.

    Credit has to go to my good mate Barry Xie, the Microsoft support engineer, for this fix. Barry has helped me in the past and is great to work with and more importantly knows his Exchange/Outlook.

    It turns out the problem was due to the "default" permissions being set using Outlook 2010. This, for whatever reason, was causing the errors with the Outlook 2007 clients. Once I modified the "default" permissions using Outlook 2007, no more errors.

    So the fix to the problem is to modify the calendar permissions using the lowest versioned client, in this case Outlook 2007.

    • Changed type 1ill Thursday, March 10, 2011 3:30 AM
    Thursday, March 10, 2011 3:29 AM

All replies

  • I'd just like to say thanks for sharing this, i've been having issues with this for a few weeks and it's been driving me nuts!!

    Funny how something so simple can be the cause.

     

    Thanks again!!

    Tuesday, October 04, 2011 1:54 PM
  • Thank you for sharing this, it also saved me time to resolve the issue. I mention that changing the permissions with a OL 2003 client also works. Regards.
    Friday, January 20, 2012 2:47 PM
  • It turns out the problem was due to the "default" permissions being set using Outlook 2010. This, for whatever reason, was causing the errors with the Outlook 2007 clients. Once I modified the "default" permissions using Outlook 2007, no more errors.

    So the fix to the problem is to modify the calendar permissions using the lowest versioned client, in this case Outlook 2007.

    The reason behind this is simply that the new presets available to you in Outlook 2010 are not presets or settings recognized by older versions.

    For example, Outlook 2010 has the option to share with somebody "Free/Busy time, subject, location" whereas it should be set to "Reviewer" for somebody using Outlook 2007 or earlier.

    Thanks for pointing me in the right direction.

    Friday, March 09, 2012 9:10 PM
  • Thank you for sharing this!
    Friday, March 16, 2012 12:46 PM
  • I Have Exchange 2007 on SBS 2008

    Hi,  the solution you have described here do not work for me.  The appointments is visible only if Read permission is set to "Full details". No matter if set in Outlook 2007 or Outlook 2010. If Read permission is set to "Free/Busy time" or "Free/Busy time, subject, location" the apointmenst is not visible an error "You do not have sufficient permisions..." appears. I think it has something with "Availability service", but dont know how to check or troubleshoot  communication between outlookk and Exchange and Availability service.

    Do you have another solution ?

    Thank You

    Lubos Madera

    Friday, May 18, 2012 8:27 AM
  • Same Issue as Lubos M

    Have converted to Exchange 2013

    Clients are Outlook 2007

    Single Exchange Server ( Simple Deployment )

    Only way so far to get it wot work is to set Default permissions to the highest level permission needed.

    Whatever the Permission is set to as default is the only permission available - Regardless of the permission of the individual user added to the calendar.

    Also Adding any user other than Default and clicking OK causes " An Error Occured when setting schedule Permissions.

    Having only "Default" Set is the only way to not get an error when clicking OK




    Wednesday, May 08, 2013 4:59 PM
  • I found another workaround I did it on my colleague's computer and it seems to work.

    He has Outlook 2007, had trouble installing calendars shared by outlook 2010 users.

    I installed the calendar (accepted the invitation) using Outlook web app. Now it seems to work in Outlook 2007.

    Wednesday, June 26, 2013 7:58 PM
  • I exactly had the same strange issue.
    Moving the mailbox containing the shared calendar to a different mailbox-database fixed the problem for me.

    Tuesday, August 20, 2013 12:19 PM