none
Outlook 2003 OAB error 0x8004010F after migrated to Exchange 2010

    Question

  • Hi,

    We are in progress to migrate Exchange 2003 SP2 to Exchange 2010 SP1 in a mixed client environment, got Outlook 2003,2007 and 2010. After moved a few mailboxes onto the new Exchange 2010 servers. Those moved users who use Outlook 2003 complained they got 0x8004010F error when click Send/Receive. Outlook 2010 and 2007 users are fine without issue.

    I checked the permission settings on OAB Versioin X folders. The client permission is set as: Default - Reviewer; Anonymous - None. Not sure if this is the problem? I guess it should have nothing to do with Administrative Rights?

    In addition, I checked folder C:\Program Files\Microsoft\Exchange Server\V14\ClientAccess\OAB, there is nothing in it! Isn't there should be a OAB created? I checked Public Folder replications in Exchange 2003 and 2010. Can see both server in the replication list... And it should be replicated already, as I can use my domain admin account from Outlook 2003 without issue...

    I am puzzled, any help will be appreciated.

    • Edited by aha_tom Monday, January 10, 2011 9:08 AM
    Friday, January 07, 2011 8:15 AM

Answers

  • Well, finally find the answer here: http://support.microsoft.com/kb/905813. The issue is fixed simply by add the OAB list in the mailbox database properties Client Settings.

    I have been working on the problem for a while, so if you got same error but my fix is not working for you, reply and I will try to help...

    • Marked as answer by aha_tom Monday, January 10, 2011 10:03 PM
    Monday, January 10, 2011 10:03 PM

All replies

  • Just updated this case. The guid folders under C:\Program Files\Microsoft\Exchange Server\V14\ClientAccess\OAB have been created after I added Authenticated Users into the ACL and give read permissions... However, Outlook 2003 users still receive 0x8004010F errors! Unless the user belongs to Domain Admins group... Out Of Office and Free/Busy information works fine in Outlook 2003, which I belive means Public Folder has been replicated successfully onto the new Exchange 2010 server... Tried with different Exchange 2010 users... Still no luck with OAB on Outlook 2003... I am desperate... although everything is actually working...

    Monday, January 10, 2011 5:20 AM
  • Another update, further tests indicate admin users have the same issue... So basically all users migrated onto Exchange 2010 with Outlook 2003 will have this error...

    Monday, January 10, 2011 9:03 AM
  • Well, finally find the answer here: http://support.microsoft.com/kb/905813. The issue is fixed simply by add the OAB list in the mailbox database properties Client Settings.

    I have been working on the problem for a while, so if you got same error but my fix is not working for you, reply and I will try to help...

    • Marked as answer by aha_tom Monday, January 10, 2011 10:03 PM
    Monday, January 10, 2011 10:03 PM
  • I have this issue, Only Domain Admins work.

    However, if the user is connected to the domain, they work. If they are running windows in workgroup mode, they do not work.

    I have also noticed that if I create a new user, with a new mail box, Outlook 2010 works the way it should. (Domain and Workgroup)

    In my case, it seems to be related to existing users.

    Ive tried resetting Outlook profiles, changing security on IIS7, jumping through hoops and praying to the Exchange gods. But I have given up on this.

     

     

     

     

    Tuesday, January 11, 2011 4:40 PM
  • Which version of Exchange you running? If Exchange 2007/2010 no need to worry about Public Folders, more like a Autodiscover issue. If that's the case try add your Exchange's IP into hosts file and point it to autodiscover.yourdomain.com ( e.g. your primary email address is username@yourdomain.com)

    By default, when use Outlook 2007/2010 inside the domain, it will look for autodiscover info from your server local address like servername.yourdomain.local as specified by set-webServiceVirtualDirectory, set-clientaccessServer. When outside the domain, it will look for autodiscover info from this address: autodiscover.yourdomain.com instead.

    Tuesday, January 11, 2011 10:26 PM
  • @aha_tom

    (Exchange 2010 sp1)

    Ive done all that, trust me, Ive tried EVERYTHING... I have given up. 

    My autodiscover works just fine, the settings are dead on, internal and external. DNS Svr is perfect, all tests internal and external work, Outlook 2010 "Test Email Autoconfiguration" Shows all the right addresses. 

     

    This issue happens with Outlook 2007/2010, logging in as existing domain users outside of the domain only.

     

    New domain users work, existing domain admins work (Or I move an existing user to admin and that will work) . 

     

    This was a migration from Exchange 2003, that server has been removed from the domain. The migration went very smooth, I had no issues at all. Of course when I was testing the laptops, I was using my Account which is a Domain Admin account, so naturally (Silly me) I assumed all workgroup PC's would work. 

    now Im going to sacrifice a chicken and see if that helps.... 

    im joking, but still, although all mail is delivered to all users, and they can send mail, it is annoying to have the OAB fail and the OOF fail.

     

    oooyyyy.

     

    Tuesday, January 11, 2011 10:47 PM
  • Hi,

    Did you try this: turn on Outlook Anywhere for all those users sit outside the domain... at least this is one option?

    Wednesday, January 12, 2011 12:23 AM
  • Yup, infact, some users have give'n up on Outlook and use Outlook Anywhere exclusively.

     

    But thats not the point, Exchange 2010 with the new office 2010 software for 50 people cost our company a fortune. I had to fight tooth and nail to get these upgrades. It would be nice to use these products as advertised. 

     

     

     

    Wednesday, January 12, 2011 5:05 PM
  • Did anyone every get a good answer to this. I have the same issue aftermigration. Everything except the oab works great?
    BOCHCO
    • Proposed as answer by Josh Fernando Saturday, April 02, 2011 9:21 AM
    • Unproposed as answer by Josh Fernando Saturday, April 02, 2011 9:21 AM
    Tuesday, March 01, 2011 6:42 PM
  • Hi Guys,

     

    Kindly post the event id 27

    on CAS server, open exchange mangement shell  run update-filedistributionservices

    try to create new OAB

    in MBX, OAB will update daily morning 5:00 am(by default)

    in Cas server,OAB will update every 8 hours (polling interval=480 minutes)

    * manually update OAB (update content)

    * restart the file distribution service on the CAS server

    * create new profile in the outlook

    * download OAB


    Thanks Joseph Pradeep
    Saturday, April 02, 2011 9:27 AM
  • Hi, I have the same problem on a coexistence between Exchange 2003 and 2010.

    Everything work well... Only Outlook 2003 system cannot download OAB..!!! Outlook 2010 and 2007 work fine.

    I have read all Microsoft official document without any success.

    Now I can try to create a new outlook profile.

    Luca


    Luca Targa Vecomp Software
    Tuesday, June 28, 2011 2:23 PM
  • Sorry, the info isn't clear.  None of the methods match up with anything in MS Outlook 2003.  Is this something that the service provider (exchange server 2010) needs to do?  Thank you.

    Friday, July 08, 2011 5:46 PM
  • Anybody found an answer to this issue yet please???
    Monday, October 17, 2011 1:53 PM
  • http://support.microsoft.com/kb/905813

    Note that in exchange 2010 this is under organization not server configuration

    Also on the client I deleted the existing outlook OAB files before I fixed the server.(XP-local settings/app data/microsoft/outlook -just don't delete any ost or pst files but everything else can go)

    I then restarted system attendant service just to be sure the changes took affect.

    Tried outlook again with no error messages in sync center folders.

    Wednesday, October 19, 2011 8:58 PM

  • Hi,

    This is my solution inspired from the tutorial of Coop888 to solve the error 0x8004010F message with Outlook 2003 and Windows XP after have migrated Exchange 2003 to Exchange 2010.

    1 - Disable Outlook cache and stop Outlook (because during the migration, some mail can't be present in the Outlook client)

    2 - Delete all files except *. NK2 from the folder %userprofile%\Application Data\Microsoft\Outlook

    3 - Delete the *. OST file cache from the folder %userprofile%\Local Settings\Application Data\Microsoft\Outlook

    4 - Re-enable the cache and start Outlook.

    Tancks All for your Help

    By


    Cristophe
    Tuesday, December 20, 2011 1:29 PM
  • Cristophe.M

    I have tried the instructions you provided along with pretty much doing everything else listed in this thread and I am still having the same problem. This one has been a thorn in my side for the past 3 days. Luckily I am only in a test environment Server 2012, Exchange 2010, Outlook 2003 clients. Does anyone else have any recommendations?

    Thursday, February 21, 2013 6:51 PM