none
Send on behalf of

    Question

  • Hi everyone

    I have a mail-enabled distribution group we'll call DL@company.ca.  It has 4-5 members in it including myself and a few others.

    Currently I am able to send as this distribution group but other members are not.  I've run the "Set-DistributionGroup -Identity DL -GrandSendOnBehalfTo username" which allowed the user in question to then send on behalf of, but I want send as, not on behalf of.

    So I googled a little more and then ran "Add-ADPermission dl -extendedrights send-as -user username" which returned False for both Deny and Inherited which I think is good?

    However, in sending more test messages, they are still on behalf of.  Do I need to remove the Set-Distribution before I will Send as instead of Behalf of?  If so, how do I do that?  If not, how do I fix this?

    Thanks!  I'm still rummaging through the forums and Google but haven't found the solution yet.

    Ryan

    Thursday, June 14, 2012 2:04 PM

Answers

All replies

  • Hi

    Here is an article for setting up send as permissions:

    http://technet.microsoft.com/en-us/library/bb676368.aspx

    • Marked as answer by primo_ Thursday, June 14, 2012 2:16 PM
    Thursday, June 14, 2012 2:09 PM
  • Thanks for the response but unfortunately I've already run the Add-ADPermission command and I am still sending on behalf of.  Do I need to reverse the Set-Distribution command first?  If so, how do I do that?

    I checked in ADUC and in the security properties of the distribution group the user in question who is sending on behalf of, not send as, does have the permission to send as... but her emails are still going on behalf of.

    Does anyone have a solution for this?

    EDIT:  Rookie move 101.. I didn't log off and on.  It works with the Add-ADPermission.


    • Edited by primo_ Thursday, June 14, 2012 2:16 PM
    Thursday, June 14, 2012 2:14 PM