none
503 Valid RCPT command must precede DATA

    Question

  • I have Windows XP Pro Service pack 3 and Outlook 2007 SP2

    I am recieving this error message 503 Valid RCPT command must precede DATA when sending E mails to a specific company. E-mails sent to an individual address or to generic Sales@ get the same response.

    I have checked the web and done the following already.

    Under Internet E Mail Settings I have set My out going server (SMTP) requires authentication and tried both the Use the same settings as my incoming mail server and Log on to an incoming mail server before sending mail.  Both these configuations work with Test E Mail Settings and I get the Microsoft Test message back.

    I have renamed outlook.nk2 as outlooknk2.old, as yet Outlook has not generated a new NK2 file.

    I have generated a contacts entry for one of the people at the company and this fails the same as typing in the E Mail address.

    I have tried sending plain E Mails and E mails with attachements and both fail.

    I can send plain E Mails and E mails with attachements to addresses that are not this company.

    I am not sure if the problem is my end, at the ISP ( DEMON.NET) or at the company end. Has any one any ideas where to start?

     

    Tuesday, November 16, 2010 10:59 AM

Answers

  • If you ever encounter this error then this means you must check your email before trying to send mail meaning that our mail server requires authentication, which can be achieved using one of these methods: 

    A) Pop before smtp -- check your email for new mail before trying to send email. This adds your IP address to a relayhosts file and allows any email to be sent from that IP address for up to 30 minutes. After 30 minutes you have to authenticate again. 

    B) Configure your email client to authenticate automatically by checking the "my server requires authentication" box in your email configuration. You will be able to send mail without having to "pop" your mail box first. 

    If using MS Outlook, please try the following: 

    1) Open outlook 
    2) Go to Tools/Email Accounts 
    3) Select the Account with the trouble and click Change 
    4) Click on More Settings 
    5) Click on Outgoing Server Tab 
    6) Click "Outgoing Mail Server (SMTP) requires authentication" and make sure "Use same settings as incoming mail server" is selected (see attached image) 
    7) Click on "Advanced Tab" 
    8) Set outgoing Port (SMTP) to 26 (if your hosting account is Linux) or 587 if your hosting account is Windows. 
    9) Click Ok and then Test Account Settings 

    If it fails on send then repeat starting from 7. 

    7) Click on Advanced Tab 
    8) Set outgoing Port (SMTP) to 465 (See attached) 
    9) Check the box Beside "The server requires an encrypted connection (SSL)". 
    10 ) Click ok and then Test Account Settings 

    Ripu Daman Mina | MCSE 2003 & MCSA Messaging
    • Marked as answer by deltathree Friday, November 26, 2010 2:35 AM
    Tuesday, November 16, 2010 12:27 PM

All replies

  • If you ever encounter this error then this means you must check your email before trying to send mail meaning that our mail server requires authentication, which can be achieved using one of these methods: 

    A) Pop before smtp -- check your email for new mail before trying to send email. This adds your IP address to a relayhosts file and allows any email to be sent from that IP address for up to 30 minutes. After 30 minutes you have to authenticate again. 

    B) Configure your email client to authenticate automatically by checking the "my server requires authentication" box in your email configuration. You will be able to send mail without having to "pop" your mail box first. 

    If using MS Outlook, please try the following: 

    1) Open outlook 
    2) Go to Tools/Email Accounts 
    3) Select the Account with the trouble and click Change 
    4) Click on More Settings 
    5) Click on Outgoing Server Tab 
    6) Click "Outgoing Mail Server (SMTP) requires authentication" and make sure "Use same settings as incoming mail server" is selected (see attached image) 
    7) Click on "Advanced Tab" 
    8) Set outgoing Port (SMTP) to 26 (if your hosting account is Linux) or 587 if your hosting account is Windows. 
    9) Click Ok and then Test Account Settings 

    If it fails on send then repeat starting from 7. 

    7) Click on Advanced Tab 
    8) Set outgoing Port (SMTP) to 465 (See attached) 
    9) Check the box Beside "The server requires an encrypted connection (SSL)". 
    10 ) Click ok and then Test Account Settings 

    Ripu Daman Mina | MCSE 2003 & MCSA Messaging
    • Marked as answer by deltathree Friday, November 26, 2010 2:35 AM
    Tuesday, November 16, 2010 12:27 PM
  • Dear,

     

    The message mains you must authenticate to the server before sending.  So please check the authentication options in the Account Settings.

    Thursday, November 18, 2010 5:59 AM