none
Outlook 2007 using exchange 2007 free busy does not show

    Question

  •  

    Free busy data is NOT showing up when going into outlook 2007 and trying to view other user schedules via Scheduling assistant.  Other user schedules are simply hashmarks, and says no free/busy informaiton could be retrieved.  Logging onto OWA 2007, the free busy data shows up.

     

    What is going on here?

    I'm thinking the availability service must be ok if it shows in owa, unless the mechanism for outlook 2007 is different to retrieve this?

    Wednesday, October 17, 2007 5:55 PM

All replies

  • Same problem.  I upgraded my Outlook client from Outlook 2003, to Outlook 2007 yesterday.  Now I can no longer retrieve free/busy time.  I can log into OWA and see free/busy time.  I have one other user on Outlook 2007, and they can see free/busy time.  However they were a fresh install, not an upgrade.

     

     

    Thursday, October 18, 2007 4:05 PM
  • Have you run ExBPA? Could outlook somehow not have access to the CAS server in question? Do you have multiple CAS servers?

    Thursday, October 18, 2007 6:32 PM
  • A little more info- the free/busy used to work up untill a few days ago.

     

    Ran Best Practices Analyzer Health and connectivity on a mailbox server and on our one and only CAS server.  Health check is showing OK, and the connectivity sees all the servers.  The CAS server is also our Hub/transport, so all mail flows through it to the mailbox servers too.

     

    Why wouldn't outlook be able to access the CAS server?  How can I check this? 

    • Proposed as answer by rajabba Wednesday, July 20, 2011 6:12 PM
    • Unproposed as answer by rajabba Wednesday, July 20, 2011 6:13 PM
    Friday, October 19, 2007 3:18 PM
  • Your not synchronizing free/busy with Exchange 2003 are you?

     

     

    Also, if you ctrl+click the outlook icon and select

    'test email autodiscover' it'll test your CAS settings, certs etc. Its not a free/busy test but it did show me on one occasion that i had a cert issue causing free/busy issues.

    Friday, October 19, 2007 3:46 PM
  • crtl click (left) opens outlook in safe mode.  I see no option to "test email autodiscover"  Synchronizing with 2003?  I don't know what you mean- we do have some mailboxes on one 2003 server. 

    Monday, October 22, 2007 9:36 PM
  • Sorry, i meant the outlook icon in the task tray when outlook is open, not the app launch icon. I should have been more specific.

     

    Monday, October 22, 2007 9:39 PM
  •  

    OK, the test for autodiscover failed.  But I don't get what this has to do with the free/busy information?  Is free/busy published through autodiscover.mydomain.edu or something?
    Tuesday, October 23, 2007 8:20 PM
  • This indicates a problem with your CAS configuration. Autodiscover and availability services both run from the CAS. What was the nature of the error? That'll clue us to whats wrong with CAS.

     

     

    Also, have you also run

    Get-AvailabilityConfig

     

     

    to make sure all your settings are right?

    Tuesday, October 23, 2007 8:25 PM
  •  

    Scratch my last entry- the test DID work, after I plugged my network cable back in.  Stick out tongue 

     

    But free/busy still doesn't show up. 

     

    Testing on the CAS server gives:

     


     


    Id      : 1003
    Type    : Information
    Message : About to test AutoDiscover with the e-mail address myname@mydomain.edu
              .

    Id      : 1013
    Type    : Error
    Message : When contacting https://outsidename.mydomain.edu/autodiscover/autodiscover.xml
               received the error Unable to connect to the remote server

    Id      : 1013
    Type    : Error
    Message : When contacting https://outsidename.mydomain.edu/autodiscover/autodiscover.xml
               received the error A connection attempt failed because the connected
               party did not properly respond after a period of time, or establishe
              d connection failed because connected host has failed to respond

    Id      : 1006
    Type    : Error
    Message : Failed to contact AutoDiscover

     

    Also, navigating to the url https://outsidename.mydomain.edu/autodiscover/autodiscover.xml in IE forces me to login through ISA- not sure if this could be causing a problem?

    Tuesday, October 23, 2007 8:29 PM
  • I have the same problem, just upgraded to Outlook 2007 as free/busy not available when previously under outlook 2003 it was.  Autodiscover results return no errors.

     

    We are synchronising free/busy with our exchange 2003, is this the cause of my problem?

     

    Cheers..

    Tuesday, January 29, 2008 1:27 AM
  •  Simkey wrote:

    I have the same problem, just upgraded to Outlook 2007 as free/busy not available when previously under outlook 2003 it was.  Autodiscover results return no errors.

     

    We are synchronising free/busy with our exchange 2003, is this the cause of my problem?

     

    Cheers..

     

    I'm having the same issue with outlook 2007 and exchange 2007... cant find a solution.

    Wednesday, March 05, 2008 5:10 PM
  • Did you find a resolution? I am having the same problem.

     

    Could it be to do with the following stated in the MS doc:

     

    "Depending on whether you have configured the Autodiscover service on a separate site, the Autodiscover service URL will be either https://<smtp-address-domain>/autodiscover/autodiscover.xml or https://autodiscover.<smtp-address-domain>/autodiscover/autodiscover.xml."

    (http://technet.microsoft.com/en-us/library/aa995956(EXCHG.80).aspx)

    (see also http://technet.microsoft.com/en-us/library/bb201695.aspx)

     

    We are hosting several email domains, but have only the default autodiscover service setup.

     

    We host email for "company1.com.au", "company2.com.au", etc, but our internal and external names are completely different to these client companies. We use exchange for http access only. The email processing is fine, and we've managed to get the GALs working properly, but I wonder if we need to set up an autodiscover virtual site for each email domain we host?

     

    Any thoughts anyone?

    Thanks.

    Wednesday, April 30, 2008 10:42 PM
  • I believe I am having the same issue but not sure.  We have Exchange 2007 using Outlok 2003.  I am now testing Vista and Office 2007.  In Outlook 2003 you can view group schedules no problem.  But when I open my Outlook 2007 I can't see anyone's information except my own.  Everyone else's information shows as hash marks which the legend says means "No Information" but I know there is information as I can open my Outlook 2003 and see their information.

     

    When we setup Exchange 2007 we didn't have anyone using Office 2007, so I am wondering if there is a setting in Exchange 2007 we need to enable.

     

    Anyone have any ideas?

     

    Barry

    Tuesday, June 10, 2008 1:47 PM
  • Hi,

    we have the exact same issue. No one is able to see free/busy information when upgraded to Outlook 2007.

    Outlook 2003 work with the Free/Busy information / Group Schedules. While Outlook 2007 does not work.

    Have anyone found out a solution to this issue?

    (We are running Exchange 2007 and Exchange 2003)

    (After posting i found this article: http://www.networkworld.com/community/node/17227 )

    It seems to fix it on my computer, and i will try running the regkey add through loginscript to fix the issue.
    Monday, September 01, 2008 8:04 AM
  • We had the same problem and the solution in the previous post (http://www.networkworld.com/community/node/17227) seemed to help us too.
    Tuesday, September 16, 2008 8:07 AM
  • I am working with an individual in our origanization who recently upgraded to Office 2007 (inclusive of Outlook) and he is having the same issue.  Can't see free/busy in the Scheduling Assistant, just hashmarks. What I found in this case was a combination of 2 things:

     

    In a new appt, his method was to click "Invite Attendees" so that the To: button would be exposed.  Clicking the To: button, he would type the name of the person he wanted to invite and place it in the "Required - >" field.  Sounds normal, right?  Not in this case.

     

    One of his practices was to add frequently used GAL entries to his Outlook Contacts (right-click the user from the GAL and choose "Add to Outlook Contacts").  When you do that, Outlook grabs the primary SMTP address and populates the E-mail field in the new contact.  This isn't normally an issue, but the plot thickens.......

     

    He also had his addressing defaults set to check the Contacts list first when resolving names.  So when he opened up the GAL and searched on the names, he was really grabbing the SMTP address from the contact he had previously added to his Contacts list.  This was no doubt done prior to migrating this persons' mailbox from Exchange 2003 to Exchange 2007 Server.  What made matters worse is that the Outlook name cache contained an entry that pointed to the contact rather than the GAL entry.

     

    I can't speak with any certainty in this instance but I am (painfully) aware that when a mailbox is moved (even from one 2003 server to another 2003 server, the x500 address changes.  My thinking here is that the combination of his methods created a situation where he could send mail to this person, but couldn't see his free/busy information because it was trying to pull it from information obtained from prior to when the mailbox was migrated.  Either that or Outlook 2007 no longer supports getting free/busy information for mailbox-enabled AD objects that you add the your contacts list.

     

    I tested and proved this theory by deleting the contact(s) in question from his Contacts list in Outlook, then creating a new appointment and inviting this person.  After I removed the Outlook Name Cache entry for this person, I was able to type the name in the To: line, press Alt-K and resolve it to the GAL. The free/busy info shows up fine now.  So even though the email address was correct in the Contact, for some reason using the contact wouldn't allow the free/busy information to be queried.

     

    Hope this helps.

     

     

    Wednesday, October 22, 2008 9:25 PM
  • I am in much the same position.  I was in a beta test type role and was using an Outlook 2007 client against an Exchange 2003 server. Free busy was handled by the Autopick feature.  When the server was upgraded to Exchange 2007 and free busy was now handled by the Suggest Time pane to the right of the screen. 

    Like those posted here, I can no longer see the Free Busy information in this pane or if I follow the Registry Hank listed here: http://www.networkworld.com/community/node/17227 the autopick feature returns, yet I still can not see free busy information.

    I have review permissions on all calendars, I can open their calendars with no problem.  I can use the Web interface and have no problems seeing free busy.

    I have:
    •  used Command line switches: outlook/cleanfreebusy, outlook/cleanschedplus, outlook/cleanreminders, outlook/firstrun.
    • nuked and recreated my OST file
    • nuked all files in the default folder (backing them up) and recreated my profile and let it recreate all the files.
    • Have verified that I am on 2007 - SP1.
       
    Nothing has worked,  anyone have any other ideas or leads?
    Wednesday, December 17, 2008 12:56 AM
  • Has anyone tried to use mfcmapi editor to clear out the free/busy and then re-launch outlook to rebuild?

    I've had great success with that tool on Outlook 2003.

    **** BE CAREFULL!!! ****

    Just a thought.

    Wednesday, January 28, 2009 5:45 PM
  • Has anyone resolved this issue?  I have Exchange 2007, Outlook 2007.  I can see free/busy data through OWA.  I have tested autodiscovery and everything passes.  When trying to book a meeting, scheduling assistant shows, "No free/busy data could be retrieved".  I have also tried this using names from GAL that are not in personal contacts.  Also, even the room I have created and given everyone access to does not display free/busy through Outlook client.
    Monday, March 02, 2009 10:42 PM
  • Open the registry:

    Go to:

    HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\Outlook\Options\Calendar

    Click edit and create a new DWORD Value

    Give the value name:

    “UseLegacyFB”

    Change the value data to:

    1

    Try it now!!

     

    • Proposed as answer by Manoj Tripathi Wednesday, June 30, 2010 8:31 PM
    Monday, May 11, 2009 8:43 PM
  • Thanks One Idea

    That worked for me. I am running outlook 2007 on Vista 64 bit and am connected to a 2007 exchange server.

    What impact does using legacy free/busy data have? 
    Sunday, May 17, 2009 11:45 AM
  • Worked like a champ for me too (the reg key). Thank you!
    Wednesday, July 22, 2009 1:56 PM
  • Sweet! Resolved my issue completely. I have already exported this reg file on my thumb drive so I import it on each Outlook 2007 client pc. Need to check into how to incorporate this as a system policy. Any takers?

    Thursday, July 23, 2009 11:06 PM
  • Will Microsoft incorporate this fix into the next Office 2007 Service Pack?

    Monday, July 27, 2009 1:10 PM
  • I found the root cause of our issues and they were not related to the Outlook client (even though adding a reg key fixed the symptom). We were missing a couple of items in our Exchange config and via another thread I had, I was pointed in the right direction. Here are the two cmdlets that not only fixed Free busy for our Outlook Anywhere users, but also Out of Office.

    By the way, there is a great site call http://testexchangeconnectivity.com that will show you where your issues may lie. I used it to test my Outlook Anywhere connectivity and that's how I discovered these two problems.

    Hi Mike and Hapreet,
    It's working!! Thank you both. We made two changes that corrected the situation:
    1) set-WebServicesVirtualDirectory -identity MAIL01\EWS (Default Web Site) -externalurl https://mail.mycompany.com/ews/exchange.asmx

    2) Set-OutlookProvider EXPR -CertPrincipalName:"msstd:mail.mycompany.com"

    Out of office now works via outlook anwhere and Free Busy is also working!

    SJ

    • Proposed as answer by slj333 Wednesday, July 29, 2009 9:22 PM
    Wednesday, July 29, 2009 9:22 PM
  • With this solution, the titles of meetings are no longer shown in the free/busy bars of attendees.
    Thursday, September 03, 2009 4:47 PM
  • Take a look at this to see if it covers your situation:

    http://itknowledgeexchange.techtarget.com/itanswers/meeting-invitees-availability-not-showing-up-in-outlook-2007/

    "Outlook 2007 will look for a Client Access Server to view free/busy info. Exchange 2003 uses public folders to publish free/busy info."
    • Proposed as answer by SteveH199 Monday, October 12, 2009 8:42 PM
    Monday, October 12, 2009 8:39 PM
  • HI Steve,
    Nope, my issue was with Exchange 2007 having some missing configuration areas. Here's what solved our issue

    It's working!! Thank you both. We made two changes that corrected the situation:
    1) set-WebServicesVirtualDirectory -identity MAIL01\EWS (Default Web Site) -externalurl https://mail.mycompany.com/ews/exchange.asmx

    2) Set-OutlookProvider EXPR -CertPrincipalName:"msstd:mail.mycompany.com"

    Out of office now works via outlook anwhere and Free Busy is also working!

    Monday, October 12, 2009 9:34 PM
  • This worked for me too - thanks a bunch!!!!
    Thursday, December 03, 2009 2:44 AM
  • I just wanted to add that I had the same issue, but the reg hack was not the fix.  I had an additional KEY under the CALENDAR KEY that was labeled as 'Internet Free/Busy' and as soon as I deleted the KEY my Free/Busy worked.
    Thursday, December 17, 2009 7:25 PM
  • I added this key to registry.

    HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\Outlook\Options\Calendar

    Create new DWORD value "UseLegacyFB" with value data '1'

    Exit from registry and restart outlook using 'outlook/cleanfreebusy' switch.

    (i.e Start > Run > Outlook /cleanfreebusy)

    • Proposed as answer by Leeroy_Brown Sunday, June 05, 2011 10:09 PM
    Wednesday, June 30, 2010 8:33 PM
  • Hi,

    I think I found the over all answer to this problem.

     

    I was also seeing this on our systems. We did NOT upgrade from Exchange 2003 we started with Exchange 2007 and Outlook 2007. The fix is on the Exchange server. Open IIS Manager on your Exchange server and then expand the Application Pools. Right click on the "MSExhangeOWAAppPool" click on Properties and then the "Identity" Tab. Select "Predefinded" and Local System.

    You will need to restart IIS. No need to close Outlook 2007 as this fix is immediate. I also tryed the registry edit and in Outlook 2007 it changes the "Add Attendees" button to "Add others" and then lets you choose your address book.

    Hope this helps??

    David Gauld

     

     

    • Proposed as answer by David GLE Monday, July 05, 2010 7:33 PM
    Monday, July 05, 2010 7:33 PM
  • FIX - FREE BUSY NOT UPDATING

     

    I also ran into this problem with a client to find out that the permission level for Free/Busy time was set to none.  I would check this setting 1st.  You may have to click Folder List to view calendar in the left pane.  Right click the calendar and slect Properties.  Go into the  Permissions tab and select Permission Level - Free/Busy time and change from None to Free/Busy time.

     

    Free/Busy Calendar permissions
    Monday, August 02, 2010 6:39 PM
  • Regedit per your suggestion works for me! Thanks!

    Thursday, August 12, 2010 2:07 AM
  • I did not test the regedit suggestion for the client had the same problem where free busy was not showing in Outlook Web Access.  If you have OWA I would test that 1st for you can eliminate cached issues and etc...
    Monday, August 16, 2010 8:55 PM
  • This worked like a charm on one of my machines. 2 Others continue to have problems.
    Monday, August 30, 2010 8:04 PM
  • I would definitely check the permissions again and if that permission was changed by the client who knows if they messed with other settings/permissions.  You will probably have to match the permissions with a know good working one and go that route.  If not than maybe create a new profile for Outlook.  Go into Control Panel - Mail and go into show profiles and add a new one.
    Wednesday, September 01, 2010 5:27 PM
  • Thanks for the reg hack. I now have free/busy data, but I lost my Rooms option. Any ideas how to make this work with Resource mailboxes?

    Thanks.

    Monday, September 06, 2010 1:31 PM
  • This is probably not the solution for everybody with this problem, but I just had a user with the same problem. The registry hack worked, but it was not an acceptable solution for the user to not have "Add rooms". In addition, this problem was applying to only one user.

    In the end we discovered his IE was set to "Work Offline" and this apparently affects the way Free/Busy works. When setting IE to online, everything worked fine.

    Thursday, November 04, 2010 9:18 AM
  • I also had a problem with Outlook reporting "suggestions cannot be provided because free/busy data cannot be provided as well as out of office reporting " Your out of office settings cannot be displayed as the server is unavailable"

    I then ran ; set-WebServicesVirtualDirectory -identity SERVER\EWS (Default Web Site) -externalurl https://externalurl.com/ews/exchange.asmx

    After that I found out that I still could not access free / busy schedules or use OOF , BUT this was ONLY for users that did not have the proxy setting set on Internet explorer. All users that access the Internet require to go through a proxy server to do so. As soon as I set the proxy setting in Internet explorer ,tools -> internet options -> Connections -> lan settings -> use proxy ,  I could then see free/busy schedule of all users as well as set OOF. 


    Lucky
    Monday, November 29, 2010 1:19 PM
  • Thanks for this find!  The hack was an immediate fix!
    Wednesday, December 29, 2010 5:31 PM
  • Just FYI, this Registry setting is not a fix, but rather a workaround.  It points your free/busy information to be pulled from Public Folder servers (legacy) format and not thru EWS. 

    It would be best to move to EWS and find your solution to fix this.  Especially if your organization is looking to remove public folders altogether.

    Wednesday, February 23, 2011 8:51 PM
  • Hi Slj333,

    I have the same issue here.....Please let me know one thing here when I Ran Get-OulookProvider | Fl 

    I was able to see....Only extracts required i am pasting here 

    =======================

    CertPrincipalName : empty

    Server            :empty

    Identity :EXCH

    =======================

    CertPrincipalName : msstd:webmail.internaldoamin.net

    Server            :empty

    Identity :EXPR

    =======================

     

    CertPrincipalName : empty

    Server            :empty

     

    Identity :WEB

    =======================

     

    Please let me know is it Normal or the empty fields need any modification again

    Also EXPR i have modified after your post......But did not restart any service...Is it required to restart any service...

    =================

    One more thing I had the external URL already Set...so Didnot change anything

    Manju

     

    Thursday, September 08, 2011 1:57 PM
  • I found the root cause of the problem,

    I would like to explain that the issue occurs because when you adding delegate to a mailbox. It only grant the delegate has permission to access the room mailbox calendar folder. However, when Outlook trying to access the forwarded meeting request, it also need to access another hidden folder called Free/Busy Data. However, due to the permission issue, we could not access the folder and encounter the error. After granting delegate to have full mailbox access permission to the room mailbox, we will not encounter the error any more.

    The Fix:

    1. Managing Exchange 2010 with Remote PowerShell

    $cred = Get-Credential

    $s = New-PSSession -ConfigurationName Microsoft.Exchange –ConnectionUri https://ps.outlook.com/powershell -Credential $cred -Authentication Basic-AllowRedirection

    $importresults = Import-PSSession $s

     

    2. Command to grant delegate to have full access permission to the room mailbox

    Add-MailboxPermission -Identity "Room" -User username -AccessRights FullAccess

    Meeting Room1

     

    Add-mailboxpermission “Meeting Room1” –AccessRights FullAccess –User User username@microsoft.com

    Friday, January 27, 2012 3:23 AM
  • Thanks!! Worked for me.But this is work around for who are using public folders.Is there any fix for this issue?


    Regards|Virender|MCSE| Directory Services & Messaging DISCLAIMER: THIS POSTING IS PROVIDED AS-IS WITH NO WARRANTIES/GUARANTEES AND CONFERS NO RIGHTS.

    Wednesday, September 19, 2012 9:26 AM