none
Exchange ActiveSync, Sync Period Setting

    Question

  • Hello,

       We have an exchange 2010 server for test enivronment.There is an issue with ActiveSync. Even if we set sync period in a mobile device to one day, it always sync mails for 3 days. it is working on fine with other servers.

    Does anybody have any idea what will be cause?

    It will be highly appritiated if anybody tell me the solution.

    Thanks

    Robin

    Wednesday, July 18, 2012 6:54 PM

All replies

  • I'd guess that's a problem with the mobile device.  It works for my Droid Bionic against our Exchange 2010 server.

    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."

    Wednesday, July 18, 2012 7:33 PM
  • Thanks for your Response...

    We have tested it with different mobile devices. But the result is the same. even if we set 'Include past email items' to One day in activesync mailbox policies, still it sync mails for 3 days only.

    Does anybody have any idea how to view and change the "Maximum e-mail age filter" ActiveSyncMailboxPolicy for the server, which has a default value 3.

    Thanks in advance

    Robin.

    Thursday, July 19, 2012 1:15 PM
  • Hi Robin,

    You can use the Get-ActiveSyncMailboxPolicy cmdlet to retrieve the policy settings for a computer running Microsoft Exchange Server 2010 that has the Client Access server role installed.


    Noya Lau

    TechNet Community Support

    Monday, July 23, 2012 7:19 AM
    Moderator
  • could you please upload source code from below path.

     %_WINCEROOT%\Public\Apps\Oak\Syncres.


    connect me @http://in.linkedin.com/in/satya11; Don't forget to mark helpful or answer

    Monday, July 23, 2012 8:14 AM
  • Thanks for your Response,

    I am not able to find the above path, it is giving error.

    Is there any way to change the default "maximum e-mail age filter" of 3 days. The mobile device is working fine with the other sync interval above 3 days; i.e for 7 days or all. But when i set it to 1 day, it sync mails for 3 days. that is i am not able to set sync interval below 3 days.

    Does anybody have any idea?

    Thanks,

    Robin.

    Monday, July 23, 2012 1:59 PM
  • That wouldn't be the maximum, it would be the minimum of 3 days, but I don't see any setting for a minimum sync period and I've never seen the problem you describe.

    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."

    Monday, July 23, 2012 4:53 PM
  • try this:

    set-ActiveSyncMailboxPolicy -Identity:Default -MaxEmailAgeFilter:1 -IsDefaultPolicy:$True


    MSP Provider (Network,Hardware,Software,WAN/LAN,Exchange,WiFi,Cisco Controllers/Routers/Switches/AP Autonomous/LWAPP)

    Monday, July 23, 2012 8:37 PM
  • Please note, the MaxEmailAgeFilter parameter specifies the maximum number of days of e-mail items to synchronize to the mobile phone. The value is specified in days or by entering one of the following values.

    • All
    • OneDay
    • ThreeDays
    • OneWeek
    • TwoWeeks
    • OneMonth

    Noya Lau

    TechNet Community Support

    Friday, July 27, 2012 9:06 AM
    Moderator
  • Hi,

    what is the recommended value for the maximum no of emails to synchronise?

    what would be the impact if this is modified for 1month?

    Please help our CIO wants this changed to 1 month

    Thursday, August 30, 2012 2:24 PM