none
Outlook 2007 - Blocked Images "Red X" for HTTPS Links

    Question

  •  

    Exchange 2007 SP1 / Outlook 2007 SP1 - One of my users receives their airline tickets via email from Delta.  The barcode image in the email is linked to a secure HTTPS site.  Outlook blocks this image but other ISPs (GMail, Charter WebMail, etc...) do not so its not a corrupt image; it has to be a security setting in Outlook.  I've already tried the methods below with no success.  Any ideas?

     

    1.  Tools, Trust Center, Automatic Download.  Uncheck "Don't download pictures autmatically...".

    2.  HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\Outlook\Security. It contains a key called "OutlookSecureTempFolder ".

    3.  Internet Explorer, Tools, Internet Options, Advanced Tab, Multimedia - Show Pictures

    Wednesday, October 01, 2008 6:04 PM

Answers

  • You are getting the Red X because Outlook 2007 uses MS Word 2007's HTML rendering engine instead of IE's.  Word's engine does not support servlet/applets, which Delta uses to produce the barcode.  You can see the barcode when you choose the option to "View in Browser" because, obviously, you are then using IE or whatever your default browser happens to be.  You can see what Word 2007's HTML and CSS rendering capabilites in Outlook 2007 are in the following MSDN article - http://msdn.microsoft.com/en-us/library/aa338201.aspx 

    Monday, October 13, 2008 5:10 PM

All replies

  • Hi,

    First please ensure that only this user has encountered this issue.

    We suspect that there’s something wrong with windows profile.

    Please try to follow the below steps to recreate the windows profile

    http://support.microsoft.com/kb/326688

    Hope it helps.

    Xiu

     
    Thursday, October 02, 2008 9:58 AM
  • We have replicated this on several different users and PCs so it's not a profile issue, unless there's something wrong with our image.  Is there a global setting in Exchange that could be causing it?

    Thursday, October 02, 2008 12:10 PM
  • We're seeing this EXACT same issue.  End user gets confirmation from Delta, barcode does not display.  We also get the infamous red X when viewing the email in Word.  Everything displays correctly when we "View in Browser".  We are able to reproduce this error on ALL desks.

     

    Windows XP Professional running MSFT Office Pro 2007.  Exchange Server 2003.

    Tuesday, October 07, 2008 3:12 PM
  • You are getting the Red X because Outlook 2007 uses MS Word 2007's HTML rendering engine instead of IE's.  Word's engine does not support servlet/applets, which Delta uses to produce the barcode.  You can see the barcode when you choose the option to "View in Browser" because, obviously, you are then using IE or whatever your default browser happens to be.  You can see what Word 2007's HTML and CSS rendering capabilites in Outlook 2007 are in the following MSDN article - http://msdn.microsoft.com/en-us/library/aa338201.aspx 

    Monday, October 13, 2008 5:10 PM
  •  

    Gotcha.  Thank you very much.
    Monday, October 13, 2008 5:39 PM
  • I couldn’t view pix in Outlook 2007 emails I received. I got this solution from

    http://office-outlook.com/outlook-forum/index.php/m/291552/#msg_291552

     

     and it worked for me:

     

    “I had the same problem. Just empty white boxes where the images were supposed
    to be. But I found the answer to it on the net. It seems I selected an option
    and never bothered to read what it was for (silly me).

    It is the Show Picture Placeholders option.
    The description for it says "Display an empty box in place of each graphic
    in the document to improve scrolling performance"

    If you have the same problem, do the following:

    Create a New email, click the Office Button in the top left, choose the
    Editor Options button at the bottom right, select Advanced, scroll down to
    the "Display email content" section and make sure there is no tick next to
    the "Show Picture Placeholders" option.

    Try it. It worked for me right now :)

    dimarvalc”
    Tuesday, December 08, 2009 2:37 PM
  • Sorry to drag up an old thread, but I'm encountering this exact same issue. What exactly do you mean when you say that servlets/applets are unsupported? If an outlook email contains an image tag pointing at a servlet URL that returns an image (e.g. <img src="http://example.com/imageservlet/?img=1.gif"/>), what exactly does Outlook not like about the response that all other clients seem tolerant of?
    Friday, March 05, 2010 7:07 PM
  • The fix I found for this was due to a setting in IE. GO TO Internet Options, Connections, LAN settings and then had to change it to Automatic detect settings (make sure it is turned ON!). This cleared the red x in Outlook 2007 and a problem with iTunes.

     

    Win7 home ed.

    IE 8

    Outlook 2007

    Thursday, May 19, 2011 9:22 PM
  • This is a flaw in Outlook, we are having the same issue dealing with emails from Delta, with Win 7 and Office 2010. It is not a specific problem with an individual Windows profile, it's global among all users.  It's too bad there's no direct solution to simply have Outlook allow viewing of images via HTTPS links.  I have never understood also why Outlook is tied to word so closely.  Word was never really meant to be an HTML viewer or composer in my opinion.  Viewing in browser seems the only viable workaround for this, thanks.

    • Edited by jachall Wednesday, October 19, 2011 2:00 PM
    Wednesday, October 19, 2011 1:55 PM
  • The above answer marked as "correct" is actually incorrect.

    The images are not shown because of Microsoft's "added" security that goes against logic and practicality.

    To show images that are displayed by a red X

    Go to Tools - Trust Center.

    Click on Automatic Downloads

    UNCHECK "Don't download pictures in HTML Messages".


    lforbes
    • Proposed as answer by wthdik65 Saturday, February 25, 2012 2:59 PM
    • Unproposed as answer by wthdik65 Saturday, February 25, 2012 2:59 PM
    Sunday, December 25, 2011 5:58 AM
  • "Word was never really meant to be an HTML viewer or composer in my opinion." - fully agree.


    Bharadwaj Vyakaranam

    Friday, August 03, 2012 5:35 AM
  • This drove me crazy but I finally figured out my problem.

    Problem: I have Windows 7 and Outlook 2007. The pictures in email messages don't show when the link is and https link.

    Solution:

    In Internet Explorer "Internet Options" on the Advanced page. If I check the;

    "Do not save encrypted pages to disk"

    then the picture links with the HTTPS link do not show. Uncheck that and they show.

    Why that didn't happen in Windows XP I don't know but it does with Windows 7.

    • Edited by dajonline Friday, May 10, 2013 3:40 AM
    • Proposed as answer by Joe D. _ Sunday, July 28, 2013 10:49 PM
    Friday, May 10, 2013 3:38 AM
  • I have put up with this issue so long and this actually resolved it for me.   Thanks!
    Sunday, July 28, 2013 10:50 PM
  • I can't believe this actually worked for me as well.  I, too, have been dealing with this issue for so long.  I don't even use IE, so I never would have guessed that the two were so intertwined.  I figured at this point, I'm willing to try anything and this actually solved my issue!  Thanks!
    Tuesday, August 13, 2013 2:33 AM
  • I too use Win 7 and Outlook 2007, and have the same problem; that is, images on emails show as a "red x" but they will load to my browser.  I do not use IE.  So I cannot relate to the solution you offer.

    How is modifying IE helping the display of images on Outlook 2007?

    Monday, September 30, 2013 10:46 PM
  • Although I do not use IE and can't see how this solution could help, I decided to give it a try out of desperation.  NOTHING ELSE HAS WORKED FOR ME.  As expected, this didn't either.

    I just can't believe (what I am saying; nothing MS does to screw the customer surprises me) that MS is not offering an official, proven solution to this problem.  

    Short of messing with the Register, I have tried everything else.  I rather live with this bad situation that really screw up my system by introducing an error in the Register.

    And this is one more reason why I do not choose MS when I have an alternative.

    Monday, September 30, 2013 11:24 PM
  • Could you please expand on how modifying Internet Explorer's options helped you with Outlook 2007?
    Monday, September 30, 2013 11:25 PM
  • THANK YOU SO MUCH!!!!!!!!!!!!

    This has been driving me crazy. I noticed that anytime i upgraded IE past IE * This issue would happen.
    I kept uninstalling to go back to explorere 8. This took care of the issue though.
    Thanks!

    Fred

    Sunday, March 30, 2014 10:21 PM