none
"Client host rejected: check your mail first"

    Question

  • Only recently, I've started to have emails bouncing almost immediately after I send them, with the message:

    "554 5.7.1 <ip67-154-172-18.z172-154-67.customer.algx.net[67.154.172.18]>:Client host rejected; check your mail first"

    I know the "67.154.172.18" bit is my IP address, but other than that, I have no idea what the error is/what the email server is trying to tell me. If it helps any, my email provider is XO Communications.

    Any help would be appreciated.
    Friday, August 08, 2008 8:58 PM

All replies

  • Hi,

     

    Is there any Exchange in your environment or just the Internet email that you are running?

     

    Did you make change on the Exchange server recently?

     

    Thanks

     

    Allen

    Tuesday, August 12, 2008 10:47 AM
  • I believe Outlook is the only application we are using that uses Exchange. The only change that has been made recently that comes to mind was when we contacted Microsoft tech support a few weeks ago when Outlook wouldn't receive or transmit emails at all. Tech support told us that the email profile was corrupted, so we had to transfer the smtp/pop3 settings to a new profile. That seemed to fix that problem completely.

    I'm not sure how relevant that is, however, as emails have been bouncing back before that incident as well. Only recently have we seen more and more emails bouncing back, and without any known change to Outlook or our email host.
    Thursday, August 14, 2008 2:00 AM
  • Hi,

     

    What’s the version of your Exchange server?

     

    Now please first check which queue did the message stopped.

     

    And improve the Diagnostics Logging in order to find the value information in Event log.

     

    For Exchange 20003

    http://technet.microsoft.com/en-us/library/aa996402(EXCHG.65).aspx

     

    For Exchange 2007

    http://technet.microsoft.com/en-us/library/bb201668(EXCHG.80).aspx

     

    Thanks

     

    Allen

    Thursday, August 14, 2008 10:32 AM