none
Outlook 2010 - Mail receiving delay

    Question

  • Hi,

    we have a couple of Users who receive mails with a delay of a few days. Some mails show up instantly, others after a few days.

    I have tried to solve the Problem with online Profiles but this also doesn`t work.

    We are using Exchange 2010.

    Any Ideas?

    Friday, February 04, 2011 9:07 AM

All replies

  •  

    Hi Lennik,

     

    For this issue, you can use message tracking log to help you troubleshoot the problem:

     

    Managing Message Tracking

    http://technet.microsoft.com/en-us/library/bb124375(EXCHG.80).aspx

     

    How to Configure Message Tracking

    http://technet.microsoft.com/en-us/library/aa997984(EXCHG.80).aspx

     

    Checking the data time in the message tracking log, and looking for where delay happened.

     

    Additionally, please check the event log on your Exchange Server, if there is any error, please paste in your next post.

     

    Thanks,

     

    Evan


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Tuesday, February 08, 2011 8:20 AM
    Moderator
  • Hi Evan,

    the mails are delivered nearly instantly to the Mailbox Server.

    It`s just the Connection with Outlook. The User can see the mails with OWA...

    Today i had another Problem like this. I take a look on the outlook conection status and it shows an HTTPS Connection.

    I changed the connection to TCP/IP and everything works fine, but why?

    For others, HTTPS Connection works without any problems.

    Tuesday, February 08, 2011 12:26 PM
  • Hi Lennik,

     

    I want to clarify do you mean you have resolved the first question, and now you have another problem that when you use Outlook Anywhere, the emails will delay. Please correct me if I misunderstand.

     

    If this issue only occur on one user, I suggest you follow these steps to troubleshoot the problem:

     

    1.       Use online mode to check whether this issue will occur or not.

    2.       Recreate the profile to have a try.

     

    If not, please explain your problem in detail.

     

    Thanks,

     

    Evan

     


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Wednesday, February 09, 2011 3:01 PM
    Moderator
  • Hi Evan,

    no, it is unfortunately still the same problem.
    The user does not use Outlook Anywhere. All users are connected via mapi...                                                                                             
    The client is in online mode and the profile has already been recreated.

    Lennik

    Monday, February 14, 2011 2:48 PM
  • Hi Evan,

    We are having a similar issue.

    Environment:

    Outlook 2010 32bit & 64bit

    Exchange 2010 sp1 RU3 in coexistance with Exchange 2007 while migrating

    HLB CAS/Hub Servers  DAG Mailbox Servers

    Our users are experiencing a problem where it seems Outlook still shows connected but new mails aren't being retreived and shown. OWA is showing the Messages in the Inbox and Activesync clients "iPhone, iPad" are receiving the messages. New messages are received when the user initiates a Send/Receive

    When we go into Outlook's Connection Status it shows connected and when we click "Reconnect" the new messages are retrieved by Outlook.

    We've disabled Cache Mode, and it continues.

    Repair the profile and the issues continues.

    Looks like creating a new Profile resolves the issue, but we have migrated a large number of users and would like to see if there is a better way to fix this issue.

    Thanks,

     

    Friday, March 11, 2011 8:33 PM
  • Do these users have shared mailboxes open?


    James Chong MCITP | EA | EMA; MCSE | M+, S+ Security+, Project+, ITIL msexchangetips.blogspot.com
    Friday, March 11, 2011 8:37 PM
  • No they do not access Shared Mailboxes. We did just determined that they are all on the Same Mailbox Database. I've logged into the system and I'm not seeing any Errors or Warning Events related to this issue. I'm looking at enabling Diagnostic Logging for the Server/DB. Any suggestion on what I should enable?

    Thanks,

    ExchangeFTW

    Friday, March 11, 2011 9:13 PM
  • So, investigating this problem further, we narrowed it down to a specific Database. We then moved to another copy of that DB on another server and the issue was resolved, but we are starting to see the delay issues from users on a non-related DB. We turned on Diagnostic Logging for MS ExchangeThrottling Client.

    Some more background information is that earlier in the week we were having Blackberry Enterprise Server issues and we update dated the BES Server to the most recent revision as well as updating the Exchange 2010 Environment to Exchange 2010 sp1 update Rollup 3.

    Thanks,

    ExchangeFTW

    • Proposed as answer by ExchangeFTW Saturday, March 12, 2011 12:30 AM
    • Unproposed as answer by ExchangeFTW Saturday, March 12, 2011 12:30 AM
    Friday, March 11, 2011 10:37 PM
  • Hello All-

    We ended up resolving our problem by adjusting the RCAMaxConcurrency on our Default Throttling Policy. It was by default set to RCAMaxConcurrency = 20 and we adjusted it to RCAMaxConcurrency = 200. We also adjusted the custom BESPolicy RCAMaxConcurrency to 200 from Unlimited. Once we did this we saw some Exchange Active Sync Delays so we also adjusted the EASMaxConcurrency from 10 to 100.

    Once we made these changes all Outlook clients stop seeing delays of Emails arriving in their mailbox.

    Our conclusion was that the BES Service was over utilizing the resources which was affecting Outlook Clients ability to retreive email from the Servers.

    Use Exchange Management Shell

    RPC Client: Command: Set-ThrottlingPolicy -Identity "<Default Throttling Policy>" -RCAMaxConcurrency 200

    Exchange Activesync Client: Set-ThrottlingPolicy -Identity "<Default Throttling Policy>" -EASMaxConcurrency 200

    To View the Current Throttling Policies: Get-ThrottlingPolicy | select Identity

    To View the setting for a specific Throttling Policy: Get-ThrottlingPolicy -Identity "<Policy Name>"

    Hope this helps.

    Thanks,

    ExchangeFTW

    • Proposed as answer by ExchangeFTW Saturday, March 12, 2011 12:44 AM
    Saturday, March 12, 2011 12:44 AM
  • Also having some delay problems, user working in terminal server environment with Outlook 2003 in none cached mode need to click on a folder or an e-mail item for update and receive new mail items or wait from 30 minutes to a couple of hours.

    Laptop user working in cached mode in any version of office 2003, 2007 or 2010 needs to initiate the update manually or wait from 30 minutes to a couple of hours.

    We checked the ThrottlingPolicy and modified according to “ExchangeFTW” but that didn’t help, also from my understanding regarding ThrottlingPolicy is that they don’t take in affect before the CPU reach 75% load which is set by default.


    Regicide
    Thursday, March 31, 2011 8:43 AM
  • Exchange 2010 Update Rollup 3 (V3), fix this problem.
    Link: http://www.microsoft.com/downloads/en/details.aspx?FamilyID=413b8979-76b8-4be4-a18b-015d025eb368&displaylang=en

    Adam Bokiniec
    • Proposed as answer by Adam.Bokiniec Friday, April 08, 2011 4:19 PM
    Friday, April 08, 2011 4:19 PM
  • HI, Thx for your update we follow your instruction and set the  Set-ThrottlingPolicy -Identity "<Default Throttling Policy>" -RCAMaxConcurrency 200. Our users able to receive the mails immediately. we found the issue Bes policy more utilizing the resources. 

    Regards,

    Kumar.G

     
    • Edited by kumargs44 Friday, July 06, 2012 10:22 AM
    Friday, July 06, 2012 10:18 AM
  • Some messages I never receive. The delay notice to them says no need to re send this message.

    Click here to get more information Raspberry Ketone Supplement

    Saturday, July 07, 2012 4:12 AM
  • you should deploy SP3. http://support.microsoft.com/kb/2778100
    Tuesday, December 17, 2013 3:12 PM