none
ISINTEG Command

    Question

  • Hello,

    I am running the following command on a database to resolve some performance issues.

    Isinteg -s colaexmbx01 -fix -test alltests

    Here are my results:
    Now in test   9(Folder) of total  21 tests; 100% complete.

    I am a bit perplexed because this command did not return to the normal C:\. Does this mean the job is finished or is it still running? Any assistance would be great.


    Jason
    Sunday, February 13, 2011 12:01 AM

Answers

    1. its still running, be patient it will take time to run and when its done it will give you the results, i.e. how many errors it found and repaired.
    2. If it reports that it fixed ANY errors then repeat the process gain until it tells you that it repaired zero (0) errors

    Troy Werelius
    www.Lucid8.com
    • Proposed as answer by Novak Wu Monday, February 14, 2011 6:59 AM
    • Marked as answer by Novak Wu Monday, February 21, 2011 1:54 AM
    Sunday, February 13, 2011 2:49 AM

All replies

    1. its still running, be patient it will take time to run and when its done it will give you the results, i.e. how many errors it found and repaired.
    2. If it reports that it fixed ANY errors then repeat the process gain until it tells you that it repaired zero (0) errors

    Troy Werelius
    www.Lucid8.com
    • Proposed as answer by Novak Wu Monday, February 14, 2011 6:59 AM
    • Marked as answer by Novak Wu Monday, February 21, 2011 1:54 AM
    Sunday, February 13, 2011 2:49 AM
  • Hi,

     

    I would like to know how thing is going on. As Troy mentioned, the tool is still running and you should wait for a while until there is a result. For more information about the tool, please refer to the link below:

     

    http://support.microsoft.com/kb/182081

     

    Thanks.

    Novak

     


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Monday, February 14, 2011 6:58 AM
  • Thank you to all for answering my questions. I was up against the end of the maintenance window and I ended up using control C to stop the process. I will working on allowing this a much longer time period next time. Here are the results below if anyone has advice for me. Thanks

     

    #########################################

     


    C:\Program Files\Microsoft\Exchange Server\Bin>Isinteg -s colaexmbx01 -fix -test
     alltests
    Databases for server colaexmbx01:
    Only databases marked as Offline can be checked

    Index  Status       Database-Name
    Storage Group Name: Recovery Storage Group 1
      1    Offline      MBX-I
    Storage Group Name: SG-E
      2    Offline      MBX-E
    Storage Group Name: SG-E-Pub
      3    Online       Public Folder Database
    Storage Group Name: SG-F
      4    Online       MBX-F
    Storage Group Name: SG-G
      5    Online       MBX-G
    Storage Group Name: SG-H
      6    Online       MBX-H
    Storage Group Name: SG-I
      7    Online       MBX-I
    Storage Group Name: SG-J
      8    Online       MBX-J
    Storage Group Name: SG-K
      9    Online       MBX-K
    Storage Group Name: SG-M
     10    Online       MBX-M
    Storage Group Name: SG-N
     11    Online       MBX-N
    Storage Group Name: SG-O
     12    Online       MBX-O
    Enter a number to select a database or press Return to exit.
    2
    You have selected SG-E / MBX-E.
    Continue?(Y/N)y
    Test Categorization Tables result: 0 error(s); 0 warning(s); 0 fix(es); 0 row(s)
    ; time: 0h:0m:24s
    Test Restriction Tables result: 0 error(s); 0 warning(s); 0 fix(es); 0 row(s); t
    ime: 0h:1m:10s
    Test Search Folder Links result: 0 error(s); 0 warning(s); 17 fix(es); 0 row(s);
     time: 0h:0m:0s
    Test Global result: 0 error(s); 0 warning(s); 0 fix(es); 1 row(s); time: 0h:0m:0
    s
    Test Delivered To result: 0 error(s); 0 warning(s); 0 fix(es); 20239 row(s); tim
    e: 0h:0m:0s
    Test Repl Schedule result: 0 error(s); 0 warning(s); 0 fix(es); 0 row(s); time:
    0h:0m:0s
    Test Timed Events result: 0 error(s); 0 warning(s); 0 fix(es); 55 row(s); time:
    0h:0m:0s
    Test reference table construction result: 0 error(s); 0 warning(s); 0 fix(es); 0
     row(s); time: 0h:20m:32s
    Now in test   9(Folder) of total  21 tests; 100% complete.
    Ctrl-Break detected, canceling all tests...
    Test Folder result: 1 error(s); 0 warning(s); 24018 fix(es); 15410 row(s); time:
     3h:36m:31s
    Now in test  10(Unknown test step) of total  21 tests; 100% complete.
    C:\Program Files\Microsoft\Exchange Server\Bin>I
    'I' is not recognized as an internal or external command,
    operable program or batch file.

    C:\Program Files\Microsoft\Exchange Server\Bin>


    Jason
    Monday, February 14, 2011 2:18 PM
  • You just need to schedule more time to do this and as previously stated

    1. Be patient it will take time to run and when its done it will give you the results, i.e. how many errors it found and repaired etc. 
    2. If it reports that it fixed ANY errors then repeat the process gain until it tells you that it repaired zero (0) errors

    Troy Werelius
    www.Lucid8.com
    Monday, February 14, 2011 6:11 PM
  • What performance isssues are you having?

     

    Monday, February 14, 2011 7:21 PM
  • Thank you for your update. If there is any further problem when running the tool next time, please feel free to let us know. Based on the current result, it is normal.

     

    Regards,

    Novak Wu

     

    TechNet Subscriber Support in forum

    If you have any feedback on our support, please contact tngfb@microsoft.com  

     


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Wednesday, February 16, 2011 1:31 AM
  • Hello Andy,

    We were experiencing some unexplained sluggish issues with one mailbox database. We ran this tool last month and saw an improvement in performance plus it fixed over 130k errors. Because of this, we figured we will run this tool on every database.


    Jason
    Wednesday, February 16, 2011 1:41 AM
  • Hi, I was running isinteg -s mail -fix -test alltests and it seemed to hang on Test 9 at 100%. I closed the Command window but did not end the process, now its still running but I dont knwo if its hung or shen it will finish.

    Is there any way to bring back the status window or to monitor this in another way. Im outside of my maintenance window now.


    Thanks!

    Tuesday, February 22, 2011 1:28 AM
  • I am not sure to be honest. I wonder if you could either try to mount the database or restart the Information Store service.
    Jason
    Tuesday, February 22, 2011 1:35 AM
  • The information store wont mount, but no error. I try to rerun isinteg -s mail -fix -test alltests but it says its already running. Really dont want to stop it, just to make sure its not hung up indefinitely. I dont see a process for it?

    Tuesday, February 22, 2011 1:39 AM