none
Task 'Microsoft Exchange' reported error (0x8004010F) : 'The operation failed. An object cannot be found.'

    Question


  • I recently set up an Exchange server (Exchange 2007 on Windows Server 2008 x64).  Whenever I click Send/Receive in Outlook, the following error is given.

    Task 'Microsoft Exchange' reported error (0x8004010F) : 'The operation failed. An object cannot be found.'

    With Outlook logging enabled, this is the log generated:

    2009.01.28 13:20:23 <<<< Logging Started (level is LTF_TRACE) >>>>
    2009.01.28 13:20:23 HELPER::Initialize called
    2009.01.28 13:20:23 Initializing: Finding a Transport
    2009.01.28 13:20:23 MAPI XP Call: XPProviderInit in EMSMDB.DLL, hr = 0x00000000
    2009.01.28 13:20:23 MAPI XP Call: TransportLogon, hr = 0x8004011d
    2009.01.28 13:20:23 MAPI XP Call: Shutdown, hr = 0x00000000
    2009.01.28 13:20:23 MAPI XP Call: XPProviderInit in EMSMDB.DLL, hr = 0x00000000
    2009.01.28 13:20:23 MAPI Status: (-- -- ---/--- -- ---)
    2009.01.28 13:20:23 MAPI XP Call: TransportLogon, hr = 0x00000000
    2009.01.28 13:20:23 Initializing: Found a transport, Error code = 0x00000000
    2009.01.28 13:20:23 MAPI XP Call: AddressTypes, hr = 0x00000000, cAddrs = 3, cUids = 1
    2009.01.28 13:20:23 MAPI XP Call: RegisterOptions, hr = 0x00000000, cOptions = 2
    2009.01.28 13:20:23 MAPI Status: (IN -- ---/OUT -- ---)
    2009.01.28 13:20:23 MAPI XP Call: TransportNotify(BEGIN_IN|BEGIN_OUT), hr = 0x00000000
    2009.01.28 13:20:23 HELPER::Initialize done, Error code = 0x00000000
    2009.01.28 13:20:23 HELPER::GetCapabilities called, Error code = 0x00000000
    2009.01.28 13:20:50 Microsoft Exchange: Synch operation started (flags = 00000001)
    2009.01.28 13:20:50 Microsoft Exchange: UploadItems: 0 messages to send
    2009.01.28 13:20:50 Microsoft Exchange: Synch operation completed
    2009.01.28 13:25:48 Microsoft Exchange: Synch operation started (flags = 00000001)
    2009.01.28 13:25:48 Microsoft Exchange: UploadItems: 0 messages to send
    2009.01.28 13:25:48 Microsoft Exchange: Synch operation completed
    2009.01.28 13:27:45 Microsoft Exchange: Synch operation started (flags = 00000001)
    2009.01.28 13:27:45 Microsoft Exchange: UploadItems: 0 messages to send
    2009.01.28 13:27:45 Microsoft Exchange: Synch operation completed
    2009.01.28 13:28:25 Microsoft Exchange: Synch operation started (flags = 00000001)
    2009.01.28 13:28:25 Microsoft Exchange: UploadItems: 0 messages to send
    2009.01.28 13:28:25 Microsoft Exchange: Synch operation completed

    Any help in resolving the issue is greatly appreciated.

    Thanks,

    Mike

    Wednesday, January 28, 2009 6:34 PM

Answers

All replies

  •  

    Hi Mike,

     

    I understand the error 0x8004010F is encountered when clicking Send and Receive in Outlook.

     

    At this time, I would like to know whether the message can be received after clicking Send/Receive button if any one sends an email to you.

     

    If you are able to receive message with no problem, please attempt the following method to troubleshoot the issue:

     

    1.      Tools->Options

    2.      Click Mail Setup tab, click Send/Receive button

    3.      Select All Accounts group and click Edit

    4.      Please uncheck Download offline address book and click OK to save the change.

     

    After that, please click Send/Receive button again to check whether the issue persists.

     

    Mike

     

    Friday, January 30, 2009 8:24 AM
  • I am able to receive messages.  Following the steps provided solved the problem, but what do I lose by doing this?  What is the offline address book for, and what do I have to do in Exchange to fix the issue?
    Monday, February 02, 2009 4:08 AM
  • Hi Mike,

     

    Based on the current situation, I believe that issue occurs when downloading Offline Address Book.

     

    Please understand Microsoft Office Outlook 2003 and 2007 uses the offline address book to provide offline access to directory information from the Global Address List (GAL).

     

    Regarding more information regardingOffline Address Book, I suggest you refer to following article:

     

    Administering the offline address book in Outlook 2003 and Outlook 2007

    http://support.microsoft.com/kb/841273/en-us

     

    Regarding the error code 0x8004010F, I would like to explain that it can caused by several factors. Therefore, please help me gather the following information firstly to troubleshoot the issue:

     

    1. Whether the issue occurs on specific users or all the users?

    2. Whether the issue only occurs on Outlook 2003 or 2007 or both two Outlook versions?

    3. Please Run "get-offlineaddressbook |fl" command and post the result here

    4. If the issue only occurs on Outlook 2007, please help me gather following information:

     

    Test E-mail AutoConfiguration

    ========================

    a. Hold down the CTRL key on your keyboard and click the Outlook icon in the notification area of the Windows Taskbar, also known as the notification area

    b. In the menu that appears, click Test E-mail AutoConfiguration

    c. Enter your E-mail Address and Password (if not logged into the domain) in the respective edit boxes.

    d. Choose the desired auto configuration methods with use Autodiscover, clear other selection.

     

    Note: You need to uncheck “Use Guessmart” and “Security Guessmart Authentication” options before autodiscover test.

     

    Mike

     

    Tuesday, February 03, 2009 3:36 AM
  • The issue occurs with all users.

    Currently, there are only Outlook 2007 clients.

    Server                          : CHRISTINA
    AddressLists                    : {Default Global Address List}
    Versions                        : {Version4}
    IsDefault                       : True
    PublicFolderDatabase            : CHRISTINA\Second Storage Group\Default Public
                                       Folder DB
    PublicFolderDistributionEnabled : True
    WebDistributionEnabled          : True
    DiffRetentionPeriod             : 30
    Schedule                        : {Sun.5:00 AM-Sun.5:15 AM, Mon.5:00 AM-Mon.5:1
                                      5 AM, Tue.5:00 AM-Tue.5:15 AM, Wed.5:00 AM-We
                                      d.5:15 AM, Thu.5:00 AM-Thu.5:15 AM, Fri.5:00
                                      AM-Fri.5:15 AM, Sat.5:00 AM-Sat.5:15 AM}
    VirtualDirectories              : {OAB (Default Web Site)}
    ExchangeVersion                 : 0.1 (8.0.535.0)
    AdminDisplayName                :
    Name                            : Default Offline Address Book
    DistinguishedName               : CN=Default Offline Address Book,CN=Offline Ad
                                      dress Lists,CN=Address Lists Container,CN=Omn
                                      ia Computer Services,CN=Microsoft Exchange,CN
                                      =Services,CN=Configuration,DC=omniacs,DC=com
    Identity                        : \Default Offline Address Book
    Guid                            : 1b4d7691-544f-4bb2-8b51-06966f9e3459
    ObjectCategory                  : omniacs.com/Configuration/Schema/ms-Exch-OAB
    ObjectClass                     : {top, msExchOAB}
    WhenChanged                     : 2/2/2009 10:14:22 AM
    WhenCreated                     : 1/27/2009 2:02:29 AM
    OriginatingServer               : CHRISTINA.omniacs.com
    IsValid                         : True

    Test Email AutoConfiguration: failed (errors 0x800X8203, 0x8004010F, 0x80072EE7)

    I greatly appreciate your help.  Thank you very much.
    Tuesday, February 03, 2009 4:55 AM
  •  

    Hi Mike,

     

    Thanks for your response.

     

    From the command line output, the Offline Address Book configuration is correctly. Nevertheless, the Test Email AutoConfiguration information is limited for us to troubleshoot the issue.

     

    Therefore, please help me gather the following information again:

     

    1.   Whether all the problem Outlook 2007 is domain connected and connects to Exchange Server directly through Exchange Mode (not Outlook Anywhere)

    2.   Please Test E-mail AutoConfiguration again and capture a screenshot to me (v-mishen@microsoft.com)

     

    Note: Please capture screenshots under Results and Log tab separately

     

    Test E-mail AutoConfiguration

    ================================

    a. Hold down the CTRL key on your keyboard and click the Outlook icon in the notification area of the Windows Taskbar, also known as the notification area

    b. In the menu that appears, click Test E-mail AutoConfiguration

    c. Enter your E-mail Address and Password (if not logged into the domain) in the respective edit boxes.

    d. Choose the desired auto configuration methods with use Autodiscover, clear other selection.

     

    Note: You need to uncheck “Use Guessmart” and “Security Guessmart Authentication” options before autodiscover test.

     

    3. On the Exchange Server, run following command and help me gather the output:

    Test-Outlookwebservices |fl

     

    Mike

    Wednesday, February 04, 2009 5:22 AM
  •  

    Hi Mike,

     

    Thanks for your response.

     

    From the command line output, the Offline Address Book configuration is correctly. Nevertheless, the Test Email AutoConfiguration information is limited for us to troubleshoot the issue.

     

    Therefore, please help me gather the following information again:

     

    1.   Whether all the problem Outlook 2007 is domain connected and connects to Exchange Server directly through Exchange Mode (not Outlook Anywhere)

    2.   Please Test E-mail AutoConfiguration again and capture a screenshot to me (v-mishen@microsoft.com)

     

    Note: Please capture screenshots under Results and Log tab separately

     

    Test E-mail AutoConfiguration

    ================================

    a. Hold down the CTRL key on your keyboard and click the Outlook icon in the notification area of the Windows Taskbar, also known as the notification area

    b. In the menu that appears, click Test E-mail AutoConfiguration

    c. Enter your E-mail Address and Password (if not logged into the domain) in the respective edit boxes.

    d. Choose the desired auto configuration methods with use Autodiscover, clear other selection.

     

    Note: You need to uncheck “Use Guessmart” and “Security Guessmart Authentication” options before autodiscover test.

     

    3. On the Exchange Server, run following command and help me gather the output:

    Test-Outlookwebservices |fl

     

    Mike


    Hi Mike,

    Was any solution found for this issue ?.
    Im seeing the same issue only on Outlook2007... OL2002 and OL2003 is fine, no errors. this issue is seen only on 2007
    Any help would be great

    Biju
    Thursday, October 29, 2009 10:32 AM
  • Biju,

    this is typical issue with OL 2007 when you are on rpc over https. Configure a autodiscover.domain.com record on the DNS.

    Follow this white paper http://technet.microsoft.com/en-us/library/bb332063.aspx

    Raj
    • Marked as answer by fyathyrio8 Thursday, February 18, 2010 1:29 PM
    Thursday, October 29, 2009 10:53 AM
  • Hi Biju,

                  Look like I'm having the same issue , 

     I run  Test-Outlookwebservices |fl and I got  these info.  

     Any help is appreciated

    Thanks!!!

    Cesar

     

    [PS] C:\Documents and Settings\jfsadmin\Desktop>"get-offlineaddressbook |fl"

    get-offlineaddressbook |fl

    [PS] C:\Documents and Settings\jfsadmin\Desktop>"get-offlineaddressbook |fl"Get-

    OfflineAddressBook | Format-List

    Unexpected token 'Get-OfflineAddressBook' in expression or statement.

    At line:1 char:51

    + "get-offlineaddressbook |fl"Get-OfflineAddressBook  <<<< | Format-List

    [PS] C:\Documents and Settings\jfsadmin\Desktop>Get-OfflineAddressBook | Format-

    List

     

     

    Server                          : JFSEXCHANGE

    AddressLists                    : {Default Global Address List, All Users}

    Versions                        : {Version2, Version3, Version4}

    IsDefault                       : False

    PublicFolderDatabase            : JFSEXCHANGE\Second Storage Group\Public Folde

                                      r Database

    PublicFolderDistributionEnabled : True

    WebDistributionEnabled          : False

    DiffRetentionPeriod             : 30

    Schedule                        : {Sun.5:00 AM-Sun.5:15 AM, Mon.5:00 AM-Mon.5:1

                                      5 AM, Tue.5:00 AM-Tue.5:15 AM, Wed.5:00 AM-We

                                      d.5:15 AM, Thu.5:00 AM-Thu.5:15 AM, Fri.5:00

                                      AM-Fri.5:15 AM, Sat.5:00 AM-Sat.5:15 AM}

    VirtualDirectories              : {}

    ExchangeVersion                 : 0.1 (8.0.535.0)

    AdminDisplayName                :

    Name                            : JFS OAB

    DistinguishedName               : CN=JFS OAB,CN=Offline Address Lists,CN=Addres

                                      s Lists Container,CN=JFS,CN=Microsoft Exchang

                                      e,CN=Services,CN=Configuration,DC=jfsadmin,DC

                                      =corp

    Identity                        : \JFS OAB

    Guid                            : ac39dfb4-1859-4c85-86a8-2cca0b68f537

    ObjectCategory                  : jfsadmin.corp/Configuration/Schema/ms-Exch-OA

                                      B

    ObjectClass                     : {top, msExchOAB}

    WhenChanged                     : 7/23/2010 10:39:50 AM

    WhenCreated                     : 9/30/2007 4:58:37 PM

    OriginatingServer               : jfsmain.jfsadmin.corp

    IsValid                         : True

     

    Server                          : JFSEXCHANGE

    AddressLists                    : {All Contacts, Default Global Address List}

    Versions                        : {Version2, Version3, Version4}

    IsDefault                       : True

    PublicFolderDatabase            : JFSEXCHANGE\Second Storage Group\Public Folde

                                      r Database

    PublicFolderDistributionEnabled : True

    WebDistributionEnabled          : False

    DiffRetentionPeriod             : 30

    Schedule                        : {Sun.5:00 AM-Sun.5:15 AM, Mon.5:00 AM-Mon.5:1

                                      5 AM, Tue.5:00 AM-Tue.5:15 AM, Wed.5:00 AM-We

                                      d.5:15 AM, Thu.5:00 AM-Thu.5:15 AM, Fri.5:00

                                      AM-Fri.5:15 AM, Sat.5:00 AM-Sat.5:15 AM}

    VirtualDirectories              : {}

    ExchangeVersion                 : 0.1 (8.0.535.0)

    AdminDisplayName                :

    Name                            : JFS NEW OAB

    DistinguishedName               : CN=JFS NEW OAB,CN=Offline Address Lists,CN=Ad

                                      dress Lists Container,CN=JFS,CN=Microsoft Exc

                                      hange,CN=Services,CN=Configuration,DC=jfsadmi

                                      n,DC=corp

    Identity                        : \JFS NEW OAB

    Guid                            : 22614c35-7ac3-4b71-b35e-ec9cce27788e

    ObjectCategory                  : jfsadmin.corp/Configuration/Schema/ms-Exch-OA

                                      B

    ObjectClass                     : {top, msExchOAB}

    WhenChanged                     : 7/23/2010 10:39:50 AM

    WhenCreated                     : 7/23/2010 9:30:58 AM

    OriginatingServer               : jfsmain.jfsadmin.corp

    IsValid                         : True

     

     

     

    Wednesday, July 28, 2010 6:08 PM
  • I had the same issue with Outlook(2007) using Exchange.

    This is what I did to fix it.

    Control Panel> Mail

    -Show Proflies
    -Remove Profie.

    Now "Add Profile"
    Name your Profile
    Click OK

    now you will setup the account as if it where new
    It will take abit of time for all the files to sync...
    And you are done.

    I have used this trick on a good number of computers at the Office.
    Quick Fix!

    Friday, September 21, 2012 8:00 PM
  • Hi Biju,

                  Look like I'm having the same issue , 

     I run  Test-Outlookwebservices |fl and I got  these info.  

     Any help is appreciated

    Thanks!!!

    Cesar

    [PS] C:\Documents and Settings\jfsadmin\Desktop>"get-offlineaddressbook |fl"

    get-offlineaddressbook |fl

    [PS] C:\Documents and Settings\jfsadmin\Desktop>"get-offlineaddressbook |fl"Get-

    OfflineAddressBook | Format-List

    Unexpected token 'Get-OfflineAddressBook' in expression or statement.

    At line:1 char:51

    + "get-offlineaddressbook |fl"Get-OfflineAddressBook  <<<< | Format-List

    [PS] C:\Documents and Settings\jfsadmin\Desktop>Get-OfflineAddressBook | Format-

    List

    Server                          : JFSEXCHANGE

    AddressLists                    : {Default Global Address List, All Users}

    Versions                        : {Version2, Version3, Version4}

    IsDefault                       : False

    PublicFolderDatabase            : JFSEXCHANGE\Second Storage Group\Public Folde

                                      r Database

    PublicFolderDistributionEnabled : True

    WebDistributionEnabled          : False

    DiffRetentionPeriod             : 30

    Schedule                        : {Sun.5:00 AM-Sun.5:15 AM, Mon.5:00 AM-Mon.5:1

                                      5 AM, Tue.5:00 AM-Tue.5:15 AM, Wed.5:00 AM-We

                                      d.5:15 AM, Thu.5:00 AM-Thu.5:15 AM, Fri.5:00

                                      AM-Fri.5:15 AM, Sat.5:00 AM-Sat.5:15 AM}

    VirtualDirectories              : {}

    ExchangeVersion                 : 0.1 (8.0.535.0)

    AdminDisplayName                :

    Name                            : JFS OAB

    DistinguishedName               : CN=JFS OAB,CN=Offline Address Lists,CN=Addres

                                      s Lists Container,CN=JFS,CN=Microsoft Exchang

                                      e,CN=Services,CN=Configuration,DC=jfsadmin,DC

                                      =corp

    Identity                        : \JFS OAB

    Guid                            : ac39dfb4-1859-4c85-86a8-2cca0b68f537

    ObjectCategory                  : jfsadmin.corp/Configuration/Schema/ms-Exch-OA

                                      B

    ObjectClass                     : {top, msExchOAB}

    WhenChanged                     : 7/23/2010 10:39:50 AM

    WhenCreated                     : 9/30/2007 4:58:37 PM

    OriginatingServer               : jfsmain.jfsadmin.corp

    IsValid                         : True

    Server                          : JFSEXCHANGE

    AddressLists                    : {All Contacts, Default Global Address List}

    Versions                        : {Version2, Version3, Version4}

    IsDefault                       : True

    PublicFolderDatabase            : JFSEXCHANGE\Second Storage Group\Public Folde

                                      r Database

    PublicFolderDistributionEnabled : True

    WebDistributionEnabled          : False

    DiffRetentionPeriod             : 30

    Schedule                        : {Sun.5:00 AM-Sun.5:15 AM, Mon.5:00 AM-Mon.5:1

                                      5 AM, Tue.5:00 AM-Tue.5:15 AM, Wed.5:00 AM-We

                                      d.5:15 AM, Thu.5:00 AM-Thu.5:15 AM, Fri.5:00

                                      AM-Fri.5:15 AM, Sat.5:00 AM-Sat.5:15 AM}

    VirtualDirectories              : {}

    ExchangeVersion                 : 0.1 (8.0.535.0)

    AdminDisplayName                :

    Name                            : JFS NEW OAB

    DistinguishedName               : CN=JFS NEW OAB,CN=Offline Address Lists,CN=Ad

                                      dress Lists Container,CN=JFS,CN=Microsoft Exc

                                      hange,CN=Services,CN=Configuration,DC=jfsadmi

                                      n,DC=corp

    Identity                        : \JFS NEW OAB

    Guid                            : 22614c35-7ac3-4b71-b35e-ec9cce27788e

    ObjectCategory                  : jfsadmin.corp/Configuration/Schema/ms-Exch-OA

                                      B

    ObjectClass                     : {top, msExchOAB}

    WhenChanged                     : 7/23/2010 10:39:50 AM

    WhenCreated                     : 7/23/2010 9:30:58 AM

    OriginatingServer               : jfsmain.jfsadmin.corp

    IsValid                         : True


    I've been having the same issue, just ignoring it.  I decided to resolve it and I've followed the directions here.  When I run the command below, I get the result below that :


             [PS] C:\Windows\system32>Test-Outlookwebservices |fl


    Id      : 1003
    Type    : Information
    Message : About to test AutoDiscover with the e-mail address our-user-name-email-address.

    Id      : 1007
    Type    : Information
    Message : Testing server CJAS-EXCHANGE.cheapjoes.local with the published name
              our-exchange-server-name/EWS/Exchange.asmx & .

    Id      : 1019
    Type    : Information
    Message : Found a valid AutoDiscover service connection point. The AutoDiscover
               URL on this object is our-exchange-server-name/Autodisc
              over/Autodiscover.xml.

    Id      : 1005
    Type    : Warning
    Message : When accessing our-exchange-server-name/Autodiscover/Aut
              odiscover.xml the error "NotTimeValid:A required certificate is not w
              ithin its validity period when verifying against the current system c
              lock or the timestamp in the signed file.
              " was reported.

    Id      : 1013
    Type    : Error
    Message : When contacting our-exchange-server-name/Autodiscover/Autodiscover.xml received the error The remote server returned an error
              : (401) Unauthorized.

    Id      : 1006
    Type    : Error
    Message : The Autodiscover service could not be contacted.

    Coincidentally (or perhaps not) it automatically picked a user name that we have had problems with getting email connected from a MAC. 

    Any ideas on why?


    Joe Gambill

    Tuesday, September 24, 2013 2:56 PM
  • This worked!  Thank you.
    Wednesday, October 16, 2013 2:35 AM