none
Exchange 2010 owa redirect to Exchange 2003

    Question

  • Hi,
    I'm trying to set up a test environment to test migration from exchange 2003 to exchange 2010.

    If I try to logon to a box that is still on the Exchange 2003 server i get an error.

    Steps:
    Set-OWAVirtualDirectory “Ex2010Srv”\OWA* -Exchange2003URL http://legacy.domain.com/exchange

    Created a legacy A-record pointing at Ex2003Srv

    Turned off all SSL (so only using http in the test environment)

    So, when accessing http://Ex2010Srv/owa I get the error message:
    Your request couldn't be completed because no server with the correct security settings was found to handle the request. If the problem continues, contact your helpdesk.

    If I change LegacyRedirectType to manual I receive a link and when I press it I can enter username and password, then I get into the exchange 2003 box.




    ftornell
    Tuesday, January 12, 2010 8:26 AM

Answers

All replies


  • So, when accessing http://Ex2010Srv/owa I get the error message:
    Your request couldn't be completed because no server with the correct security settings was found to handle the request. If the problem continues, contact your helpdesk.

    Try this URL: https://Ex2010Srv/owa
    By default, Exchange OWA has a self-signed certificate

    Elie B. MCITP: EMEA|EA|SA; MCTS: Microsoft Exchange Server 2010: Configuration; Blog: http://blog.elieb.info
    Tuesday, January 12, 2010 8:38 AM

  • So, when accessing http://Ex2010Srv/owa I get the error message:
    Your request couldn't be completed because no server with the correct security settings was found to handle the request. If the problem continues, contact your helpdesk.

    Try this URL: https://Ex2010Srv/owa
    By default, Exchange OWA has a self-signed certificate

    Elie B. MCITP: EMEA|EA|SA; MCTS: Microsoft Exchange Server 2010: Configuration; Blog: http://blog.elieb.info
    Hi,
    I know Exhcange 2010 uses a self-signed certificate but exchange 2003 doesn't.

    But even if I try accessing through that path I receive the same error! :(


    ftornell
    Tuesday, January 12, 2010 8:49 AM
  • Can you check the internal/external URL from EMC.
    To do this follow the first 5 steps in this article: http://technet.microsoft.com/en-us/library/dd298140.aspx

    Also, can you confirm that you ran a similar function as the below:

    Set-OWAVirtualDirectory \OWA* -ExternalURL https://mail.contoso.com/OWA -Exchange2003URL http://legacy.domain.com/exchange

    Elie B. MCITP: EMEA|EA|SA; MCTS: Microsoft Exchange Server 2010: Configuration; Blog: http://blog.elieb.info
    Tuesday, January 12, 2010 9:00 AM
  • Can you check the internal/external URL from EMC.
    To do this follow the first 5 steps in this article: http://technet.microsoft.com/en-us/library/dd298140.aspx

    Also, can you confirm that you ran a similar function as the below:

    Set-OWAVirtualDirectory \OWA* -ExternalURL https://mail.contoso.com/OWA -Exchange2003URL http://legacy.domain.com/exchange

    Elie B. MCITP: EMEA|EA|SA; MCTS: Microsoft Exchange Server 2010: Configuration; Blog: http://blog.elieb.info

    Hi again Elie,

    Both are the same with no SSL:
    InternalURL: http://ex2010srv.domain.com/owa
    ExternalURL: http://ex2010srv.domain.com/owa

    And i Did run the command: 
    Set-OWAVirtualDirectory ex2010srv\OWA* -ExternalURL http://ex2010srv.domain.com/OWA -Exchange2003URL http://legacy.domain.com/exchange

    This should work without HTTPS/SSL as well right?

    Thx!

    ftornell
    Tuesday, January 12, 2010 9:13 AM
  • It is better to have this run as https If you want to remove the self-signed certificate, that will definitely need another process, and i'm not sure if it works.
    Elie B. MCITP: EMEA|EA|SA; MCTS: Microsoft Exchange Server 2010: Configuration; Blog: http://blog.elieb.info
    Tuesday, January 12, 2010 9:19 AM
  • It is better to have this run as https If you want to remove the self-signed certificate, that will definitely need another process, and i'm not sure if it works.
    Elie B. MCITP: EMEA|EA|SA; MCTS: Microsoft Exchange Server 2010: Configuration; Blog: http://blog.elieb.info
    Ok,
    Now I changed the ExternalURL to HTTPS, but still I get the same error message.

    Any more hints?

    ftornell
    Tuesday, January 12, 2010 1:11 PM
  • This is a complete guess. But in your script you are still listing http://legacy.domain.com/exchange are you replacing that with the correct URL for your Exchange 2003 server....

    so something like Set-OWAVirtualDirectory “Ex2010Srv”\OWA* -Exchange2003URL http://Ex2003Srv/exchange

    Dave
    Dave Doeppel
    Wednesday, January 13, 2010 10:58 PM
  • Hi,

    I have the same problem. When I try to use Outlook Web Access with an account/mailbox located on an Exchange 2003 server without SSL I get the answer:

    "Your request couldn't be completed because no server with the correct security settings was found to handle the request. If the problem continues, contact your helpdesk."

    I have tried both HTTPS and HTTP, without luck. I can log into a mailbox located on the Exchange 2010 server, but not on the Exchange 2003. We need to coexist with 2003 and 2010.

    The mailboxes residing on the Exchange 2010 server, receives mail through the Exchange 2003 server, but are unable to send mail through the Exchange 2003 server. We would like to have the Exchange 2003 send/receive mail, since we do not know if the Exchange 2010 server will send/receive mail to the Exchange 2003 server, since we can not communicate with OWA on the Exchange 2003 server through the Exchange 2010 server. We can not move all the mailboxes at once from the Exchange 2003 server to the Exchange 2010 server, and therefore we need to have the Exchange 2003 server running.

    If I set LegacyRedirectType to "Manual" it work fine, with http://legacy.xxx.xxx/exchange to the Exchange 2003 server, but I still do not get Exchange 2003 to send mail from the Exchange 2010 server.
    Wednesday, February 03, 2010 2:22 PM
  • To your's question,I suggestion what it's setting as follow:

    1、Set-OWAVirtualDirectory “Ex2010Srv”\OWA* -Exchange2003URL http://legacy.domain.com/exchange

    2、Set-OWAVirtualDirectory “Ex2010Srv”\OWA* -LegacyRedirectType  Manual

    3、It's ok.

    Saturday, April 23, 2011 3:08 AM
  • Hi,

    I have the same problem and I want to use the CAS2010 instead as the 2003 will retire. Can I disable the server redirection?

     

    Thank you,

     

    Friday, May 27, 2011 4:24 PM
  • Thank you Elie - This post greatly assisted me. Essentially I was encountering the same issue as ZID, although with a slight modification of your code was able to correct the problem. As follows:

    Set-OWAVirtualDirectory -identity E2K10CASHUB\OWA* -ExternalURL https://mail.corporation.com/OWA -Exchange2003URL https://email.corporation.com/exchange

     

    Thursday, September 08, 2011 1:49 PM
  • I just figured out it doesn't work without SSL... Only if you set the LegacyRedirectType to manual.
    Wednesday, October 26, 2011 12:00 PM
  • If I have a cas array, can I configure that to point to the cas array instead of an individual  CAS?
    Thursday, December 15, 2011 4:54 AM