none
Policy command missing from the ribbon in Outlook 2010

    Question

  • We're running Exchange 2010 SP1 and have an Enterprise CAL license. We're testing archiving and retention policies right now for use in Outlook 2010. We're running Office 2010 Professional Plus.

    We've created a single, default retention tag to target all folders in our mailboxes and then move them Archive after 30 days. We created a Retention Policy with that tag, as well as a few Personal Tags for testing. We applied them to two existing mailboxes. We ran the Mailbox Attendant and it ran perfectly. All looks well except we cannot see the Policy command button on the folder ribbon bar in Outlook 2010. Also we cannot see the Assign Policy button on the Home tab.

    Is there something else we need to do so that we can display these?


    Orange County District Attorney
    Wednesday, January 26, 2011 11:14 PM

Answers

  • After adding personal tags you may need to wait until the managed folder assistant processes the mailbox again before they'll show up. You can force it by running Start-ManagedFolderAssistant <MailboxIdentity>.

    I just tested this in my lab. I used a retention policy with one folder having a RPT on it. With no personal tags the "Apply Policy" button is not in the Outlook ribbon or the right-click menu. After adding a personal tag to the retention policy and running Start-ManagedFolderAssistant the buttons and tag showed up after closing/opening Outlook.


    Microsoft Premier Field Engineer, Exchange
    MCSA 2000/2003, CCNA
    MCITP: Enterprise Messaging Administrator 2010
    Former Microsoft MVP, Exchange Server
    My posts are provided “AS IS” with no guarantees, no warranties, and they confer no rights.
    • Marked as answer by Sandy Wood Thursday, January 27, 2011 3:23 PM
    Thursday, January 27, 2011 1:41 AM

All replies

  • Hi Sandy,

    Besides those issues, the archive does appear and is accessible in Outlook? How long has it been since the Personal tags were added to the Rention Policy, or have they been in it the whole time?

    When using OWA, do you have the ability to choose the different personal tags and apply them to items or folders?

     


    Microsoft Premier Field Engineer, Exchange
    MCSA 2000/2003, CCNA
    MCITP: Enterprise Messaging Administrator 2010
    Former Microsoft MVP, Exchange Server
    My posts are provided “AS IS” with no guarantees, no warranties, and they confer no rights.
    Wednesday, January 26, 2011 11:33 PM
  • Hello Brian,

    The archive does appear and is accessible in Outlook. Also in OWA too.

    We just created the retention policy this afternoon, it's only a few hours old. We added the personal tags to the policy about an hour ago.

    We don't have the ability to choose any tags in OWA.


    Orange County District Attorney
    Wednesday, January 26, 2011 11:41 PM
  • After adding personal tags you may need to wait until the managed folder assistant processes the mailbox again before they'll show up. You can force it by running Start-ManagedFolderAssistant <MailboxIdentity>.

    I just tested this in my lab. I used a retention policy with one folder having a RPT on it. With no personal tags the "Apply Policy" button is not in the Outlook ribbon or the right-click menu. After adding a personal tag to the retention policy and running Start-ManagedFolderAssistant the buttons and tag showed up after closing/opening Outlook.


    Microsoft Premier Field Engineer, Exchange
    MCSA 2000/2003, CCNA
    MCITP: Enterprise Messaging Administrator 2010
    Former Microsoft MVP, Exchange Server
    My posts are provided “AS IS” with no guarantees, no warranties, and they confer no rights.
    • Marked as answer by Sandy Wood Thursday, January 27, 2011 3:23 PM
    Thursday, January 27, 2011 1:41 AM
  • Thanks Brian, your suggestion worked for me. I can now see the "Apply Policy" button now.

    From what I've read in Technet, it appears that I'll need to 'configure' the Managed Folder Assistant so that it will do this for me, correct? The example Technet gives shows this command to configure the Assistant to process all mailboxes within a day

    Set-MailboxServer MyMailboxServer -ManagedFolderWorkCycle 1

    Once done, shouldn't this eliminate the need to manually run Start-ManagedFolderAssistant <MailboxIdentitly> on each individual mailbox?


    Orange County District Attorney
    Thursday, January 27, 2011 3:12 PM
  • In SP1 the Managed Folder Assistant runs 24x7 as a throttled process meaning we'll pause/resume it as necessary if the server needs more resources. There is no scheduling it in SP1 (there was in RTM), and using Start-ManagedFolderAssistant simply forces the MFA to stop processing whatever mailbox it is currently doing and process the mailbox you specified at that time. Once done with that mailbox it will go back and pick up where it left off before.

    By default the ManagedFolderWorkCycle is set to 1 day, which will require the mailbox server to process all mailboxes on the server at least once every 24 hours.

    You can check your current settings with Get-MailboxServer | FT Name,ManagedFolderW* and it should be 1.00:00:00.

     


    Microsoft Premier Field Engineer, Exchange
    MCSA 2000/2003, CCNA
    MCITP: Enterprise Messaging Administrator 2010
    Former Microsoft MVP, Exchange Server
    My posts are provided “AS IS” with no guarantees, no warranties, and they confer no rights.
    Thursday, January 27, 2011 3:18 PM
  • OK, I understand. So if I had waited long enough, the Apply Policy button would have appeared eventually, at least by the end of the 1 day work cycle.

    I checked my current settings and I'm at 1.00:00:00

     

    Thanks again for the help!


    Orange County District Attorney
    Thursday, January 27, 2011 3:23 PM
  • You're welcome! :)
    Microsoft Premier Field Engineer, Exchange
    MCSA 2000/2003, CCNA
    MCITP: Enterprise Messaging Administrator 2010
    Former Microsoft MVP, Exchange Server
    My posts are provided “AS IS” with no guarantees, no warranties, and they confer no rights.
    Thursday, January 27, 2011 3:35 PM
  • Hello Brian,

    I just recently updated to SP1 and am having the same issue.  I created a test policy and added 2 tags to it.  The default 1 month delete tag as well as a delete items older than a day tag.  I have issued the following command on the exchange server which forces the mailbox to abide by the policy.  Start-ManagedFolderAssistant –Mailbox 

    What I am not seeing is the Policy sections that should be available within Outlook.  I've tried every almost everything that I've found from the web, but nothing seems to allow it through.  I am able to view these policies within OWA, so I am confused at this point.   

    Exchange 2010 SP1 rollup 2 - standard

    I am not using premium cals.

    thanks

    Monday, March 14, 2011 5:24 PM
  • What version of Outlook is it? And is it a Volume License edition or not?
    Microsoft Premier Field Engineer, Exchange
    MCSA 2000/2003, CCNA
    MCITP: Enterprise Messaging Administrator 2010
    Former Microsoft MVP, Exchange Server
    My posts are provided “AS IS” with no guarantees, no warranties, and they confer no rights.
    Monday, March 14, 2011 5:51 PM
  • outlook 2010 std.

    It is Volume License.

    Monday, March 14, 2011 5:55 PM
  • I have the exact same issue as Michael_6835 and a month has passed since the retention policy with a tag has been applied. I've also manually applied it multiple times using: Start-ManagedFolderAssistant -Identity user

    I see the policies in OWA, but there's no button in the Ribbon or a tab (right click on Deleted Items\Properties) in Outlook 2010 Standard (VLSC). I'm running Exchange 2010 SP1 Version 14.1 (Build 218.15).

    Any ideas, solutions?

     

    Tuesday, June 21, 2011 9:09 AM
  • I have the exact same issue as Michael_6835 and a month has passed since the retention policy with a tag has been applied. I've also manually applied it multiple times using: Start-ManagedFolderAssistant -Identity user

    I see the policies in OWA, but there's no button in the Ribbon or a tab (right click on Deleted Items\Properties) in Outlook 2010 Standard (VLSC). I'm running Exchange 2010 SP1 Version 14.1 (Build 218.15).

    Any ideas, solutions?

     

    We are having the exact same issue.

    The policies show up in OWA but there's no button in the Ribbon or a tab in Outlook 2010.


    Zay Yar
    Wednesday, July 06, 2011 6:15 AM
  • Just tested the issue again on a machine with Outlook 2010 SP1 installed. I can see the buttons in the Ribbon now.

    It seems to be an issue with Outlook 2010 RTM version.

    Hope, it helps.

     


    Zay Yar
    Wednesday, July 06, 2011 6:52 AM
  • zay yar, I just checked since rolling out SP1 for Office 2010, but I still don't see them in Outlook. It's not a huge issue, but an inconsistency nonetheless, which I'd rather see resolved.

    Tuesday, July 26, 2011 6:27 AM
  • I'm having the same trouble as several others here... I have Outlook 2010 SP1 installed, I created the tags, applied to a policy, applied the policy to all users, and ran the ManagedFolderAssistant. I'm not seeing the usual signs in Outlook of the policy:

    • No "Retention Policy" information in the Reading Pane
    • No "Policy" tab on the Outlook folder properties
    • No "Policy" button on the "Folder" Ribbon tab
    • No "Add or Remove Retention Policies" on the File > Account Settings button
    • No "Retention Policy" bar at the bottom of messages

    I do see it on my desktop computer (cached mode) with my own logon using my own mailbox. I don't see it on my laptop (cached mode) with my own logon using my own mailbox, so that leads me to believe it's something specific to Outlook.

    Tuesday, August 02, 2011 7:32 PM
  • Also depends on version of Outlook you are running. We had the same problem, visible in OWA but not in Outlook. We had a volume license of Office 2010 standard, which after reading the following article explained why we couldn't see the policies in Outlook. The following may explain why it is not working in your environment, this fixed it for us:

    http://office.microsoft.com/en-us/outlook-help/license-requirements-for-personal-archive-and-retention-policies-HA102576659.aspx?CTT=3

    • Proposed as answer by Nedim Sahin Saturday, September 07, 2013 9:16 PM
    Tuesday, July 10, 2012 10:30 AM
  • Thanks NemoTec! It worked for me

    RSS Facebook Youtube Twitter Linkedin

    Saturday, September 07, 2013 9:17 PM