none
unable to mount database

    Question

  • Hi Experts,

    Suddenly My databse is dismounted and services are down. hen I'm trying to create new DB as dial-tone its not getting mounted. Im getting below mentioned error.

     

    Mount Test09
    Failed

    Error:
    Exchange is unable to mount the database that you specified. Specified database: AUSCLMBX01\First Storage Group\Test09; Error code: MapiExceptionCallFailed: Unable to mount database. (hr=0x80004005, ec=-515)
    .

    Exchange Management Shell command attempted:
    mount-database -Identity 'CN=Test09,CN=First Storage Group,CN=InformationStore,CN=AUSCLMBX01,CN=Servers,CN=Exchange Administrative Group (FYDIBOHF23SPDLT),CN=Administrative Groups,CN=hosting,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=AUSTRA,DC=COM'

    Elapsed Time: 00:00:02

    Its exchange server 2007-Ent.

     

     


    Regards Suman B. Singh
    Tuesday, November 22, 2011 8:09 AM

All replies

  • Hi Experts,

    Suddenly My databse is dismounted and services are down. hen I'm trying to create new DB as dial-tone its not getting mounted. Im getting below mentioned error.

     

    Mount Test09
    Failed

    Error:
    Exchange is unable to mount the database that you specified. Specified database: AUSCLMBX01\First Storage Group\Test09; Error code: MapiExceptionCallFailed: Unable to mount database. (hr=0x80004005, ec=-515)
    .

    Exchange Management Shell command attempted:
    mount-database -Identity 'CN=Test09,CN=First Storage Group,CN=InformationStore,CN=AUSCLMBX01,CN=Servers,CN=Exchange Administrative Group (FYDIBOHF23SPDLT),CN=Administrative Groups,CN=hosting,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=AUSTRA,DC=COM'

    Elapsed Time: 00:00:02

    Its exchange server 2007-Ent.

     

     


    Regards Suman B. Singh

    Hi, what is the reason that you have down mailbox database? Is it no free space on the disk with transaction logs or what?

    see also:

    http://social.technet.microsoft.com/Forums/en-US/exchangesvravailabilityandisasterrecovery/thread/4d1f1ec0-afa7-4a97-af2c-896f3d3c2abb/


    Petr Weiner
    Tuesday, November 22, 2011 8:25 AM
  • Hi Petr,

    I observed that AV has quarantined some filed but I restored them successfully. There is not any space issue.

     


    Regards Suman B. Singh
    Tuesday, November 22, 2011 8:50 AM
  • Hi Petr,

    I observed that AV has quarantined some filed but I restored them successfully. There is not any space issue.

     


    Regards Suman B. Singh
    So it was an antivirus issue. Are you able mount DB just now?

    Petr Weiner
    Tuesday, November 22, 2011 8:53 AM
  • No. Im not. Still same issue. Can we find out which log/s are missing and rebuild them?
    Regards Suman B. Singh
    Tuesday, November 22, 2011 9:17 AM
  • No. Im not. Still same issue. Can we find out which log/s are missing and rebuild them?
    Regards Suman B. Singh
    I suppose that you are missing the files which has been stolen by antivirus. You can recover them from backup. First of all stop the antivirus on the server and try to mount DB.

    Petr Weiner
    Tuesday, November 22, 2011 9:24 AM
  • Hi petr,

    Can we recover emails from uncommitted log files? I just observed that Backup is not happened and log files are still there since last 3 months.


    Regards Suman B. Singh
    Tuesday, November 22, 2011 1:17 PM
  • Hi petr, Can we recover emails from uncommitted log files? I just observed that Backup is not happened and log files are still there since last 3 months.
    Regards Suman B. Singh
    Did you check the log via eseutil? I´m asking, because you wrote they are uncommited. If logs are uncommited it indicates that information which contains are not written to your database. If you have enought space so you have to make a copy of these logs to another location for sure.
    Exchange 2007 DB recovery tools:
    http://technet.microsoft.com/en-us/library/aa998611%28EXCHG.80%29.aspx


    Petr Weiner
    Tuesday, November 22, 2011 1:34 PM
  • Hi

    We tried to use Eseutil /ml “Path of the log files\log prefix and there were lots of files missing. Logs are more than 250GB so we decided to use dial tone assuming backup is there and can be recovered from RSG.

    Yes we do have sufficientther space. As 300 GB (data and log) was taking so long time so we renamed First storage group (First_storage_group) and created another Folder called "First Storage Group" as it as in real and mounted blank DB. This DB mounted successfully.

     

    Now when we started to add in RSG it threw attached error and found that logs are still there. Came to know Server 2008 only takes full Drives backup rather than Exchange Backup and commits logs in DB.

    I have logs and the Original EDB, please help me to recover data from those LOGs.

     

     

     

     

     


    Regards Suman B. Singh
    Tuesday, November 22, 2011 1:51 PM
  • Hi

    We tried to use Eseutil /ml “Path of the log files\log prefix and there were lots of files missing. Logs are more than 250GB so we decided to use dial tone assuming backup is there and can be recovered from RSG.

    Yes we do have sufficientther space. As 300 GB (data and log) was taking so long time so we renamed First storage group (First_storage_group) and created another Folder called "First Storage Group" as it as in real and mounted blank DB. This DB mounted successfully.

     

    Now when we started to add in RSG it threw attached error and found that logs are still there. Came to know Server 2008 only takes full Drives backup rather than Exchange Backup and commits logs in DB.

    I have logs and the Original EDB, please help me to recover data from those LOGs.

     

     

     

     

     

     


    Regards Suman B. Singh

    Check this link:

    http://www.mikepfeiffer.net/2010/04/getting-an-exchange-database-into-a-clean-shutdown-state-using-eseutil/

     


    Petr Weiner
    • Edited by Petr Weiner Tuesday, November 22, 2011 2:03 PM
    Tuesday, November 22, 2011 2:00 PM
  • Hi Petr

    Here is the output that we tried to follow.


    Extensible Storage Engine Utilities for Microsoft(R) Exchange Server
    Version 08.02
    Copyright (C) Microsoft Corporation. All Rights Reserved.

    Initiating FILE DUMP mode...
             Database: G:\Exchange\FirstStorageGroup\MailboxDatabase.edb

            File Type: Database
       Format ulMagic: 0x89abcdef
       Engine ulMagic: 0x89abcdef
     Format ulVersion: 0x620,12
     Engine ulVersion: 0x620,12
    Created ulVersion: 0x620,12
         DB Signature: Create time:12/18/2009 23:46:18 Rand:3666067 Computer:
             cbDbPage: 8192
               dbtime: 412141612 (0x1890c82c)
                State: Dirty Shutdown
         Log Required: 196508-196509 (0x2ff9c-0x2ff9d)
        Log Committed: 0-196510 (0x0-0x2ff9e)
       Streaming File: No
             Shadowed: Yes
           Last Objid: 337570
         Scrub Dbtime: 0 (0x0)
           Scrub Date: 00/00/1900 00:00:00
         Repair Count: 0
          Repair Date: 00/00/1900 00:00:00
     Old Repair Count: 0
      Last Consistent: (0x2B8CD,52C,1B9)  11/11/2011 03:19:17
          Last Attach: (0x2B8CE,9,86)  11/11/2011 03:19:17
          Last Detach: (0x0,0,0)  00/00/1900 00:00:00
                 Dbid: 1
        Log Signature: Create time:12/18/2009 23:46:18 Rand:3648382 Computer:
           OS Version: (6.0.6002 SP 2 NLS 500100.50100)

    Previous Full Backup:
            Log Gen: 0-0 (0x0-0x0)
               Mark: (0x0,0,0)
               Mark: 00/00/1900 00:00:00

    Previous Incremental Backup:
            Log Gen: 0-0 (0x0-0x0)
               Mark: (0x0,0,0)
               Mark: 00/00/1900 00:00:00

    Previous Copy Backup:
            Log Gen: 0-0 (0x0-0x0)
               Mark: (0x0,0,0)
               Mark: 00/00/1900 00:00:00

    Previous Differential Backup:
            Log Gen: 0-0 (0x0-0x0)
               Mark: (0x0,0,0)
               Mark: 00/00/1900 00:00:00

    Current Full Backup:
            Log Gen: 0-0 (0x0-0x0)
               Mark: (0x0,0,0)
               Mark: 00/00/1900 00:00:00

    Current Shadow copy backup:
            Log Gen: 0-0 (0x0-0x0)
               Mark: (0x0,0,0)
               Mark: 00/00/1900 00:00:00

         cpgUpgrade55Format: 0
        cpgUpgradeFreePages: 0
    cpgUpgradeSpaceMapPages: 0

           ECC Fix Success Count: none
       Old ECC Fix Success Count: none
             ECC Fix Error Count: none
         Old ECC Fix Error Count: none
        Bad Checksum Error Count: none
    Old bad Checksum Error Count: none

    Operation completed successfully in 2.31 seconds.


    C:\Program Files\Microsoft\Exchange Server\Bin>



























    Tuesday, November 22, 2011 2:13 PM
  • Hi Petr

    Here is the output that we tried to follow.


    Extensible Storage Engine Utilities for Microsoft(R) Exchange Server
    Version 08.02
    Copyright (C) Microsoft Corporation. All Rights Reserved.

    Initiating FILE DUMP mode...
             Database: G:\Exchange\FirstStorageGroup\MailboxDatabase.edb

            File Type: Database
       Format ulMagic: 0x89abcdef
       Engine ulMagic: 0x89abcdef
     Format ulVersion: 0x620,12
     Engine ulVersion: 0x620,12
    Created ulVersion: 0x620,12
         DB Signature: Create time:12/18/2009 23:46:18 Rand:3666067 Computer:
             cbDbPage: 8192
               dbtime: 412141612 (0x1890c82c)
                State: Dirty Shutdown
         Log Required: 196508-196509 (0x2ff9c-0x2ff9d)
        Log Committed: 0-196510 (0x0-0x2ff9e)
       Streaming File: No
             Shadowed: Yes
           Last Objid: 337570
         Scrub Dbtime: 0 (0x0)
           Scrub Date: 00/00/1900 00:00:00
         Repair Count: 0
          Repair Date: 00/00/1900 00:00:00
     Old Repair Count: 0
      Last Consistent: (0x2B8CD,52C,1B9)  11/11/2011 03:19:17
          Last Attach: (0x2B8CE,9,86)  11/11/2011 03:19:17
          Last Detach: (0x0,0,0)  00/00/1900 00:00:00
                 Dbid: 1
        Log Signature: Create time:12/18/2009 23:46:18 Rand:3648382 Computer:
           OS Version: (6.0.6002 SP 2 NLS 500100.50100)

    Previous Full Backup:
            Log Gen: 0-0 (0x0-0x0)
               Mark: (0x0,0,0)
               Mark: 00/00/1900 00:00:00

    Previous Incremental Backup:
            Log Gen: 0-0 (0x0-0x0)
               Mark: (0x0,0,0)
               Mark: 00/00/1900 00:00:00

    Previous Copy Backup:
            Log Gen: 0-0 (0x0-0x0)
               Mark: (0x0,0,0)
               Mark: 00/00/1900 00:00:00

    Previous Differential Backup:
            Log Gen: 0-0 (0x0-0x0)
               Mark: (0x0,0,0)
               Mark: 00/00/1900 00:00:00

    Current Full Backup:
            Log Gen: 0-0 (0x0-0x0)
               Mark: (0x0,0,0)
               Mark: 00/00/1900 00:00:00

    Current Shadow copy backup:
            Log Gen: 0-0 (0x0-0x0)
               Mark: (0x0,0,0)
               Mark: 00/00/1900 00:00:00

         cpgUpgrade55Format: 0
        cpgUpgradeFreePages: 0
    cpgUpgradeSpaceMapPages: 0

           ECC Fix Success Count: none
       Old ECC Fix Success Count: none
             ECC Fix Error Count: none
         Old ECC Fix Error Count: none
        Bad Checksum Error Count: none
    Old bad Checksum Error Count: none

    Operation completed successfully in 2.31 seconds.


    C:\Program Files\Microsoft\Exchange Server\Bin>



























    You have DB in "Dirty Shutdown" state so you have to continue as is written in link I sent (you have to have DB in clean shutdown state). As I can see-you never did not do a backup of Exchange...

    Petr Weiner

    • Edited by Petr Weiner Tuesday, November 22, 2011 2:45 PM
    Tuesday, November 22, 2011 2:35 PM
  • Ok.. But e are taking full Drives backup using Windows server backup tool. Can't it help us?
    Regards Suman B. Singh
    Tuesday, November 22, 2011 2:53 PM
  • Ok.. But e are taking full Drives backup using Windows server backup tool. Can't it help us?
    Regards Suman B. Singh

    I´m not sure that you really did full backup via Windows Server Backup because of the eseutil log you sent:

    Previous Full Backup:
            Log Gen: 0-0 (0x0-0x0)
               Mark: (0x0,0,0)
               Mark: 00/00/1900 00:00:00

    When did you do a backup and what is your backup schedule? If you did backup after your DB crashed so it is too late and bad.

     


    Petr Weiner
    • Edited by Petr Weiner Tuesday, November 22, 2011 2:59 PM
    Tuesday, November 22, 2011 2:58 PM
  • It as done on 17/11/2011.

    We take full backup on every month.


    Regards Suman B. Singh
    Tuesday, November 22, 2011 3:10 PM
  • It as done on 17/11/2011.

    We take full backup on every month.


    Regards Suman B. Singh
    When the full backup is done than all commited transaction logs are deleted from the disk and backup records itto the .chk file info about last full backup. I think that the easiest way will be try to make the old DB to clean shutdown state. How many MB of the transaction log are not commited to the DB?

    Petr Weiner
    • Edited by Petr Weiner Tuesday, November 22, 2011 3:15 PM
    Tuesday, November 22, 2011 3:15 PM
  • Its only one. DB.

    I heard Windows server backup is not exchange aware backup to doesnot commit logs. Its it true?


    Regards Suman B. Singh
    Tuesday, November 22, 2011 3:21 PM
  • Its only one. DB.

    I heard Windows server backup is not exchange aware backup to doesnot commit logs. Its it true?


    Regards Suman B. Singh

    I´m not sure about Exch. 2007 vs Win.Server 2008 now. It was good use 3rd party backup SW here when Win 2008 edition started. In Windows Server 2008 R2 with Exch. 2010 works well.

    Check this link, please:

    http://technet.microsoft.com/en-us/library/aa997761%28EXCHG.65%29.aspx


    Petr Weiner

    • Edited by Petr Weiner Tuesday, November 22, 2011 3:30 PM
    Tuesday, November 22, 2011 3:29 PM
  • Its only one. DB.

    I heard Windows server backup is not exchange aware backup to doesnot commit logs. Its it true?


    Regards Suman B. Singh

    I´m not sure about Exch. 2007 vs Win.Server 2008 now. It was good use 3rd party backup SW here when Win 2008 edition started. In Windows Server 2008 R2 with Exch. 2010 works well.

    Check this link, please:

    http://technet.microsoft.com/en-us/library/aa997761%28EXCHG.65%29.aspx


    Petr Weiner

    How it looks just now? Any progress?

    Petr Weiner
    Wednesday, November 23, 2011 1:06 PM
  • I hope you have Exclusion set in AV for exchange files.
    Gulab | MCITP: Exchange 2010-2007 | Lync Server 2010 | Windows Server 2008 | Skype: Exchange.Ranger | Blog: www.ExchangeRanger.Blogspot.com
    Thursday, November 24, 2011 7:03 AM
  • Hi,

    1) You should have full backup of well running state. Else try to change shutdown state of database from dirty to clean and then try to mount it.

    2) You heard wrong, Windows server backp is perfectly fine but you should have Exchange 2007 sp-2.

    3) Once your database is mounted , immedietely perform full backup so that all logs can be committed.

     

     

    Thanks

    Amit Rawat

    Thursday, November 24, 2011 2:47 PM
  • Any progress !

    Amit Rawat | MCITP - Exchange 2007/2010| CCNA |MCSE- 2003| Lync 2010|

    Tuesday, February 21, 2012 1:32 PM
  • Hello Sword Maker,

    I see that the database is in Dirty Shutdown with two log files required.  "Log Required: 196508-196509 (0x2ff9c-0x2ff9d)"

    Please check the log files for Log files 0x2ff9c & 0x2ff9d. If they are present, move them to a temporary folder and run the eseutil /ml command on by specifying the path of the temp folder. The command should look like this:

    Eseutil /ml "path of the temp folder\E00"

    If both the files pass the consistency check, run the following command to bring it to a state of clean shutdown :

    eseutil /r e00 /l "path of log files" /d "path of database"

    Path of Log files would be the temporary log files folder we specified.

    Please let me know if you have any queries.

    Cheers!

                                       


    - Ayyappan Pillai MCITP, Microsoft Enterprise Messaging Admin

    Thursday, June 28, 2012 5:34 AM