none
exchange 2010 Web APP mail delete

    Question

  • Hi,

    I have the following problem on Exchange 2010 sp1 Outlook web app. When I try to delete an email it comes up with the following error

    "Your network connection isn't available. If the problem continues, contact your helpdesk with this HTTP Status code: 0." Does anybody know how to fix this?

    Thanks

    Wednesday, September 08, 2010 8:55 AM

Answers

All replies

  • That sounds like it isn't getting any response back. Are you trying this on the same box as the server or on a workstation somewhere? Can you try this on the server? If it is still not responding, then something is wrong at the server side. Can you confirm that?

    Regards, Kip Ng - http://blogs.technet.com/b/provtest/
    Thursday, September 09, 2010 12:31 AM
  • Have you resolved the issue? Let us know if you still need help on this.
    Regards, Kip Ng - http://blogs.technet.com/b/provtest/
    Tuesday, September 14, 2010 1:18 PM
  • I have the same problem. If I open the email and then click on the delete icon, the email gets deleted.

    If I select the email, but don't open it, and click delete, I get the same error as noted above.

    Exchange 2010.

    Thursday, September 16, 2010 1:40 PM
  • Are you doing this on the server itself? Are you running on Exchange 2010 SP1 RTM or beta?
    Regards, Kip Ng - http://blogs.technet.com/b/provtest/
    Thursday, September 16, 2010 3:57 PM
  • Exchange 2010 Enterprise edition with SP1.

     

    Thursday, September 16, 2010 8:53 PM
  • This issue occurs when accessing OWA from a workstation connected to the LAN or from a home computer.

     

    Thursday, September 16, 2010 8:54 PM
  • Do you face the problem when you try to do that on the CAS? If yes, then the troubleshooting will start at the server side. If no, then the problem should be in between such as it could be OWA publishing issue or etc.

    Regards, Kip Ng - http://blogs.technet.com/b/provtest/
    Friday, September 17, 2010 12:18 AM
  • We don't have CAS.

    We don't have UC.

    We don't have instant messenging.

    The only server we have for commications of any kind is Microsoft Exchange Enterprise 2010 with SP1.

    The issue occurs with Outlook Web App regardless of whether it is used locally or remotely.

    Please note....if we open the email, then try to delete it, the deletion is successful.

    If you do not open the email, you can't delete it.

    I believe this to be a bug, but can't find anything on technet to help.

     

     

     

     

    Friday, September 17, 2010 1:11 PM
  • If you have any client connections(including Web App) to Exchange then you have a CAS (Client Access Server). Have you tried www.testexchangeconnectivity.com. Specifically Exchange Web Services. I have a test box where I cant delete mail and it appears to do with the Exchange Web Services setup.
    Friday, September 17, 2010 8:46 PM
  • i have the same error!

    4 Exchange Servers (2 DB + 2 CAS NLB Cluster) all Exchange 2010 SP1

    i try it from all the server and many PC all the same error!

    Tuesday, September 28, 2010 7:04 AM
  • We installed Exchange 2010 SP1 last night and now our Outlook Web App users are experiencing this same issue.  Delete does not work (unless you open the email first and then delete it).  You also cannot drag-drop a message to a folder.  It comes up with the same error message: "Your network connection isn't available. If the problem continues, contact your helpdesk with this HTTP Status code: 0."
    Jim Nicol
    Monday, October 04, 2010 5:35 PM
  • And what appears to be a possibly related issue, in Outlook Web App, when a user clicks on any of the Options (Set Automatic Replies..., Change Your Password..., etc.), the user is immediately prompted to log back in -- and the system won't accept the user's password that they enter.  They have to exit that browser (IE) session and start all over again.  Is anyone else experiencing this issue?
    Jim Nicol
    Monday, October 04, 2010 5:58 PM
  • No, Jim. I didn't encounter any issue on the password change. It works fine for me.


    Regards, Kip Ng - http://blogs.technet.com/b/provtest/
    Wednesday, October 06, 2010 3:11 AM
  • This is realy interesting. I did not see this issue on my box at all. This almost seems like there is a problem with the powershell website or something wrong with the binding or EWS.

    Check a few things,

    1. Did you disable IPv6? If yes, can you try to enable it?

    2. Try to bind localhost (127.0.0.1) to the IIS as well.

    3. Here is what I have on my authentication, just for your comparison in case you changed it,

    EWS - InternalAuthenticationMethod and ExternalAuthenticationMethod - {ntlm, windowsintegrated, WSSecurity}

    OWA - ExternalAuthenticationMethods - {fba}, InternalAuthenticationMethod - {basic, fba}

     


    Regards, Kip Ng - http://blogs.technet.com/b/provtest/
    Wednesday, October 06, 2010 3:25 AM
  • And what appears to be a possibly related issue, in Outlook Web App, when a user clicks on any of the Options (Set Automatic Replies..., Change Your Password..., etc.), the user is immediately prompted to log back in -- and the system won't accept the user's password that they enter.  They have to exit that browser (IE) session and start all over again.  Is anyone else experiencing this issue?
    Jim Nicol

    Jim, I had this problem as well, but it was resolved by changing the authentication on the ECP virtual directory to include windows authentication.

     

    I am also having this problem with the http status code 0.  Opening the message, I can delete - also, using the light version of OWA works properly.

    I have removed/reimported certificates, removed and recreated all virtual directories, and continue to get the message when attempting to delete, move, or copy messages from the main screen.

    • Edited by GregRussell Thursday, October 07, 2010 3:07 PM Added post responding to.
    Thursday, October 07, 2010 5:54 AM
  • This is realy interesting. I did not see this issue on my box at all. This almost seems like there is a problem with the powershell website or something wrong with the binding or EWS.

    Check a few things,

    1. Did you disable IPv6? If yes, can you try to enable it?

    2. Try to bind localhost (127.0.0.1) to the IIS as well.

    3. Here is what I have on my authentication, just for your comparison in case you changed it,

    EWS - InternalAuthenticationMethod and ExternalAuthenticationMethod - {ntlm, windowsintegrated, WSSecurity}

    OWA - ExternalAuthenticationMethods - {fba}, InternalAuthenticationMethod - {basic, fba}

     


    Regards, Kip Ng - http://blogs.technet.com/b/provtest/


    Kip,

    1) Thanks for the ideas - I have tried ipv6 on and off and it made no difference.

    2) I initially had bindings for 127.0.0.1 for the server but removed them while troubleshooting.  I also verified there were no host headers just for good measure. 

    3) Those authentication methods are what I have as well. 

    Perhaps one of the other settings?  Here is my owavirtualdirectory settings:

     

    RunspaceId                     : 0f4ba880-c69f-48a9-b39f-c50826159fec
    DirectFileAccessOnPublicComputersEnabled      : True
    DirectFileAccessOnPrivateComputersEnabled      : True
    WebReadyDocumentViewingOnPublicComputersEnabled   : True
    WebReadyDocumentViewingOnPrivateComputersEnabled  : True
    ForceWebReadyDocumentViewingFirstOnPublicComputers : False
    ForceWebReadyDocumentViewingFirstOnPrivateComputers : False
    RemoteDocumentsActionForUnknownServers       : Block
    ActionForUnknownFileAndMIMETypes          : ForceSave
    WebReadyFileTypes                  : {.xlsx, .pptx, .docx, .xls, .rtf, .ppt, .pps, .pdf, .dot, .doc}
    WebReadyMimeTypes                  : {application/vnd.openxmlformats-officedocument.presentationml.pre
                               sentation, application/vnd.openxmlformats-officedocument.wordproc
                               essingml.document, application/vnd.openxmlformats-officedocument.
                               spreadsheetml.sheet, application/vnd.ms-powerpoint, application/x
                               -mspowerpoint, application/vnd.ms-excel, application/x-msexcel, a
                               pplication/msword, application/pdf}
    WebReadyDocumentViewingForAllSupportedTypes     : True
    WebReadyDocumentViewingSupportedMimeTypes      : {application/msword, application/vnd.ms-excel, application/x-msex
                               cel, application/vnd.ms-powerpoint, application/x-mspowerpoint, a
                               pplication/pdf, application/vnd.openxmlformats-officedocument.wor
                               dprocessingml.document, application/vnd.openxmlformats-officedocu
                               ment.spreadsheetml.sheet, application/vnd.openxmlformats-officedo
                               cument.presentationml.presentation}
    WebReadyDocumentViewingSupportedFileTypes      : {.doc, .dot, .rtf, .xls, .ppt, .pps, .pdf, .docx, .xlsx, .pptx}
    AllowedFileTypes                  : {.rpmsg, .xlsx, .xlsm, .xlsb, .tiff, .pptx, .pptm, .ppsx, .ppsm, 
                               .docx, .docm, .zip, .xls, .wmv, .wma, .wav...}
    AllowedMimeTypes                  : {image/jpeg, image/png, image/gif, image/bmp}
    ForceSaveFileTypes                 : {.vsmacros, .ps2xml, .ps1xml, .mshxml, .gadget, .psc2, .psc1, .as
                               px, .wsh, .wsf, .wsc, .vsw, .vst, .vss, .vbs, .vbe...}
    ForceSaveMimeTypes                 : {Application/x-shockwave-flash, Application/octet-stream, Applica
                               tion/futuresplash, Application/x-director}
    BlockedFileTypes                  : {.vsmacros, .msh2xml, .msh1xml, .ps2xml, .ps1xml, .mshxml, .gadge
                               t, .mhtml, .psc2, .psc1, .msh2, .msh1, .aspx, .xml, .wsh, .wsf...
                               }
    BlockedMimeTypes                  : {application/x-javascript, application/javascript, application/ms
                               access, x-internet-signup, text/javascript, application/xml, appl
                               ication/prg, application/hta, text/scriplet, text/xml}
    RemoteDocumentsAllowedServers            : {}
    RemoteDocumentsBlockedServers            : {}
    RemoteDocumentsInternalDomainSuffixList       : {}
    FolderPathname                   : 
    Url                         : {}
    LogonFormat                     : FullDomain
    ClientAuthCleanupLevel               : High
    FilterWebBeaconsAndHtmlForms            : UserFilterChoice
    NotificationInterval                : 120
    DefaultTheme                    : 
    UserContextTimeout                 : 60
    ExchwebProxyDestination               : 
    VirtualDirectoryType                : 
    OwaVersion                     : Exchange2010
    ServerName                     : TITAN
    InstantMessagingCertificateThumbprint        : 
    InstantMessagingServerName             : 
    RedirectToOptimalOWAServer             : True
    DefaultClientLanguage                : 0
    LogonAndErrorLanguage                : 0
    UseGB18030                     : False
    UseISO885915                    : False
    OutboundCharset                   : AutoDetect
    GlobalAddressListEnabled              : True
    OrganizationEnabled                 : True
    ExplicitLogonEnabled                : True
    OWALightEnabled                   : True
    DelegateAccessEnabled                : True
    IRMEnabled                     : True
    CalendarEnabled                   : True
    ContactsEnabled                   : True
    TasksEnabled                    : True
    JournalEnabled                   : True
    NotesEnabled                    : True
    RemindersAndNotificationsEnabled          : True
    PremiumClientEnabled                : True
    SpellCheckerEnabled                 : True
    SearchFoldersEnabled                : True
    SignaturesEnabled                  : True
    ThemeSelectionEnabled                : True
    JunkEmailEnabled                  : True
    UMIntegrationEnabled                : True
    WSSAccessOnPublicComputersEnabled          : True
    WSSAccessOnPrivateComputersEnabled         : True
    ChangePasswordEnabled                : True
    UNCAccessOnPublicComputersEnabled          : True
    UNCAccessOnPrivateComputersEnabled         : True
    ActiveSyncIntegrationEnabled            : True
    AllAddressListsEnabled               : True
    RulesEnabled                    : True
    PublicFoldersEnabled                : True
    SMimeEnabled                    : True
    RecoverDeletedItemsEnabled             : True
    InstantMessagingEnabled               : True
    TextMessagingEnabled                : True
    ForceSaveAttachmentFilteringEnabled         : False
    SilverlightEnabled                 : True
    CalendarPublishingEnabled              : True
    InstantMessagingType                : None
    Exchange2003Url                   : https://legacy.removedURL.com/
    FailbackUrl                     : 
    LegacyRedirectType                 : Silent
    Name                        : owa (Default Web Site)
    InternalAuthenticationMethods            : {Basic, Fba}
    MetabasePath                    : IIS://TITAN.voyager.local/W3SVC/1/ROOT/owa
    BasicAuthentication                 : True
    WindowsAuthentication                : True
    DigestAuthentication                : False
    FormsAuthentication                 : True
    LiveIdAuthentication                : False
    DefaultDomain                    : 
    GzipLevel                      : High
    WebSite                       : Default Web Site
    DisplayName                     : owa
    Path                        : C:\Program Files\Microsoft\Exchange Server\V14\ClientAccess\owa
    ExtendedProtectionTokenChecking           : None
    ExtendedProtectionFlags               : {}
    ExtendedProtectionSPNList              : {}
    Server                       : TITAN
    InternalUrl                     : https://titan/owa
    ExternalUrl                     : https://www.removedURL.com/owa
    ExternalAuthenticationMethods            : {Fba}
    AdminDisplayName                  : 
    ExchangeVersion                   : 0.10 (14.0.100.0)
    DistinguishedName                  : CN=owa (Default Web Site),CN=HTTP,CN=Protocols,CN=TITAN,CN=Server
                               s,CN=Exchange Administrative Group (FYDIBOHF23SPDLT),CN=Administr
                               ative Groups,CN=First Organization,CN=Microsoft Exchange,CN=Servi
                               ces,CN=Configuration,DC=voyager,DC=local
    Identity                      : TITAN\owa (Default Web Site)
    Guid                        : 37f33d7f-4fd0-4910-9f39-4fe162fc9b4d
    ObjectCategory                   : voyager.local/Configuration/Schema/ms-Exch-OWA-Virtual-Directory
    ObjectClass                     : {top, msExchVirtualDirectory, msExchOWAVirtualDirectory}
    WhenChanged                     : 10/4/2010 3:18:10 PM
    WhenCreated                     : 10/4/2010 1:00:52 PM
    WhenChangedUTC                   : 10/4/2010 10:18:10 PM
    WhenCreatedUTC                   : 10/4/2010 8:00:52 PM
    OrganizationId                   : 
    OriginatingServer                  : TITAN.voyager.local
    IsValid                       : True
    

    Is it possibly the fact that there was an exchange 2003 server coexisting?  Anybody else or is that just me?  I actually have the old server powered down now.  Mail is still flowing properly, but I still do not get any luck with this http status code 0 message. I'm getting low on ideas.

    Thursday, October 07, 2010 6:07 AM
  • Branching off of some advice in another thread: http://social.technet.microsoft.com/Forums/en-US/exchange2010/thread/26f46cfb-4335-4dd4-999d-301e70f89607

    Try deleting or renaming the web.config file in your ...inetpub\wwwroot folder

    After doing this, all of my emails are properly deleting from OWA without having to open the message.

    Thursday, October 07, 2010 3:27 PM
  • I just did this as well and everything now appears to be working!  I'm not sure what the presence of the web.config file does to cause this issue but the absence certainly fixed it.

    Thanks for the help!


    Jim Nicol
    Thursday, October 07, 2010 3:45 PM
  • Looks like you have a corrupted web.config then. Good to know it is fixed now.
    Regards, Kip Ng - http://blogs.technet.com/b/provtest/
    Thursday, October 07, 2010 3:54 PM
  • all that was in mine was:

    <?xml version="1.0" encoding="UTF-8"?>
    <configuration>
        <system.web>
            <authentication mode="Forms" />
        </system.web>
    </configuration>

    Seems strange that the web.config file in wwwroot would cause such a strange error in OWA.  iisreset did not rebuild the web.config file, but it has remained absent and this has allowed OWA to work properly.

    Thursday, October 07, 2010 4:41 PM
  • Hi,

    I had same problem deleting mail in OWA.

    I solved the problem renaming web.config file in inetpub/wwwroot.

    Thanks a lot

     

    By Stefano

    ITALY

    Tuesday, October 12, 2010 10:08 AM
  • Hi there,

     

    tried everything mentioned here... but we do not have a web.config file in inetpub... Any other ideas?

     

    Please advise

    Sunday, October 17, 2010 2:03 PM
  • Same error here opening it i can delete it..
    Tuesday, October 19, 2010 3:14 PM
  • Marcus,

    The web.config file is actually in c:\inetpub\wwwroot by default, not just in the inetpub folder itself.  Check there and see if you have anything present. If wwwroot is not your default website root folder, delete the web.config in your default web site's default folder (which is typically c:\inetpub\wwwroot)

     

    Trent,

    Did you try checking for the web.config file in the wwwroot folder mentioned above?  Yours is just  like mine was. If you are getting a Status Code 0 error this was all that needed to be done.

    • Edited by GregRussell Tuesday, October 19, 2010 7:56 PM updated for nonstandard default websites
    Tuesday, October 19, 2010 6:37 PM
  • I have been going nuts for a couple of days on this and eventually I solved all the issues (cant delete/move/attach files) by enabling anonomous access on the EWS and ECP directories..

     

    Im sure someone will tell me this is a bad idea and I am an exchange dunce - but its working after days of swaet and tears....

    Wednesday, October 27, 2010 3:42 PM
  • I have been going nuts for a couple of days on this and eventually I solved all the issues (cant delete/move/attach files) by enabling anonomous access on the EWS and ECP directories..

     

    Im sure someone will tell me this is a bad idea and I am an exchange dunce - but its working after days of swaet and tears....


    When I removed and recreated these directories, by default anonymous authentication is enabled.  I'm not sure why it would have been off on your installation unless you already had the virtual directories in place before your installation.  This leads me to believe that this is the default setting. 
    • Proposed as answer by Arnaud-31 Wednesday, December 01, 2010 4:29 PM
    Wednesday, October 27, 2010 3:58 PM
  • A hours and hours, i find the issue (for me)

    In my case, i had to modify the authentification parameters in IIS management console.

    Caution : i'm not talking about files and folder permissions but the Authentification icon in iis management console when you click on each subfolder.

    For the subfolder ecp :

    • anonymous : disabled
    • basic : enabled
    • digest : disabled 
    • Forms : disabled
    • Windows : enabled
    • ASP.NET : disabled

    For the subfolder EWS :

    • anonymous : enabled
    • basic : enabled
    • digest : disabled 
    • Forms : disabled
    • Windows : enabled
    • ASP.NET : disabled

    For the subfolder owa :

    • anonymous : disabled
    • basic : enabled
    • digest : disabled 
    • Forms : disabled
    • Windows : enabled
    • ASP.NET : disabled

    And it works, i can delete / move messages in owa !!

    I think that if you use Form authentification, you need to disable Basic and enable forms in those three subfolders.

    Arnaud

    • Proposed as answer by Pandya789 Wednesday, September 18, 2013 7:38 AM
    Wednesday, December 01, 2010 4:30 PM
  • To fix this issue do the following things.

    1. Go to c:\inetpub\wwwroot
    2. Make a copy of web.config file
    3. Open the original web.config file with notepad.
    4. Search for childonly="false"
    5. change the "false" to "true" and save the file.
    6. Restart the IIS service.

     

         Go to IIS -> Default Web Site -> EWS -> Authentication -> Windows Authontication should be "Enabled"

     

    http://itdreaming.blogspot.com/2011/03/fixed-exchange-owaecp-http-400-bad.html

    • Proposed as answer by DammZ Thursday, March 31, 2011 8:18 PM
    Thursday, March 31, 2011 5:16 PM
  • I Was having the same thing, and it was the http protocol. You have to make sure http * 80 and http 127.0.0.1 80 is configure on the website for OWA. The web.config trick was not working for me.
    • Proposed as answer by Bashtien Wednesday, June 08, 2011 3:17 AM
    Wednesday, June 08, 2011 3:17 AM
  • I deleted the web.config file after making a backup and it has fixed the problem. Thanks for the advice.
    • Proposed as answer by justjackuk Monday, November 07, 2011 2:10 PM
    Friday, August 26, 2011 3:35 PM
  • Deleting the web.config file from C:\inetpub\wwwroot worked for me as well. Thanks for the tip.
    • Proposed as answer by justjackuk Monday, November 07, 2011 2:10 PM
    Thursday, October 27, 2011 5:14 AM
  • I had the same issue, deleting the webconfig resolved the issue.
    Monday, November 07, 2011 2:09 PM
  • Worked for me to! 
    Thursday, November 10, 2011 5:37 PM
  • This "solution" just broke my webserver altogether. Now all I get is a 503 HTTP error that the service is unavailable.
    Sunday, December 04, 2011 5:14 PM
  • Open IIS Click on Default Web Site and choose HTTP Redirect.  Check the "Redirect requests to this destination" and set the redirect behavior to Only redirect requests to content in this directory (not subdirectories.  In the first box remove owa and leave just a / if you are hosting your own website.  Stop & Restart IIS using IISRESET and this should fix your issue.

    Thanks,
    Herbie - MCITP

    Friday, December 16, 2011 1:11 AM
  • Thanks a lot XxPhReAkEr328xX, this is the only solution that has worked for me.
    Friday, March 16, 2012 12:28 PM
  • I also had to fix authentication in the EMC, not just in IIS.

    Server Configuration/Client Access/Exchange Control Panel/Properties/Authentication.

    When we checked, we had it set to forms-based for some reason.

    Tuesday, June 05, 2012 2:16 PM
  • It worked for me, is authentication issue;

    Thanks


    El Khiyati

    Tuesday, November 13, 2012 11:53 AM
  • Hi,  I have the same deleting issue with OWA 2003.

    It only happens to users that are using Win Vista or Win 7 running IE8 or IE9.

    Unable to delete using the delete button in OWA 2003 but dragging and dropping the email into the Deleted Items folder is the temporary workaround for it.

    There are no such issues with Win Xp on IE8.


    Does anyone have the solution for this issue?
    • Edited by alas2802 Monday, December 03, 2012 10:05 AM
    Monday, December 03, 2012 9:51 AM
  • I was having the exact same problem.  I have SBS Standard 2011 with Exchange 2010 SP2 RU 4v2.  I tried all of the fixes everywhere, and none of them worked.  However, somebody mentioned the web.config file for EWS.

    There was one line in the web.config file for EWS that was causing this problem:

    <httpRuntime maxRequestLength="10485760" />

    Changing this back to the default value of "2097151" solved the problem.

    Which is weird, because the SBS BPA 1.3 scan told me:

    "The /EWS virtual directories maxRequestLength doesn't match the get-transportconfig MaxSendSize"

    However, according to this Microsoft article (under "Known Issues"), we need to ignore this error in the SBS 2011 Standard BPA 1.3:

    http://support.microsoft.com/kb/2699813

    • Proposed as answer by Justin L Baker Sunday, December 09, 2012 6:37 PM
    Sunday, December 09, 2012 6:36 PM
  • Thanks Justin.  Solved my problem.  I hate when MS suggestions break things.
    Wednesday, January 09, 2013 5:00 PM
  • I was able to resolve my issue by disabling "Forms Based Authentication" on EWS Virtual Directory in IIS.  Incidentally, doing the same to the ECP Virtual Directory resolved an issue trying to access "See All Options" in OWA.  Not sure why Exchange 2010 SP1 - Exchange 2013 Standard (V14) is setting these VirDir's like this.

    Technology Administrator Erie County (Career and) Technical School.

    Saturday, February 16, 2013 4:55 PM
  • Yes thats correct... i had the same problem and that fix it for me... at the end of the day your sub folders should have the same authentication...
    Wednesday, April 17, 2013 6:06 AM
  • Yes 100 % to this... I have exchange 2010 Sp3 Rollup 2 .. i was facing the same problem..

    The authentication method given here is perfect..

    and all app pools for exchange should be set to use framework 2.0.. thats it and it works charmm

    regards

    Bhargav


    Bhargav L Pandya

    Wednesday, September 18, 2013 7:40 AM