none
OWA - An unexpected error occurred

    Question

  • Hi,

    I have a windows 2008 server R2 with exchange 2010 SP1 RollUp Update 1. When I log into OWA, everything look like beeing ok. But when I try to open the calendar or write an email, I receive "An unexpected error occurred and your request couldn't be handled."
    No problems by using light version of Outlook Web App!
    We need to do a migration in 2 days, but that problem needs to be resolved!
    Regards
    Peter
    Tuesday, November 16, 2010 9:20 AM

Answers

  • Do you have redirection configured?

    If so, try the following navigate to \inetpub\wwwroot\config and delete or rename the web.config. Restart IIS.

    Also, uncheck the HTTP Redirect from the Default Web Site level in IIS.


    MCITP: Enterprise Messaging Administrator 2007/2010 | MCITP: Server Administrator | MCTS: Windows Server 2008 Applications Infrastructure, Configuring | MCP | MCDST
    • Marked as answer by PeterN22 Tuesday, November 16, 2010 2:15 PM
    Tuesday, November 16, 2010 2:04 PM

All replies

  • Do you get this problem on every PC?  i.e. does the problem "move" between PCs or is it limited to one PC?  Does it affect all users?
    Neil Hobson | Principal Consultant | Silversands | www.silversands.co.uk | www.msexchange.org/neil_hobson
    Tuesday, November 16, 2010 11:08 AM
  • if it is happening for all users , initiate logging to for events.
    Tuesday, November 16, 2010 11:11 AM
  • Hi Neil

    It happens on every PC and it affects all users.

    Tuesday, November 16, 2010 11:38 AM
  • On the exchange server I set the eventlog level for all *owa* identities to high. No entries in the eventlog.
    Tuesday, November 16, 2010 11:42 AM
  • Are you able to delete messages successfully?

    Do you by any chance have a host header configured? If so, go into IIS and under the bindings of the Default Web Site remove the host name, perform IISRESET and see if everything is running smoothly again.

    Also, check to see under the SSL Settings in IIS if it is set to require or accept client certificates. If it is configured, change it to Ignore Client certificates and then apply changes.

     


    MCITP: Enterprise Messaging Administrator 2007/2010 | MCITP: Server Administrator | MCTS: Windows Server 2008 Applications Infrastructure, Configuring | MCP | MCDST

    Tuesday, November 16, 2010 12:54 PM
  • No, I cannot delet messages.

    No host headers are configured.

    SSL isn't set ro require SSL, and Client Certificates is set to ignore.

    Tuesday, November 16, 2010 1:45 PM
  • Do you have redirection configured?

    If so, try the following navigate to \inetpub\wwwroot\config and delete or rename the web.config. Restart IIS.

    Also, uncheck the HTTP Redirect from the Default Web Site level in IIS.


    MCITP: Enterprise Messaging Administrator 2007/2010 | MCITP: Server Administrator | MCTS: Windows Server 2008 Applications Infrastructure, Configuring | MCP | MCDST
    • Marked as answer by PeterN22 Tuesday, November 16, 2010 2:15 PM
    Tuesday, November 16, 2010 2:04 PM
  • You are my hero ;-)  -  Now it works fine!

    So it's not possible to configure redirection with IIS?

    Thank you so much.

    Regards
    Peter

     

    Tuesday, November 16, 2010 2:18 PM
  • Update:

    I now reconfigured HTTP redirection, and it still works. I guess something crashed the config.

    Regards
    Peter

    Tuesday, November 16, 2010 2:40 PM