none
Exchange 2010 Out of Office "server unavailable"

    Question

  • I am running Exchange 2010 Rollup 3 on Server 2008 R2 and whenever a user, using Outlook 2007 (we are not using 2003 or 2010) trys to use the Out of Office Assistant they get the following message "Your Out of Office settings cannot be displayed, becase the server is currently unavailable. Try again later."

    I have read pretty much everthing there is to read (technet, google, every small time it blog anywhere), and short of installing a new CAS instance (this is a standalone Exchange 2010 instance), which im not confident will even fix it, I dont know what to do.

    Here is a little bit of what ive done and experienced:

    1. Removed and recreated both the Autodisocver and EWS directory's many times

    2. Confirmed internal and external URL's are right for both of them

    3. Tried modifying authentication types on IIS virtual directories

    4. OOF works in OWA

    5. Tried running the "Test E-mail AutoConfiguration" wizard in Outlook and all settings are correct and OOF URL is accesible from onsite and offiste

    6. This install is a few months old, but we are just now getting around to getting some "preprod" users over

    Any input anyone can give me would be helpful. I know there was a hotfix floating around for SBS 2008 that fixed this exact issue, but just not for 2008 R2.

    Thanks in advance!

    David

    Friday, June 11, 2010 4:39 PM

Answers

  • For the sake of time, i have decided to scrap fixing it, and just bring up another server and move everyone over. I have confirmed OOF is working on a default install of Exchange 2010 RU3.

    Thanks for your help everyone!

    dave

    • Marked as answer by dcs_115 Tuesday, June 15, 2010 7:16 PM
    Tuesday, June 15, 2010 7:16 PM

All replies

  • I have the same issue on my end. Any ideas yet? We have basically the same setup, except we are using office 2010 client.
    Friday, June 11, 2010 8:21 PM
  • please make sure that the Internal and External URL are both included in the certificate assigned to the Exchange IIS server. I think that one of URLs is missing!
    Regards, Mahmoud Magdy Watch Arabic Level 300 Videos about Exchange 2010 here: http://vimeo.com/user3271816 Read pretty advanced Exchange stuff I and other MVPs post here: http://www.enowconsulting.com/ese/blog.asp Or follow my blog: http://busbar.blogspot.com or our corp blog: http://ingazat.wordpress.com and if you Liked my post please mark it as helpful and accept it as an asnwer
    Friday, June 11, 2010 8:31 PM
  • Internal and External URL's are on the cert. And if I go directly to the EWS site, I get prompted for credentials and am logged in and see the xml. Any other thoughts? Thanks in advance!
    Friday, June 11, 2010 8:43 PM
  • can you install a sniffer on the machine and try to see the URL the outlook tries to access, your case is the same as the original post but I don't know how did you do your troubleshooting.

    can you post get-exchangewebservicesvirtualdirectory | fl *int*,*ext* output.

     


    Regards, Mahmoud Magdy Watch Arabic Level 300 Videos about Exchange 2010 here: http://vimeo.com/user3271816 Read pretty advanced Exchange stuff I and other MVPs post here: http://www.enowconsulting.com/ese/blog.asp Or follow my blog: http://busbar.blogspot.com or our corp blog: http://ingazat.wordpress.com and if you Liked my post please mark it as helpful and accept it as an asnwer
    Friday, June 11, 2010 8:48 PM
  • Here is my output for get-webservicesvirtualdirectory. i did the whole list (with real domain name replaced with "mydomain", just in case that will help.

    As far as the cert question goes, i have a SAN cert with the appropriate names. One interesting note is that i can get OOF Assistant to show up if i explicitly assign IIS authentication settings to exchange.asmx (Anonymous and Basic), but as soon as i restart IIS it stops working. This definitely feels like a bug with an unhanded exception.... i'm hoping not though!

     

    Thanks! dave

     

    [PS] C:\Windows\system32>get-webservicesvirtualdirectory | fl

    RunspaceId                    : e202a0db-36ec-4aea-82f2-5bc46655b848

    CertificateAuthentication     :

    InternalNLBBypassUrl          : https://exch2010.mydomain.local/EWS/Exchange.asmx

    GzipLevel                     : High

    Name                          : EWS (Default Web Site)

    InternalAuthenticationMethods : {Ntlm, WindowsIntegrated}

    ExternalAuthenticationMethods : {Ntlm, WindowsIntegrated}

    LiveIdSpNegoAuthentication    : False

    WSSecurityAuthentication      : False

    LiveIdBasicAuthentication     : False

    BasicAuthentication           : False

    DigestAuthentication          : False

    WindowsAuthentication         : True

    MetabasePath                  : IIS://EXCH2010.mydomain.local/W3SVC/1/ROOT/EWS

    Path                          : C:\Program Files\Microsoft\Exchange Server\V14\ClientAccess\exchweb\EWS

    Server                        : EXCH2010

    InternalUrl                   : https://mail.mydomain.com/EWS/Exchange.asmx

    ExternalUrl                   : https://mail.mydomain.com/EWS/Exchange.asmx

    AdminDisplayName              :

    ExchangeVersion               : 0.10 (14.0.100.0)

    DistinguishedName             : CN=EWS (Default Web Site),CN=HTTP,CN=Protocols,CN=EXCH2010,CN=Servers,CN=Exchange Admin

                                    istrative Group (FYDIBOHF23SPDLT),CN=Administrative Groups,CN=mydomain,CN=Microso

                                    ft Exchange,CN=Services,CN=Configuration,DC=mydomain,DC=local

    Identity                      : EXCH2010\EWS (Default Web Site)

    Guid                          : 6d5687ea-25dd-46e9-bd9d-f5ed1417ce8f

    ObjectCategory                : mydomain.local/Configuration/Schema/ms-Exch-Web-Services-Virtual-Directory

    ObjectClass                   : {top, msExchVirtualDirectory, msExchWebServicesVirtualDirectory}

    WhenChanged                   : 6/11/2010 7:32:27 AM

    WhenCreated                   : 6/11/2010 7:32:27 AM

    WhenChangedUTC                : 6/11/2010 2:32:27 PM

    WhenCreatedUTC                : 6/11/2010 2:32:27 PM

    OrganizationId                :

    OriginatingServer             : exchange.mydomain.local

    IsValid                       : True


    Friday, June 11, 2010 9:41 PM
  • hey diannemg278, if you get an answer at some point, could you let me know at david@sundquisthomes.com? Ill do the same.
    Friday, June 11, 2010 9:47 PM
  • hi DCS

    can you validate the IIS permissions using this table

    http://busbar.blogspot.com/2010/05/exchange-20102007-virtual-directory_16.html

    meanwhile can you add the authenticated users to the NTFS permissions on the exchange.asmx and try again.

     


    Regards, Mahmoud Magdy Watch Arabic Level 300 Videos about Exchange 2010 here: http://vimeo.com/user3271816 Read pretty advanced Exchange stuff I and other MVPs post here: http://www.enowconsulting.com/ese/blog.asp Or follow my blog: http://busbar.blogspot.com or our corp blog: http://ingazat.wordpress.com and if you Liked my post please mark it as helpful and accept it as an asnwer
    Saturday, June 12, 2010 5:15 AM
  • That post is very valuable when troubleshooting IIS issues, i will make sure to pass it on!

    Unfortunately, after confirming IIS permissions (authenticated users was already part of exchange.asmx ntfs permissions), I am still receiving the same error.

    Thanks!

    david

    Saturday, June 12, 2010 6:43 PM
  • David-

    If you Ctrl+right click the Outlook icon in the tray and go to Test Email Autoconfiguration, uncheck the guess-smart boxes and run the test. What are the results like? What happens if you just browse to the returned EWS URL from the client? What's www.testexchangeconnectivity.com say?


    Active Directory, 4th Edition - www.briandesmond.com/ad4/
    Sunday, June 13, 2010 7:53 PM
  • The results of "Test Email Auto-configuration" are as expected. When I enter the displayed OOF URL into my browser, i am asked to auth, redirected from exchange.asmx to /EWS/Services.wsdl and am shown the XML conf file.

    testexchangeconnectivity.com (which is arguable the best resource for exchange admins, ever.) shows everything as working. Just so we are on the same page, OOF doesnt work remote or local. 

    Thanks!

    dave

    Monday, June 14, 2010 1:48 PM
  • An interesting update. I enabled logging in Outlook and now see what is causing OOF to fail. While it may not be too helpful its at least something more to go off of. The first line "request to url" is the correct URL for access. If i recall, 500 is a catch all code.

     

    2010/06/14 08:13:44.552: Request to URL: https://mail.mydomain.com/EWS/Exchange.asmx

    2010/06/14 08:13:44.552: Request action: http://schemas.microsoft.com/exchange/services/2006/messages/GetUserOofSettings

    2010/06/14 08:13:44.552: Request XML: <?xml version="1.0"?>

    <q:Envelope xmlns:q="http://schemas.xmlsoap.org/soap/envelope/"><q:Body><ex12m:GetUserOofSettingsRequest xmlns:ex12m="http://schemas.microsoft.com/exchange/services/2006/messages"><ex12t:Mailbox xmlns:ex12t="http://schemas.microsoft.com/exchange/services/2006/types"><ex12t:Address>david@domainname.com</ex12t:Address><ex12t:RoutingType>SMTP</ex12t:RoutingType></ex12t:Mailbox></ex12m:GetUserOofSettingsRequest></q:Body></q:Envelope>

    2010/06/14 08:13:44.552: Sending request

    2010/06/14 08:13:44.607: Request sent

    2010/06/14 08:13:44.607: Response error code: 00000000

    2010/06/14 08:13:44.607: HTTP status code: 500

    2010/06/14 08:13:44.607: -------------------------------

    2010/06/14 08:13:44.607: There is an error in request/response.

    2010/06/14 08:13:44.607: XML response:<?xml version="1.0" encoding="utf-8"?><s:Envelope xmlns:s="http://schemas.xmlsoap.org/soap/envelope/"><s:Body><s:Fault><faultcode xmlns:a="http://schemas.microsoft.com/exchange/services/2006/types">a:ErrorInternalServerError</faultcode><faultstring xml:lang="en-US">An internal server error occurred. The operation failed.</faultstring><detail><e:ResponseCode xmlns:e="http://schemas.microsoft.com/exchange/services/2006/errors">ErrorInternalServerError</e:ResponseCode><e:Message xmlns:e="http://schemas.microsoft.com/exchange/services/2006/errors">An internal server error occurred. The operation failed.</e:Message></detail></s:Fault></s:Body></s:Envelope>

    2010/06/14 08:13:44.607: -------------------------------

     

    Monday, June 14, 2010 3:19 PM
  • In what was a small mistake, i realized that i missed the reason you wanted me to use testexchagneconnectivity.com to begin with. I was just using the autodiscover\ outlook anywhere piece, and missed the "Exchange Web Services Synchronization, Notification, Availability, and OOF" test portion. I ran that, and came up with something similar to my post below. Everything works except the last test, which is the "Setting and retrieving user OOF settings". The error is below.

     

    Setting and retrieving user OOF settings
      ExRCA failed to set and retrieve user Automatic Reply (OOF) settings.
       Test Steps
       Getting user OOF settings and confirming them against expected values
      Failed to retrieve and confirm user OOF settings
       Additional Details
      ErrorInternalServerError: An internal server error occurred. The operation failed.
    Last EWS request:
    <Trace Tag="EwsRequest" Tid="6" Time="2010-06-14 16:34:14Z" Version="14.01.0170.000">
    <?xml version="1.0" encoding="utf-8"?>
    <soap:Envelope xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:m="http://schemas.microsoft.com/exchange/services/2006/messages" xmlns:t="http://schemas.microsoft.com/exchange/services/2006/types" xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/">
    <soap:Header>
    <t:RequestServerVersion Version="Exchange2007_SP1" />
    <t:TimeZoneContext>
    <t:TimeZoneDefinition Id="Pacific Standard Time" />
    </t:TimeZoneContext>
    </soap:Header>
    <soap:Body>
    <m:GetUserOofSettingsRequest>
    <t:Mailbox>
    <t:Address>dave@mydomain.com</t:Address>
    </t:Mailbox>
    </m:GetUserOofSettingsRequest>
    </soap:Body>
    </soap:Envelope>
    </Trace>

    Last EWS response:
    <Trace Tag="EwsResponse" Tid="6" Time="2010-06-14 16:34:14Z" Version="14.01.0170.000">
    <?xml version="1.0" encoding="utf-8"?>
    <s:Envelope xmlns:s="http://schemas.xmlsoap.org/soap/envelope/">
    <s:Body>
    <s:Fault>
    <faultcode xmlns:a="http://schemas.microsoft.com/exchange/services/2006/types">a:ErrorInternalServerError</faultcode>
    <faultstring xml:lang="en-US">An internal server error occurred. The operation failed.</faultstring>
    <detail>
    <e:ResponseCode xmlns:e="http://schemas.microsoft.com/exchange/services/2006/errors">ErrorInternalServerError</e:ResponseCode>
    <e:Message xmlns:e="http://schemas.microsoft.com/exchange/services/2006/errors">An internal server error occurred. The operation failed.</e:Message>
    </detail>
    </s:Fault>
    </s:Body>
    </s:Envelope>
    </Trace>

    Monday, June 14, 2010 5:04 PM
  • For the sake of time, i have decided to scrap fixing it, and just bring up another server and move everyone over. I have confirmed OOF is working on a default install of Exchange 2010 RU3.

    Thanks for your help everyone!

    dave

    • Marked as answer by dcs_115 Tuesday, June 15, 2010 7:16 PM
    Tuesday, June 15, 2010 7:16 PM
  • Guys,

    Hope this can be helpful.  I've find out that the problem was actually DNS.  After adding autodiscover.<yourdomainname.com>, all starting working fine.  I've also added remote.<yourdomainname.com>.

    Ohh, I'm also referring of the internal DNS.

    Give that a go guys.  Hope this is helpful to some of you out there.

    Regards,

    Hamun

    Wednesday, September 26, 2012 10:00 AM