none
OWA localhost is not working exchange 2010

    Question

  • hi gusy, i just start to do exchange 2007 to exchange migration , i followed correct steps and install one exchange server with HUB/CAS/MAILBOX Roles. every thinsg was working fine and not my OWA is not working for either Server name or my internal URL Name. as i founf this is IIS Error . i have done the OWA redirection for default Site.

    https://localhost    this is not working & give me DNS Error

    https://localhost/owa this is working fine and can use OWA from Server it self.

    https://server.mydomain.com or https://server.mydomina.com/owa dowan't work

    https://172.16.200.14 https://172.16.200.14/owa ( IP Address for Servers) doesn't work

    https://127.0.0.1 not working  & https://127.0.0.1/owa will work

    https//:mail.mydomain.com or https//:mail.mydomain.com/owa doesn't work

    Default web site - binding ( HTTP -  All Unassigned port-80 , HTTPS- All Unassigned -port 443 - Exchange Local certificiate with all required Names)

    i feel if my https://localhost can browse  with IIS Default web Site, every things will be fine. since i have all excahnge roles in same same , unistall every things and do it from the strach will be take lot of time). So how can i fix this browser  localhost issues  

    Basically default Site is not working from Local IP address and only loop work for  IP address( 172.0.0.1 )with Virtaul Directory Name (  

    thank you

    indunil


    • Edited by Indunil Monday, May 28, 2012 9:01 AM adde
    Monday, May 28, 2012 8:37 AM

Answers

All replies

  • Hi,
    Have you changed anything on the bindings (you should not)?

    Here's what it should look like.


    Regarding the redirection...
    Did you follow the step  Simplify the Outlook Web App URL ?

    Martina Miskovic

    • Marked as answer by Indunil Monday, May 28, 2012 11:28 AM
    Monday, May 28, 2012 8:55 AM
  • hi thank you for the reply

    yes i removed except  http * https *. yes i followed the redirection and believe it's fine. now i created binding as it was( as same as screen shot )&  remove the redirection. now i can get the default webpage from localhost , but still i can't access default website from either Server name or IP address .

    it seem this is some things binding issues . any clue to fix this

    thank you

    Indunil

    Monday, May 28, 2012 9:12 AM
  • After you corrected the bindings, did you restart the Exchange Services?
    If not, I would recommend you to do so. At least the once that has to do with the CAS Role.
    If you need to know which one they are, check with Test-ServiceHealth


    Martina Miskovic

    Monday, May 28, 2012 9:21 AM
  • thank you for reply. yes i even restarted whole server. still default site can't be access from IP address , Server anme or URL Name . only diffrent in binding is  my https even it's unassigned, it can see * on https binding. but beleive this is okay .

    Monday, May 28, 2012 9:55 AM
  • Can you post a new picture where all bindings is shown, like I did?


    Martina Miskovic

    Monday, May 28, 2012 10:05 AM
  • is this enougth.

    Monday, May 28, 2012 10:19 AM
  • Hi,
    Thanks, it's so much easier to see :)

    There's a difference between the pic I posted and yours.
    It could be the assigned certificate..or lack of. I have never changed the bindings so I don't really know what errors it will cause.

    I suggest that your assign the service IIS to the certificate and see if that helps.
    Do it with enable-exchangecertificate in EMS or use the guiversion in EMC.

    You can also run the testcmdlet Test-OwaConnectivity and see if you get any information there.


    Martina Miskovic

    Monday, May 28, 2012 10:39 AM
  • now it's started to working, i am not sure what is the reason. this might after change binding only. but it took some time even after restart.

    anywhay thank you for great help

    Indunil

    Monday, May 28, 2012 11:27 AM