none
Exchange 2010 2003 migration - Post-move cleanup failed

    Question

  • During our migration from Exchange 2003 SP2 to Exchange 2010 SP2 RU5v2 (2 multi-role servers in a DAG), we're migrating our beta users.  Everything looks good except we're receiving delays at the end of the moves.  I'm using the management console to preform the move requests which result in these messages:

    ...

    12/21/2012 7:01:54 PM [exchange1] Move has completed and final clean up has started.
    12/21/2012 7:01:54 PM [exchange1] Source mailbox 'Primary (d5b10926-27ed-43fc-93c6-f51ac5508c73)' was successfully cleaned up after the move.
    12/21/2012 7:01:54 PM [exchange1] Target mailbox 'Primary (d5b10926-27ed-43fc-93c6-f51ac5508c73)' was successfully reset after the move.
    12/21/2012 7:01:54 PM [exchange1] Post-move cleanup failed. The operation will try again in 30 seconds (1/6).
    12/21/2012 7:02:24 PM [exchange1] Post-move cleanup failed. The operation will try again in 30 seconds (2/6).
    12/21/2012 7:02:55 PM [exchange1] Post-move cleanup failed. The operation will try again in 30 seconds (3/6).
    12/21/2012 7:03:25 PM [exchange1] Post-move cleanup failed. The operation will try again in 30 seconds (4/6).
    12/21/2012 7:03:56 PM [exchange1] Post-move cleanup failed. The operation will try again in 30 seconds (5/6).

    12/21/2012 7:04:26 PM [exchange1] Request is complete.

    1) What is the Post-move cleanup?

    2) Why might it be failing?

    I need to move some 1000ish mailboxes and would love to eliminate this 3 minute/mailbox delay.

    Thanks,

    Jake

    Saturday, December 22, 2012 1:12 AM

Answers


  • 12/21/2012 7:03:56 PM [exchange1] Post-move cleanup failed. The operation will try again in 30 seconds (5/6).

    1) What is the Post-move cleanup?

    2) Why might it be failing?

    I need to move some 1000ish mailboxes and would love to eliminate this 3 minute/mailbox delay.

    Thanks,

    Jake

    Hi,
    I can't tell you why this happens, but it is a know issue since RU3 and as you have noticed, it hasn't been fixes in RU5-v2.

    To workaround the 3 minutes delay, you can modify MaxCleanupRetries in the file \bin\MSExchangeMailboxReplication.exe.config (MRSConfiguration section) and change the "5" to something lower.

    See: Throttling the Mailbox Replication Service


    Martina Miskovic

    • Marked as answer by Jake Schmidt Thursday, January 10, 2013 4:52 PM
    Saturday, December 22, 2012 5:40 AM

All replies

  • Hi Jake

    I believe this is a solution for you  A stub object is left behind in the source database for certain users after a move mailbox operation is complete in Exchange 2003 Service Pack 2


    Fred Chamanara | Advanced Agile Technology LLC | Hire us | please mark "Propose As Answer" if this post helped.


    Saturday, December 22, 2012 2:15 AM
  • Fred,

    Thanks for the response, however, I don't see a stub object in the source datastore.  So I don't beleive this is the solution.

    Jake

    Saturday, December 22, 2012 5:39 AM

  • 12/21/2012 7:03:56 PM [exchange1] Post-move cleanup failed. The operation will try again in 30 seconds (5/6).

    1) What is the Post-move cleanup?

    2) Why might it be failing?

    I need to move some 1000ish mailboxes and would love to eliminate this 3 minute/mailbox delay.

    Thanks,

    Jake

    Hi,
    I can't tell you why this happens, but it is a know issue since RU3 and as you have noticed, it hasn't been fixes in RU5-v2.

    To workaround the 3 minutes delay, you can modify MaxCleanupRetries in the file \bin\MSExchangeMailboxReplication.exe.config (MRSConfiguration section) and change the "5" to something lower.

    See: Throttling the Mailbox Replication Service


    Martina Miskovic

    • Marked as answer by Jake Schmidt Thursday, January 10, 2013 4:52 PM
    Saturday, December 22, 2012 5:40 AM
  • Martina,

    Thanks for the link, I saw a blog post on how to do this but it looked like a dicy source.  I'll let you know how it goes.

    Merry Christmas,

    Jake

    Saturday, December 22, 2012 4:54 PM
  • Hi Jake,

    Any updates?


    Frank Wang
    TechNet Community Support

    Wednesday, December 26, 2012 2:54 AM
  • I am having the same issue without any solution. Is it safe not to pay atention to this log?

    Thursday, March 07, 2013 2:31 PM
  • I followed Martina's advice above and have been working fine since the beginning of the year.  I haven't seen any negative side affects thus far.

    Good Luck,

    Jake

    Thursday, March 07, 2013 2:36 PM
  • On Exchange 2013 there are the following settings:

    <MRSConfiguration
        MaxRetries="60"
        MaxCleanupRetries="480"

    I do not think it is retrying the operation 480 times.  I think it is retrying it closer to 60 times going by the log entries.  So should I change both of these?  Is MaxRetries for something else, like migrating the mailbox, and MaxCleanupRetries for cleaning it up?  I might try modifying both entries.

    Thanks,

    Flux-B

    Monday, July 07, 2014 6:19 PM