none
"Load balancing failed to find a valid mailbox database." error creating new mailbox

    Question

  • Hello-

    Tried to create a new mailbox (Exchange 2010 SP1) and got the following error:

    "Load balancing failed to find a valid mailbox database."

    After searching other threads I've verified that the databases (I have 3) are all mounted and that they are all enabled for provisioning.  I have only one server and all roles are installed on it. 

    I am able to create a mailbox if I specifically choose a database, but I would like to get load balancing to work again.  This issue was not present last week.

    Any and all help is greatly appreciated.  Thanks.

    Wednesday, March 21, 2012 5:36 PM

Answers

  • Hi skeegy,

    I am afraid of that you have to update it for RU6 or later, because, per my known, the issue seems fix by it. And please also confirm all the database are mounted.

    Regards! 

    Gavin

    TechNet Community Support

    • Marked as answer by skweegy Monday, April 02, 2012 2:40 PM
    Tuesday, March 27, 2012 6:07 AM

All replies

  • Any updates applied to the server?

    Can you create a test account with the right permission and test with that account?


    Sukh

    Wednesday, March 21, 2012 8:24 PM
  • All permissions are valid.  My account is part of the Organization Management role.  I tried with another account with the same permissions. 

    This server has been in production for 2+ years and has a couple hundred mailboxes, all of which I have added.  This is a new issue just this week.  OS Updates were last installed two weeks ago via WSUS and the machine restarted.  No changes since then.

    Wednesday, March 21, 2012 8:38 PM
  • Hi skweegy,

    It seems the account profile corrupted, please try below:
    1,Ran the Get-Mailboxdatabase cmdlet to check the “IsExcludedFromProvisioning” attribute.
    2,Suggested to use the cmdlets : Set-Mailboxdatabase and Set-MailboxServer to include the databases for provisioning.
    3,delete and recreat your profile on the Server
    Please also update your exchange server with the latest version, sp1 ru6 or later.

    Regards!


    Gavin

    TechNet Community Support

    Friday, March 23, 2012 8:58 AM
  • Hello,

    Follow the link below for the solution

    http://www.exchangemaster.net/index.php?option=com_content&task=view&id=141&Itemid=1&lang=en

    Friday, March 23, 2012 9:27 AM
  • Hi skweegy,

    Any update for your issue?

    Regards!

    Gavin

    TechNet Community Support

    Monday, March 26, 2012 3:02 AM
  • Hello-

    My apologies for not replying, I have been traveling.

    I appreciate the comments so far, but as I stated in my original post all databases are mounted and all databases are enabled for provisioning.  I verified both again just now.

    As for updates, I am currently on Update Rollup 5 and cannot install 6 until my next maintenance window.

    Any other suggestions?

    Monday, March 26, 2012 3:20 PM
  • Hi skeegy,

    I am afraid of that you have to update it for RU6 or later, because, per my known, the issue seems fix by it. And please also confirm all the database are mounted.

    Regards! 

    Gavin

    TechNet Community Support

    • Marked as answer by skweegy Monday, April 02, 2012 2:40 PM
    Tuesday, March 27, 2012 6:07 AM
  • Hey All-

    I installed Update Rollup 6 last night and everything seems to be working now.  Thanks for all the help.

    Monday, April 02, 2012 2:40 PM
  • This is odd.

    I started getting this error on 2010 SP1 RU6.

    I upgraded to 2010 SP2 RU4 yesterday. Rebooted all Exchange servers.

    I still have the same problem.

    All databases are mounted, nothing seems to be wrong.

    A BPA healthscan checks out.

    I'm trying to create the mailbox from our management server. It actually says to me there are no exchange serveres in this AD site. Which there is, of course. Management from the exchange servers themselves is fine.

    After trying to enter the FQDN, I get this:

    [mail.domain.local] Connecting to remote server failed with the following error message : WinRM cannot process
     the request. The following error occured while using Kerberos authentication: The network path was not found.
     Possible causes are:
      -The user name or password specified are invalid.
      -Kerberos is used when no authentication method and no user name are specified.
      -Kerberos accepts domain user names, but not local user names.
      -The Service Principal Name (SPN) for the remote computer name and port does not exist.
      -The client and remote computers are in different domains and there is no trust between the two domains.
     After checking for the above issues, try the following:
      -Check the Event Viewer for events related to authentication.
      -Change the authentication method; add the destination computer to the WinRM TrustedHosts configuration setting or us
    e HTTPS transport.
     Note that computers in the TrustedHosts list might not be authenticated.
       -For more information about WinRM configuration, run the following command: winrm help config. For more information,
     see the about_Remote_Troubleshooting Help topic.
        + CategoryInfo          : OpenError: (System.Manageme....RemoteRunspace:RemoteRunspace) [], PSRemotingTransportExc
       eption
        + FullyQualifiedErrorId : PSSessionOpenFailed

    I think this may be more of a powershell thing, than an exchange thing as such.

    Any ideas ?

    Thursday, September 06, 2012 8:16 AM
  • Hello!

    I started to see this after upgradering from Exchange 2010 SP2 to SP2 Ru5v2. All databases are mounted, permissions are correct.

    Friday, March 01, 2013 9:09 AM
  • Hi Jonasca1,

    Did you manage to find any solution to your problem? I'm having the same error as well using SP2 RU4. All database are mounted, roles are assigned, mailbox database is not excluded from automatic mailbox distribution and AD and mailbox database are on the same site.

    Friday, March 15, 2013 1:24 AM