none
Exchange 2007 - How to configure the autodiscover service?

    Question

  • I'm using BETA2.

    What do I have to do to get Autodiscover working?

    I enabled Outlook Anywhere on the CAS Server, but the autodiscover.xml file on the CAS Server is still empty...

    Shouldn't the RPC/HTTP config(besides other settings) appear in the XML file?

    I can't find anything in the helpfile...

    Thanks for your answers!

    Christian Schindler

    Tuesday, August 08, 2006 8:25 PM

Answers

  • ok, now more importantly, if you do get-outlookprovider, are any of the 3 entries listed associated with a server (see my below example)?  When I installed Beta2, I believe there were either 2 or 3 outlook providers listed, but none of them were associated with a server.  As you can see below, you can use SSL with Beta2...

    [MSH] C:\>Get-OutlookProvider

    Name                       Server                          SSL
    ----                             ------                              ---
    EXCH                       DEVE12                     True

    If you need to associate one with your server, you should be able to type

    set-outlookprovider exch -server yourserver

    Tuesday, August 08, 2006 9:18 PM

All replies

  • Autodiscover is not the same thing as Outlook Anywhere.  Outlook Anywhere = RPC/HTTP.

    Autodiscover is the ability to publish an xml file that tells Outlook how to configure itself.

    If you do a get-outlookprovider from MSH, do you have any listed?

    If you look in IIS Manager, do you see an Autodiscover virtual directory under the default website?

    The autodiscover.xml file is also just a placeholder file.

    Tuesday, August 08, 2006 8:58 PM
  • Ben,

    thanks for your answer.

    I know that RPC/HTTP and Autodiscover are two different things.

    But if I configure RPC/HTTP on the CAS, according to all the presentations, Outlook 2007 should get

    the RPC/HTTP config automaticaly via the autodiscover service(xml-file).

    Yes, I have three entries listed when I execute get-outlookprovider. And yes, there's the autodiscover

    V-dir in IIS-Manager - and it contains all the .aspx, etc files...

    I also configured the outlookprovider to not use ssl(which was necessary in beta1)...no success...

    Maybe it's simply a missunderstanding of how the automatic client config should work.

    Maybe someone can explain...

    Thanks!

    Christian Schindler

    Tuesday, August 08, 2006 9:10 PM
  • ok, now more importantly, if you do get-outlookprovider, are any of the 3 entries listed associated with a server (see my below example)?  When I installed Beta2, I believe there were either 2 or 3 outlook providers listed, but none of them were associated with a server.  As you can see below, you can use SSL with Beta2...

    [MSH] C:\>Get-OutlookProvider

    Name                       Server                          SSL
    ----                             ------                              ---
    EXCH                       DEVE12                     True

    If you need to associate one with your server, you should be able to type

    set-outlookprovider exch -server yourserver

    Tuesday, August 08, 2006 9:18 PM
  • ok, that's a good point. I'll have a look at that.

    thank you!

    Christian Schindler

    Tuesday, August 08, 2006 9:23 PM
  • Thanks Ben!

    That fixed it! None of the providers was associated with a server...

    Christian Schindler

    Wednesday, August 09, 2006 9:06 AM
  • Hello Ben

    Please can you tell me the difference between the outloop providers EXCH and EXPR

    in what context these two providers are user. Is there a major difference between these two

    Monday, October 02, 2006 4:47 AM
  • The difference is that EXCH is for use with MAPI mail clients, while EXPR is for legacy web services.
    Tuesday, February 06, 2007 12:09 PM
  • Name                       Server                          SSL
    ----                             ------                              ---
    EXCH                       DEVE12                     True

    How can I set SSL true?

     

    Thursday, February 15, 2007 4:33 PM
  • Hi Ben

    You have provided valuable information in this thread. 

    I am having a problem in configuring autodiscovery service. I am unable to bind the CA server with EXCH. It doesnt update the binding after running the command set-outlookprovider -id exch -server exchange. How can i check what is wrong. I am using final version of exchange 2007.

     

     

    Thanks Mate

    Friday, March 16, 2007 6:48 AM
  • Set-OutlookProvider –id exch –ssl:$true
    Friday, March 16, 2007 8:15 AM
  • I am getting the following error message from Outlook 2007 when performing a send/receive. 15:02:18 Microsoft Exchange offline address book
    15:02:18                                 Not downloading Offline address book files.  A server (URL) could not be located.
    15:02:18                0X8004010F

    After trace the OAB gerneration process and publish to the OAB virtual web site is successful. I just find that the autodiscover.xml is not correct and nothing inside this file. it means the autodiscover service not generating new autodiscover.xml 

    Any can help fix this?

     

    the result of get-outlookprovider | format-text

     

     

    CertPrincipalName :
    Server            : dvn-hk-mail2007
    TTL               : 1
    AdminDisplayName  :
    ExchangeVersion   : 0.1 (8.0.535.0)
    Name              : EXCH
    DistinguishedName : CN=EXCH,CN=Outlook,CN=AutoDiscover,CN=Client Access,CN=DVN-HK,CN
    Identity          : EXCH
    Guid              : e28d743f-c65e-48bd-a486-9a5d3a6f8270
    ObjectCategory    : dvngroup.com/Configuration/Schema/ms-Exch-Auto-Discover-Config
    ObjectClass       : {top, msExchAutoDiscoverConfig}
    WhenChanged       : 6/11/2007 5:11:10 PM
    WhenCreated       : 5/23/2007 2:05:20 PM
    OriginatingServer : DVN-HK-AD2007.dvngroup.com
    IsValid           : True

     

     

     

    Thanks

    Monday, June 11, 2007 10:19 AM
  •  

    I find it strange that your

     

    Server            : dvn-hk-mail2007

    and

     

    OriginatingServer : DVN-HK-AD2007.dvngroup.com

     

    are not the same, does that matter?

    Friday, February 29, 2008 5:35 AM
  •  

    Hi, I’m trying to get Outlook2007 and Exchange 2007 working together for our remote users who are having issues coming from misconfigured autodiscover service.

    I have followed a lot of the threads and tried various things to see if I can resolve the problem but I am still having the same problem with free/busy times not showing.  Our Exchange 2007 was setup about a year ago by an external company and recently we have moved to Outlook2007 for our remote users.  We have working Outlook Anywhere but I think our Exchange was never configured for autodiscover service, or at least not configured all the way.

    This is what I have so far, our DNS for autodiscover.domainname.com now points to our firewall’s NAT for HTTP/rpc inbound and goes to the Exchange box.  Initially when I tried the “test autoconfiguration” on the external client, it was failing on everything. Now it passes on the 2nd check, where it looks at autodiscover to HTTPS and the results page shows some information; now this is where I think the server is misconfigured. When I run the test from inside the network, it has the FQDN for the Exchange server, so it states https://servername.activedirectory.domain.com and has the various things for Availability Server, OOF, OAB, UM, etc. for RPC. 

    For HTTP, it has

    server: mail.domainname.com

    loginname: my login

    SSL: yes

    Mutual Authentication: Yes

    Auth Package: NTLM

    Certificate Principal Name: msstd:mail.domainname.com

     

    Now I have run the same test from remote laptop and it shows the exact same information for RPC and HTTP. I’m thinking, shouldn’t RPC show how it reaches the server from the outside and not the internal FQDN with servername and active directory? Also, for our OWA, we use webmail.domainname.com instead of just plain mail, is that causing an issue with the certification listed above?

     

    Also, on the Exchange Server, I ran Get-OutlookProvider and I have EXCH, EXPR, WEB but the server column is empty for all three. I also ran Test-OutlookWebServices and unfortunately I can’t read the middle column fully and I’ve tried putting the output to txt file and expanding the buffer for the screen. However, ID 1013 and 1017 does fail but I can’t read where.  I have checked IIS on Exchange and it does have autodiscover sub category under Default Web Site.

     

    I have also tried the registry hack but that has not resolved the matter.

     

    Can someone please point me to a step-by-step on how to configure Exchange 2007 for this so I can see if the server was setup properly from the start, or what I need to change?  I think I’ve pretty much done everything on the client side and need to look at the server side now.  One other thing, Outlook2003 was working before I moved to 2k7 on the client laptops.

    Tuesday, April 15, 2008 5:01 PM
  • Yes Nahmed,

     

    I'm on the same boat with you, i guess we're having the same condition of empty XML file which leads to OOF, OAB, free/busy status error.

     

    here's my autodiscover entry:

     

     

    <?xml version="1.0" encoding="utf-8"?>
    <Autodiscover>
    <!-- This is a placeholder file -->
    </Autodiscover>

     

    it would be great if someone out there could give us a clue of how does it looks like when it is filled in.

     

    thanks.

    Wednesday, September 03, 2008 4:51 AM
  • Hello,

    Wow more than one year and nobody did a complete step by step guide about this issue.
    Actually, one of my customer is having this issue as well ..and i started today to have a look.

    I will let you know if i find any valuable information. 
    Thursday, October 15, 2009 9:01 PM
  • Hi All,

    If anyone still having issues ?

    I can help.

    Regards,

    Irfan Ali


    Irfan Ali. Snr. Infrastructure Consultant
    Thursday, September 16, 2010 2:15 PM
  • Dear Irfan,

    Can you help me out for following

    1. My OOA doesn't work with proxy settings ON on ISA Server as autodiscover URL is directed towards ISA Server

    2. When I move user mailbox credentials from one exchnage server to other , user did not automatically gets connected to new server

    Anwar


    SPPS 2003 Upgrade to 2007
    Saturday, September 18, 2010 3:08 AM
  • I also have autodiscover.xml and need to know step by step how we can fill the autodiscover.xml and what will be the entries in autodiscover.xml after the autodiscover configuration finished.

    • Proposed as answer by Binu John Thursday, September 23, 2010 8:43 AM
    Thursday, September 23, 2010 8:42 AM
  • Hi Anwar,

    Please list some details on your environment on how is it setup, OS, Exch, ISA versions, Topology, clustering, etc,

    Are you using HLB or NLB ?

    Thanks,


    Irfan Ali.

    Snr. Infrastructure Consultant

    Wednesday, October 13, 2010 4:13 PM
  • same issue here as nahmed.

    we have Exchange 2007 SP1.  Two, 2 node clusters, about 1700 users.  ISA 2006.

    autodiscover works, but the first URL it tries fails, then the next one works.  Why is this?  also, when i do get-outlookprovider, it shows the

     Name                   Server                 CertPrincipalName     TTL
    ----                   ------                 -----------------                  ---
    EXCH                                                                               1
    EXPR                                          msstd:*.domain.com        1
    WEB                                                                                 1

     

    here is where the autodiscover service fails first, then passes.  is it possible to elminate the first URL so it passes the first time?

    FAILS: Attempting to test potential Autodiscover URL https://domain.com/AutoDiscover/AutoDiscover.xml

    PASSES: Attempting to test potential Autodiscover URL https://autodiscover.domain.com/AutoDiscover/AutoDiscover.xml

     

    Thursday, November 04, 2010 3:09 PM
  • Hi,

    Please confirm, which clustering model are you using and the version of the OS?

    Add more details about your servers, but on high level, I looked at the details

    Attempting to test potential Autodiscover URL https://xyz.com/AutoDiscover/AutoDiscover.xml
    Testing of this potential Autodiscover URL failed.
     Test Steps
     Attempting to resolve the host name xyz.com in DNS.
    The host name resolved successfully.
     Additional Details
    IP addresses returned: x.x.x.x.
     
     Testing TCP port 443 on host alvarezandmarsal.com to ensure it's listening and open.
    The specified port is either blocked, not listening, or not producing the expected response.
     <label for="testSelectWizard_ctl12_ctl06_ctl00_ctl00_ctl00_ctl01_tmmArrow">Tell me more about this issue and how to resolve it</label>
     

    Do a telnet from your desktop to server on port 443 to make sure the port is not blocked internally , if you trying to access it externally, you have to open that port on firewall aswell. in your case it's ISA 2006 I believe, make sure the PORT 443 is opened for your internal and external network.

    Keep us posted.

    Irfan.

     


    Irfan Ali. Snr. Infrastructure Consultant
    Thursday, November 04, 2010 5:40 PM