none
Outlook Client recurring appointments time zone / GMT offset problem

    Question

  • I will try to describe this with text, although it's a very visual problem.  I added a post to my blog with it so I could include pictures.  If you think you need pictures to understand the text below, please review that entry.  Please note, the one appointment instance cited below, is an example, there are many others with this same problem, and it only happens with recurring appointments.

     

    Relevant System Information:

    • Windows 7 Utlimate
    • Office 2010 Professional Plus (14.0.6023.1000 64-bit)
    • Exchange services hosted by Microsoft.
    • Android HTC Inspire 4G also configured as exchange active sync client.

     

    Issue Description:

    I have a specifications meeting that is scheduled for Tuesday mornings (every 2 weeks) at 8:30 am.  In the body of the appointment, it even has this text spelled out.  "When: Occurs every 2 weeks on Tuesday effective 11/23/2010 from 8:30 AM to 11:30 AM (UTC-05:00) Eastern Time (US & Canada)." as an indicator of the actual appointment time.  The problem is that one day, several weeks after this appointment had been sent to me, Outlook 2010 decided that it was really at 1:30 PM.  Since that time it's been showing incorrectly on my calendar at 1:30 PM.   So, I recognized almost immediately that this was a 5 hour difference, which happens to also be my timezone offset (except that I'm currently in daylight savings time -- so it's really a -4 offset right now).

    I ran the 2010 service pack 1 installer, based on the suggestion of my IT group, and found I already had the service pack installed.  I've tried the timezone tool as well and that didn't work.  Please keep reading.

    Next I went to my exchange host with outlook web access.   The appointment is closer to correct there, showing at 9:30am.  It think here it almost seems as though it's applying the DST, but not correctly, maybe doubling it?.  Meanwhile, back in outlook, if I go to the scheduling assistant and look at my time while making an appointment with other invitees it - much to my surprise - matches the time in OWA, not the time in outlook client.

    Finally, if I go to my Android and look at the appointment, it is correct.  8:30 AM.  

    So to summarize:

    • Real Appoinment:   8:30 AM
    • Outlook Client Time: 1:30 PM
    • OWA / Exchange Time: 9:30 AM
    • Android Calendar Time: 8:30 AM
    • This applies to many others, this is just a convenient example.
    • This applies only to recurring appointments.

    Any help would be very appreciated.

     

    Thanks,

    Jon

     

    Wednesday, August 03, 2011 12:09 PM

Answers

  • I can't say with absolute certainty, however I think I resolved this -- by changing my android client.   I recently bought a Kindle fire and paid the $20 license fee for Touchdown (by nitrodesk).   Since I had it anyway, I also installed it on my phone and my calendar seems to be working correctly now everywhere.   I think the bug, in my case, was in the HTC/Google implementation of Active Sync.   

    Touchdown had been recommeded by a colleague, there may be lower cost alternatives, I don't know.

    Wednesday, February 22, 2012 5:07 PM

All replies

  • Hi Jon,

     

    It appears you have two issues:

     

    1.    The meeting time is 1 hour behind the scheduled;

    2.    Some of your recurring meetings has 5 hours delay.

     

    Considering the mobile device—the Android—is used, I am suspecting the second issue is caused by the incorrect synchronization. It is common issues that a mobile device synchronization may corrupt an calendar item’s attribute.

     

    Generally, we will temp disable the thirdparty mobile device to isolate the fault.

     

    To fix this issue, we need to delete and update the problematic meeting via the meeting organizer.

     

    Regarding the first issue, since the time in Android calendar is correct, I suppose the DST hotfix is installed correctly in your Exchange servers; the issue might be caused by the machine you are using. And my suggestion is:

     

    1.    Run “fix it” tool from here, verify and make sure the latest DST hotfix is installed. If you are located in a special location, you might need to install additional DST hotfix like this one.

     

    For more information on DST, please refer to http://support.microsoft.com/kb/914387.

     

    2.    Verify the Time Zone Settings in your computer, make sure “Automatically adjust clock for Daylight Saving Time” is selected.

     

    3.    Log into OWA in another computer to see if the issue continues. If so, verify the regional settings in Option in OWA; make sure the regional is setup correctly.

     

    Hope it is helpful.


    Fiona
    Monday, August 08, 2011 6:05 AM
    Moderator
  • Any update?
    Fiona
    Thursday, August 11, 2011 10:18 AM
    Moderator
  • Sorry, for taking so long to reply.  I was on vacation last week and forgot about it, and then I also forgot that the email for this was pointed at my hotmail account.  I don't check that account very often, so today I finally made it back to checking this site.  Your response is rather helpful, and I agree with your assessment about the Android, however it is the one place I can go for an accurate picture of my calendar, so I'm very reluctant to disable it while trying to work out the issue.

    However, I need it all to work, so I'll do what I must ;-).

    When I try to run the "fix it" tool it gives me an error.  I tried in both IE 9 and in chrome.  

    I am configured locally for GMT -5 Eastern Time with the automatically adjust option selected.

    I also checked OWA as you suggested.  It is also set as Eastern Time

    I also checked the settings in outlook.   Again, GMT - 5

    Being unable to run the hotfix I can't say if that may or may not fix the problem, but it does continue to plague me at this time.

    Thursday, August 11, 2011 8:18 PM
  • Thanks for your udpate.

    Try to download the latest update here http://support.microsoft.com/kb/2570791.

    Note that, the update only affect the newly created meetings; for the existing recurring meetings that has incorrect time schedule, you need to run the update tool after intalling the hotfix.


    Fiona
    Friday, August 12, 2011 6:04 AM
    Moderator
  • I have ran the latest update.  I'll keep an eye on it going forward.  I have asked the owners of the errant meetings to send me updates, that has fixed them for now.

    Thanks for the help!  I'll update the issue if the problem reappears.

    Wednesday, August 17, 2011 1:03 AM
  • Thanks for the help Fiona, I'm just going to look into replacing my phone's calendar application.  Nothing else is helping.   An appointment *I* created (that's a first for this problem) fell victim to it this week.   I created a recurring appointment for 8:00 Tuesday mornings, and almost missed it this morning because outlook suddenly had it at 12:00p.  My phone buzzed in the other room was the only reason I made the call.

    The problem is very frustrating.   I'm going to, as a last ditch effort, contact HTC to see if they have a known bug or a "hotfix" for this or something.

    Regardless, thanks for the help on this.

    Tuesday, September 20, 2011 12:10 PM
  • Jonathan,

    Did you ever find any resolution to this?

    I am experiencing your same issue step by step.

    I even deleted several of the calender items and re-created them. Again after a few days the times changed in Outlook, but are fine in both my HTC Evo, iPad, and even Outlook Web. The only problem is in Outlook 2010 itself.

    Thanks,

    Shawn


    Sean
    Thursday, December 01, 2011 8:02 PM
  • No, Shawn, unfortunately not.  I thought so, but just today I had a 10:00am (ET) meeting and was late because my calendar at it at 3:00pm. Even in the body of the invite it said 10:00am, but it was wrong on the calendar.   I checked my phone, and it was correct there.
    Friday, January 20, 2012 4:09 PM
  • I've been having this issue for over six months now. I have tried all updates. I even got a different machine.

    This is really causing some headaches on recurring meetings for work. I'm risking missing them-- sure, they're all recurring so I could remember, but then what's the point of having a calendar?

    Tuesday, February 14, 2012 9:06 PM
  • I can't say with absolute certainty, however I think I resolved this -- by changing my android client.   I recently bought a Kindle fire and paid the $20 license fee for Touchdown (by nitrodesk).   Since I had it anyway, I also installed it on my phone and my calendar seems to be working correctly now everywhere.   I think the bug, in my case, was in the HTC/Google implementation of Active Sync.   

    Touchdown had been recommeded by a colleague, there may be lower cost alternatives, I don't know.

    Wednesday, February 22, 2012 5:07 PM
  • I have experienced the same thing, and I'll agree - it appears to be the HTC/Verizon implementation of ActiveSync on Gingerbread 2.3.4. Curious - has anyone here opened a case with HTC?

    My Scenario:

    SOME Outlook 2010 Calendar appointments (not all) shift by 5 hours ahead, seemingly at random. (I believe the 5 hour difference has to do with us being in the Eastern Time Zone (UTC-5). Sometimes it is the meeting organizer, and sometimes it is one (or possibly more) of the attendees who are impacted, but the rest of the attendees and the organizer’s appointments still show up in the right time slot. For the impacted users, logging into OWA and looking at the phone calendar, the time slots are correct, even though the Outlook appointment is incorrect.

    Criteria:

    This appears to be limited to Outlook 2010 on Windows 7, where the impacted individuals are utilizing ActiveSync with the stock email client on an HTC Android running Gingerbread (2.3.4 from HTC/Verizon).

    NOTE: While this issue presently appears to be limited to users with Android devices, since it is apparently possibly caused by a setting that sent from the device over ActiveSync, it is conceivable that ANY ActiveSync client could cause this issue – not just Android.

    Research thus far:

    I did a significant amount of digging and happened across this link (no solution, but HTC and Microsoft are aware of the issue):

    Outlook 2010 shows calendar appointments in the wrong time for Incredible 2 users

    After getting the response from the OP, I did some more digging, and came across this link in the Microsoft Communities (still no solution, though):

    Recurring Calendar Appointment shifted 6 hours later in Outlook 2010 (maybe ActiveSync)

    Which led me to post this question in the Exchange Server forum (which was before I found your thread):

    Calendar appointments move by 5 hours (or whatever the TZOffset is) - ActiveSync issue?

    If I gain any further insight, I'll post here. As for changing to Touchdown, my opinion is that if HTC can't or won't fix this, then Touchdown is the best app for the job.

    Jonathan

    Wednesday, April 18, 2012 1:56 PM
  • Status Update, and recommended next steps:

    I opened a ticket with HTC support the day before yesterday (Ticket # 03543601). The initial response was an email reply with the typical level one suggestion to remove and re-add the Exchange ActiveSync account on my phone, and if that didn't resolve the issue to do a hard reset and then add the account again. Since I have multiple users experiencing this same issue, where the common denominator seems to be centralized around the move from Outlook 2007 to 2010 and the HTC Gingerbread OS, I convinced them that this would not be an acceptable remedy, and my case was immediately escalated without hesitation. I will say that though I don't have a resolution, I'll applaud HTC for not giving me the runaround and giving me a live person who could talk intelligently about the issue.

    Today, I received a phone call back on this ticket  from someone in the escalations department at HTC named Travis. After explaining the issue in detail to him and referencing this specific thread, he acknowledged that it did in fact sound like a coding issue coming from the device where the value in the “dispidApptTZDefStartDisplay” property was being set improperly by the device/stock email/calendar application in their implementation of ActiveSync. He then stated that he would relay this to the developers to look into the issue. He further elaborated that the case would either be in a status of, "this is being looked into", or "We believe this to be resolved in [x] update". He said that they will probably continue releasing updates for the Incredible (I did not specifically ask about the Incredible 2), and while the Incredible 2 is definitely slated to get Ice Cream Sandwich, the Incredible one is still in a classification of, "being evaluated". Personally, I doubt that the Inc 1 will get ICS, but it is possible. From what I have read, the general stance is that phones will be updated for 18 months after release, and the Inc 1 is 24 months old this month (bummer - I REALLY like this phone).

    According to Verizon and HTC, these are the phones that will get ICS (or Android 4.0):

    Ice Cream Sandwich Coming to Many Verizon Wireless Smartphones

    Android 4.0, Ice Cream Sandwich Updates

    While it is possible that an update will be released for the Incredible 1 to fix this issue, it will likely be months before one is available, so we'll probably have to move to Touchdown for Exchange by NitroDesk in order to resolve this issue....or move to a newer phone with ICS 4.0.

    Speaking of which, there is a whole laundry list of issues with Exchange ActiveSync and third-party devices. A number of them are listed in this Microsoft KB article:

    Current issues with Microsoft Exchange ActiveSync and third-party devices

    Per the article:

    Microsoft's recommendation for Android - Upgrade to Android OS 4.0
    Microsoft's recommendation for iPhone/iOS devices - Upgrade to iOS version 5

    So, for anyone on Android experiencing this issue (or others listed in the Microsoft KB above), if your phone is likely to get ICS soon, then you may want to hold on and just be vigilant about checking your calendar on OWA. If your phone isn't slated to get ICS or if you can't wait, my recommendation is to get Touchdown for $20. You may still have to delete and re-create appointments that are wrong, but hopefully the issue won't happen any more once you move to Touchdown. And if they do, at least you've got a shot at a more rapid fix with a company like NitroDesk. (no offense HTC).

    Good luck. I probably won't post again unless I get notice of a fix for this specific issue or some other significantly useful information.

    Jonathan, MCSE

    For reference, here are other forums where this same issue has been discussed:

    Weird Outlook issue

    Calendar appointments move by 5 hours (or whatever the TZOffset is) - ActiveSync issue?

    Outlook Client recurring appointments time zone / GMT offset problem (This is the thread that you are presently reading)

    Outlook 2010. Recurring meeting time off by 5 hours, what is the problem?

    Recurring Calendar Appointment shifted 6 hours later in Outlook 2010 (maybe ActiveSync)

    Friday, April 20, 2012 7:44 PM
  • My boss is having a similar problem with her HTC Evo phone (on Gingerbread) and Outlook 2007 on Windows 7. She keeps showing up at recurring meetings an hour late, and is not happy. From these threads it sounds like the only advice I can give her at this time is to stop using her phone with her calendar. Pretty pathetic...

    Although I guess there is the option of installing TouchDown. I guess I'll try that route first.

    Wednesday, May 09, 2012 1:57 PM
  • I just wanted to post to see if there was any news on this problem.  I had this problem previously with my Sprint HTC EVO 4G.  I ended up having to stop the sync and just rely on my desktop calendar in Outlook 2010.  I recently upgraded to the EVO 4G LTE with ICS and thought for sure the problem would be resolved here.  But I was wrong.  I have had my recurring appointments start shifting again by the TZ differential.  If anyone had an update it would be much appreciated.
    Friday, August 31, 2012 4:18 PM
  • I HAVE IT!

    I just got off the phone with HTC Support and after a little prodding (No, I do not want to remove the ActiveSync Account, again).  They found the solution!  In Outlook 2010 Select the View Ribbon>ViewSettings>Reset Current View.  This put the appointments back in the right place in Outlook. Thanks HTC!

    • Proposed as answer by Poozr Friday, August 31, 2012 6:30 PM
    Friday, August 31, 2012 6:30 PM
  • I no longer have the problem after switching to using Touchdown, and I didn't at any point have to reset the current view.  That being said, I would like to know if this solves the problem long term for you.  So I can update my post blog post with it, and so I can help any colleagues who may run into the problem in the future.

    Thanks for providing your solution!

    Friday, August 31, 2012 6:34 PM
  • I have the same problem. I'm in EDT, Outlook 2010 shows some events 4 hours late, but my HTC Inspire running Android 2.3.3 and Web Outlook show the same events at the correct time. It's always recurring events, and they show up correct initially.

    Answering Jonathan's question, doing Reset Current View did not help me.

    Friday, September 07, 2012 8:27 PM
  • Not sure if you got this resolved - but i ran into a similar issue just recently.  For me the issue appeared to be in Outlook 2007.  When i edited a re-occuring appointment and clicked on re-occurence - its there that i saw the wrong time zone listed.  It was the right -5  but wrong location.  In my case -5 bogata and not -5 Eastern Canada.

    I have to now edit all the reoccuring  appointment's timezone but its only a hand full of events.

    Hope that helps

    Monday, September 10, 2012 7:23 PM
  • We have similar issue from  last 6 month .  For me the issue appeared to be in Outlook 2010.  

    Any one got solution for this.. Not reset view setting that does not work





    Tracking encrypted mail send from exchagne server 2007

    Thursday, October 04, 2012 7:39 AM
  • I am experiencing an IDENTICAL problem with the following setup.

    Exchange 2003, MS Outlook for Office 2010, Mobile Devices Blackberry Torch, Iphone 3gs, Ipad 2nd gen.

    The meeting was organised by the Directors PA who sent the request out. The meeting is scheduled for 9-9:15 and reoccurs every day of the working week baring Wednesdays.

    When i open the Directors calendar SERIES on a THURSDAY & go to PRINT the meeting out, in the PRINT & the PREVIEW if i check the REOCCUERENCE PATTERN, it shows the meeting being scheduled on the correct days but from 4-4:15 instead of 9-9:15. This only shows on the 1 date and does not show up on others dates or on the date in question as an occurrence. 

    Any Ideas??

    Friday, October 19, 2012 11:40 AM
  • Microsoft also does not have any solution for this issue. its more then  6 month now. Kindly update progress(as above mention by microsoft partner) on this issue?


    Tracking encrypted mail send from exchagne server 2007

    Monday, October 29, 2012 11:42 AM
  • Any progress?

    Tracking encrypted mail send from exchagne server 2007

    Monday, November 05, 2012 2:32 PM
  • Hi,

    I also had the same problem. Outlook client had incorrect time listed, OWA and android had it correct. Probably, I found one work-around solution for this.

    The OWA deleted item, somehow, had two meeting invites listed. Whereas, the organizer had sent it only once. The outlook client had only one instance of the invite (in deleted items).

    Surprisingly, the receive time for both the invites was exactly same in OWA deleted items. (Which confirms some issue with the outlook client/ OWA/ some sync up mess).

    Out of the two invites, one of them had the correct time and correct time zone, other one had the correct time zone but actual time from a different time zone.

    I declined the incorrect invite and re-accepted the correct one. It worked for me. The time got corrected at all the places.

    Wednesday, January 08, 2014 5:18 AM