none
4.4.1 Connection timed out

    Question

  • During sending about 2000 e-mails through Exchange 2010 server, after 500 sends, we get the following error:

    System.Net.Mail.SmtpException: Service not available, closing transmission channel. The server response was: 4.4.1 Connection timed out

       at System.Net.Mail.MailCommand.CheckResponse(SmtpStatusCode statusCode, String response)

       at System.Net.Mail.SmtpTransport.SendMail(MailAddress sender, MailAddressCollection recipients, String deliveryNotify, SmtpFailedRecipientException& exception)

       at System.Net.Mail.SmtpClient.Send(MailMessage message)

     

    Before moving to 2010 using Exchange 2003 this has never happend. Any ideas how to solve this?

    Regards,Miha

    Thursday, September 16, 2010 8:00 AM

Answers

  • Hi,

    Are you using a program to send the mails through Exchange 2010 server?

    Try to modify the following settings of the receive connector is capable of receiving mails from your programs:

    Open EMS, type:

    Set-receiveconnector -identify "your receiveConnector" -connectiontimeout:00:30:00

    Then test to see if the issue persists.

    More information:

    Set-ReceiveConnector

     http://technet.microsoft.com/en-us/library/bb125140.aspx

     


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Thanks Gen Lin-MSFT
    Friday, September 17, 2010 10:11 AM

All replies

  • Hi,

    Are you using a program to send the mails through Exchange 2010 server?

    Try to modify the following settings of the receive connector is capable of receiving mails from your programs:

    Open EMS, type:

    Set-receiveconnector -identify "your receiveConnector" -connectiontimeout:00:30:00

    Then test to see if the issue persists.

    More information:

    Set-ReceiveConnector

     http://technet.microsoft.com/en-us/library/bb125140.aspx

     


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Thanks Gen Lin-MSFT
    Friday, September 17, 2010 10:11 AM
  • Thanks!
    Monday, September 27, 2010 2:09 PM
  • Hi,

    Are you using a program to send the mails through Exchange 2010 server?

    Try to modify the following settings of the receive connector is capable of receiving mails from your programs:

    Open EMS, type:

    Set-receiveconnector -identify "your receiveConnector" -connectiontimeout:00:30:00

    Then test to see if the issue persists.

    More information:

    Set-ReceiveConnector

     http://technet.microsoft.com/en-us/library/bb125140.aspx

    The first parameter should be -identit


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Thanks Gen Lin-MSFT

    Friday, March 18, 2011 1:00 PM
  • This works

    [PS] C:\Windows\system32>Get-receiveconnector

    Identity                                Bindings                                Enabled
    --------                                --------                                -------
    SRV-EXCH07\Default SRV-EXCH07           {:::25, 0.0.0.0:25}                     True
    SRV-EXCH07\Client SRV-EXCH07            {:::587, 0.0.0.0:587}                   True
    SF-DEV-EXC10\Default SF-DEV-EXC10       {:::25, 0.0.0.0:25}                     True
    SF-DEV-EXC10\Client SF-DEV-EXC10        {:::587, 0.0.0.0:587}                   True

    [PS] C:\Windows\system32>Set-receiveconnector -identity "SF-DEV-EXC10\Default SF-DEV-EXC10" -connectiontimeout:00:30:00

    thank you


    Saturday, June 16, 2012 3:30 PM