none
OWA error - Outlook Web App didn't intialize

    Question

  • Clean install of Exchange 2010 on Server 2008 R2 in a 2003 AD environment. Only 2 mailboxes created so far.

    After logging in to OWA (forms based auth), the error message appears:

    Outlook Web App didn't initialize. If the problem continues, please contact your helpdesk.
    Copy error details to clipboard Show details
    Request Url: https://exchange:443/owa/auth/error.aspx
    User host address: 192.168.60.131
    OWA version: 14.0.639.21



    The mailbox is available using Outlook 2003 and nothing seems out of the ordinary on the server. I've restarted IIS just in case, but no luck.



    EDIT: Located the following in Event Log:

    There's an error in your configuration.

    The authentication type specified in the C:\Program Files\Microsoft\Exchange Server\V14\ClientAccess\owa\web.config file is incorrect. The correct authentication type is "Windows".



    Following instructions in another technet article I'd changed to Forms but by changing the web.config file to "Windows" it fixed the problem. Now to see if it broke anything else.

    Wednesday, January 27, 2010 10:20 PM

Answers

  • Hi,

    How about your question now? I found same solution with yours about the error.

    After making a backup copy of the file, find the authentication mode and verify that it is set to Windows: <authentication mode="windows" />,
    restart the IIS Admin Service, is there any error now?


    Frank Wang
    • Marked as answer by Frank.Wang Wednesday, February 03, 2010 1:33 AM
    Friday, January 29, 2010 2:31 AM

All replies

  • Hi,

    How about your question now? I found same solution with yours about the error.

    After making a backup copy of the file, find the authentication mode and verify that it is set to Windows: <authentication mode="windows" />,
    restart the IIS Admin Service, is there any error now?


    Frank Wang
    • Marked as answer by Frank.Wang Wednesday, February 03, 2010 1:33 AM
    Friday, January 29, 2010 2:31 AM
  • Frank,

    I found this page because I got the same problem.

    I try to follow your suggestion but no luck. I then found the correct setting is "Windows" (capital 'W').

    You might want to update your answer.

    Thanks,


    Ray
    Thursday, April 29, 2010 2:47 AM
  • I have the same problem. Here's the error:

    Request

    Url: https://xxxxxxxxxxxx.local:443/owa/auth/error.aspx?url=https://xxxxxxxxxxxx.local/owa/&reason=0

    User host address: 192.168.1.105

    OWA version: 14.0.639.21

     

    Exception

    Exception type: Microsoft.Exchange.Clients.Owa.Core.OwaInvalidConfigurationException

    Exception message: Cannot find information about the local server EX2010.xxxxxxxxxxxx.local in Active Directory. This may be related to a change in the server name.

     

    Call stack

     

    Microsoft.Exchange.Clients.Owa.Core.OwaConfigurationManager.CreateAndLoadConfigurationManager() 

    Microsoft.Exchange.Clients.Owa.Core.Globals.InitializeApplication() 

    Microsoft.Exchange.Clients.Owa.Core.Global.ExecuteApplicationStart(Object sender, EventArgs e)

     

    Inner Exception

    Exception type: Microsoft.Exchange.Data.Directory.LocalServerNotFoundException

    Exception message: Cannot find information about the local server EX2010.xxxxxxxxxxxx.local in Active Directory. This may be related to a change in the server name.

     

    Call stack

     

    Microsoft.Exchange.Data.Directory.SystemConfiguration.ADSystemConfigurationSession.FindLocalServer() 

    Microsoft.Exchange.Clients.Owa.Core.OwaConfigurationManager.InitializeConfigurationManager() 

    Microsoft.Exchange.Clients.Owa.Core.OwaConfigurationManager.CreateAndLoadConfigurationManager()

    Tuesday, October 26, 2010 6:21 AM
  • Hi, I was getting the same issue - seemingly brought about by the installation of Exchange 2010 SP1 Update Rollup 1.

    Please note: Mine is a lab environment so please validate these procedures and modify accordingly to fit your environment; use proper precautions and ensure you have a backup before attempting these steps in production; and Always, always confirm the steps in a TEST environment before moving to production.

    My Setup:

    - Windows 2008 R2
    - Exchange 2010 SP1 + Update Rollup 1 - NOTE this is Update Rollup 1 for Exchange 2010 SP1 - so Post SP1 - apparently this is not generally available for download. It came down as a Windows Update.

    Symptoms experienced:
    1. OWA site would load internally but not externally
    2. After entering credentials at OWA login page, receieved the above error (OWA not initialized) and after mucking around with permissions i would also get HTTP 400 (which if you turn off friendly errors in IE Advanced options translates into 'Bad Request')
    3. I found this article that states it's a known issue and that they are working on it (although in that article they are talking about selecting a different language at first login). These steps however did not fix it for me.

    What i tried to fix this problem:
    1. I tried mucking arround with the ISS virtual directory permissions - boy that was a mistake.
    2. Uninstalled and re-installed Rollup Update 1
    3. Followed the instructions in the article at above link and changed the default language

    none of it made a difference.

    Here's what did work. I don't recall the article but, i remember reading an article that suggested that you remove the OWA virtual directory and then re-create a new one. So with nothing left to lose, i decided to give it a try:

    1. Run CmdLet: Remove-OwaVirtualDirectory -identity "ExCASServerName\OWA (Default Web Site)"
    Substitue Your CAS HostName for ExCASServerName
    Assumption: OWA site is named OWA - actually cannot/should not be named anything else
    Assumption: The OWA virtual Directory exists under the 'Default Web Site' - That is, the name of the IIS 7 Website is 'Default Web Site'

    2. The above command removes the OWA and Exchange (and maybe even ExchWeb - i don't recall) virtual directories

    3. On the affected CAS server Run the CmdLet: New-OWAVirtualDirectory -Name OWA -WebSite "Default Web Site"

    4. open the EMC and locate the affected CAS server under Server Configuration/Client Access and edit the properties of the (new) OWA virtual directory.

    5. At this point i did not see the Internal / External URLs populated on the General Tab - So I populated each appropriately and applied the settings

    6. At this point, i received a warning stating that no authentication method had been specified for the (new) OWA virtual directory.

    7. So on the Authentication tab (OWA virt dir properties) i configure 'Forms based authentication' and the appropriate 'Logon Format' - in my case i selected the option to login with username only and selected my domain... but this is just my preference.

    8. Finally i ran an IISREST /NOFORCE

    and well what do you know?... I got my OWA back - internally at least... still need to try externally.
    Salig950
    • Proposed as answer by Matt Slaga Wednesday, December 22, 2010 8:41 PM
    Thursday, November 18, 2010 3:23 AM
  • Salig,

     

    Thank you so much :) you have made my life easy. I was struck on this issue for the past 1 week. once again, thanks :)

    Monday, January 31, 2011 9:37 AM
  • Salig, Big thanks for your little tutorial. I was about to reinstall the entire exchange server until I stumbled in to your post. It took me 3 minutes and the whole server was functional again! 

     

    Props to you sir!

    Thursday, September 15, 2011 5:31 PM
  • salig thanks  for your help.

    but externally did not work for me. did not receive external mail in my exchange can you help me please. my mail id itraj123@gmail.com


    • Edited by ramboraj123 Monday, August 20, 2012 6:26 AM
    Monday, August 20, 2012 6:25 AM
  • I had this problem as well. Lucky for me I was setting up 2 servers at once. One had the problem the other did not. The only diferance was on one (the one with broken OWA) I had gone thru the BPA and resolved many of the issues, the other I had not. Looking at the Applications pools on the broken server all the MSexchange App pool identities were set to ApplicationPoolIdentity (PER BPA Recommendations), on the working machine they were set to LOCALSYSTEM. I changed all the identities on the broken machine to LOCALSYSTEM and Shazam working OWA again.
    Thursday, March 28, 2013 2:54 PM
  • Quick fix:

    1)Remove the external and ionternal addresses.

    2) Apply

    3) Enter the addresses back.

    4)Apply

    Worked for me!

    Monday, August 12, 2013 6:53 PM