none
Migration form EX2003 to EX2007 mailbox cannot be moved

    Pregunta

  • Hello, we are migrating to from Ex 03Ex07 and encoutnered that a users mailbox cannot be moved. Error: Database is mandatory on UserMailbox. It was running command 'move-mailbox -TargetDatabase 'XXXX\First Storage Group\Mailbox Store.

    bis

    jueves, 01 de marzo de 2012 11:30

Respuestas

  • On Fri, 2 Mar 2012 09:07:00 +0000, bsunuwar wrote:
     
    >yes my E2K3 has database assigned
     
    Before you do this, make sure that you have all the information about
    the mailbox saved somewhere and that database's "Keep deleted
    mailboxes for (days)" has a value greater than zero so you can recover
    a deleted mailbox.
     
    1. Use the Active Directory Users and Computers
    2. Find the mailbox
    3. Right-click the mailbox
    4. Select "Exchange tasks..."
    5. Select "Remove Exchange Attributes"
    6. Click "Next" twice
     
    When the task finishes, wait a little while for AD replication to
    finish and then switch to the Exchange System Manager, navigate to the
    mailbox database and right-click on the "Mailboxes" view. Select "Run
    Cleanup Agent" and wait for it to finish. Then right-click the
    disconnected mailbox and select "Reconnect". Find the user and
    reconnect the mailbox.
     
    Wait for AD replication to finish and then switch back to the ADUC and
    put the information back into the mailbox properties (Custom
    Attributes, additional e-mail addresses, etc.).
     
    Wait for AD replication to finish and try moving the mailbox again.
     
    ---
    Rich Matheisen
    MCSE+I, Exchange MVP
     

    --- Rich Matheisen MCSE+I, Exchange MVP
    • Marcado como respuesta bsunuwar lunes, 19 de marzo de 2012 9:49
    sábado, 03 de marzo de 2012 3:26

Todas las respuestas

  • Hello, we are migrating to from Ex 03Ex07 and encoutnered that a users mailbox cannot be moved. Error: Database is mandatory on UserMailbox. It was running command 'move-mailbox -TargetDatabase 'XXXX\First Storage Group\Mailbox Store.

    bis

    jueves, 01 de marzo de 2012 11:31
  • Hello, we are migrating to from Ex 03Ex07 and encoutnered that a users mailbox cannot be moved. Error: Database is mandatory on UserMailbox. It was running command 'move-mailbox -TargetDatabase 'XXXX\First Storage Group\Mailbox Store.

    bis

    jueves, 01 de marzo de 2012 11:35
  • Run:

    move-Mailbox -Identity <alias> -TargetDatabase <database of Exchange 2007>

    Target database is the database where you will be moving that user. (Here it would be database from Exchange 2007 server)

    Use the exchange management console if its complicated for you.

    Cheers! 


    Vinit Nair MCSE | MCITP - Exchange 2007 "Sanity and happiness are an impossible combination."

    • Marcado como respuesta bsunuwar jueves, 01 de marzo de 2012 13:21
    • Desmarcado como respuesta bsunuwar jueves, 01 de marzo de 2012 13:21
    jueves, 01 de marzo de 2012 13:05
  • I am using exchange management console. The problem is there used to be exchange server 2003 which was used for internal email system then i installed exchange 2007 on another server then i tried to move mailbox using exchange 2007 but it comes with this error. When i open up system manager on old server exchange 2003 it shows exchange 2007 server on server list and no first administrative server. I am confused I cant configure old exchange 2003 nor i can move mailbox to exchange 2007. I installed both server in same domain and in same Active directory so that must be the cause. I tried uninstalling exchange 2003 and reinstall and restore mailbox but again setup comes with error ......


    bis

    jueves, 01 de marzo de 2012 13:27
    1. Does event viewer provide any errors that are pertinent
    2. is this the only user that has experienced the issue?
    3. How are you doing the move mailbox, i.e. by cmdlet or GUI?
    4. Have you run Get-MoveRequestStatistics so that you can see whats going on?  Could be that you need to set the BadItemLimit, here is a good troubleshooting document http://technet.microsoft.com/en-us/library/dd638094.aspx

    Troy Werelius
    www.Lucid8.com
    Search, Recover, & Extract Mailboxes, Folders, & Email Items from Offline EDB's and Live Exchange Servers with Lucid8's DigiScope

    jueves, 01 de marzo de 2012 15:43
  • I would check the attributes on the source user account to make sure that it's HomeDB attribute is set correctly in AD.  You can use ADSIEdit to browse to the user account, right click on the account and select properties.  Then look for HomeDB and see if this database is correct.

    JAUCG

    jueves, 01 de marzo de 2012 15:57
  • I am using exchange management console. The problem is there used to be exchange server 2003 which was used for internal email system then i installed exchange 2007 on another server then i tried to move mailbox using exchange 2007 but it comes with this error. When i open up system manager on old server exchange 2003 it shows exchange 2007 server on server list and no first administrative server. I am confused I cant configure old exchange 2003 nor i can move mailbox to exchange 2007. I installed both server in same domain and in same Active directory so that must be the cause. I tried uninstalling exchange 2003 and reinstall and restore mailbox but again setup comes with error ...... and I am using GUI

    I also uninstalled exchange 2003 now there`s even more problem. I am worried how can i get my calenders appointment. I have copied all exchange server 2003 folger "exchservr" would that save all my email and calender stuff??? 


    bis

    jueves, 01 de marzo de 2012 19:20
  • On Thu, 1 Mar 2012 11:35:58 +0000, bsunuwar wrote:
     
    >Hello, we are migrating to from Ex 03Ex07 and encoutnered that a users mailbox cannot be moved. Error: Database is mandatory on UserMailbox. It was running command 'move-mailbox -TargetDatabase 'XXXX\First Storage Group\Mailbox Store.
     
    Does the E2K3 mailbox have a mailbox database assigned to it?
     
    ---
    Rich Matheisen
    MCSE+I, Exchange MVP
     

    --- Rich Matheisen MCSE+I, Exchange MVP
    jueves, 01 de marzo de 2012 22:49
  • bsunuwar,


    Nelson N Exchange 2003|2007|2010

    viernes, 02 de marzo de 2012 8:25
  • can you get me the event logs while this operation fails..


    Nelson N Exchange 2003|2007|2010

    viernes, 02 de marzo de 2012 8:25
  • I would say you can check the following attributes

     -discovery mailbox :
           - HomeMTA: point to Microsoft MTA
           - HomeMDB  : point to DN of database
      -federation email:
           - HomeMTA: point to Microsoft MTA
           - HomeMDB  : point to DN of database

    Let me know if this helps


    Nelson N Exchange 2003|2007|2010

    viernes, 02 de marzo de 2012 8:34
  • Hi Rich, 

    yes my E2K3 has database assigned 


    bis

    viernes, 02 de marzo de 2012 9:07
  • I had same issue ,check the following attributes

    -discovery mailbox :
           - HomeMTA: point to Microsoft MTA
           - HomeMDB  : point to DN of database
      -federation email:
           - HomeMTA: point to Microsoft MTA
           - HomeMDB  : point to DN of database


    Nelson N Exchange 2003|2007|2010

    viernes, 02 de marzo de 2012 9:12
  • On Fri, 2 Mar 2012 09:07:00 +0000, bsunuwar wrote:
     
    >yes my E2K3 has database assigned
     
    Before you do this, make sure that you have all the information about
    the mailbox saved somewhere and that database's "Keep deleted
    mailboxes for (days)" has a value greater than zero so you can recover
    a deleted mailbox.
     
    1. Use the Active Directory Users and Computers
    2. Find the mailbox
    3. Right-click the mailbox
    4. Select "Exchange tasks..."
    5. Select "Remove Exchange Attributes"
    6. Click "Next" twice
     
    When the task finishes, wait a little while for AD replication to
    finish and then switch to the Exchange System Manager, navigate to the
    mailbox database and right-click on the "Mailboxes" view. Select "Run
    Cleanup Agent" and wait for it to finish. Then right-click the
    disconnected mailbox and select "Reconnect". Find the user and
    reconnect the mailbox.
     
    Wait for AD replication to finish and then switch back to the ADUC and
    put the information back into the mailbox properties (Custom
    Attributes, additional e-mail addresses, etc.).
     
    Wait for AD replication to finish and try moving the mailbox again.
     
    ---
    Rich Matheisen
    MCSE+I, Exchange MVP
     

    --- Rich Matheisen MCSE+I, Exchange MVP
    • Marcado como respuesta bsunuwar lunes, 19 de marzo de 2012 9:49
    sábado, 03 de marzo de 2012 3:26
  • Hello bsunuwar,

    Is that mailbox still on your Exchange 2003?

    If you use commands to move the mailbox from Exchange 2007, what error did you get ?

    Could you give me a screenshot for your error?

    Thanks,

    Evan


    Evan Liu

    TechNet Community Support

    lunes, 05 de marzo de 2012 9:17
    Moderador
  • Hi Evan,

                I have uninstalled EX2003 but with errors and now left with EX2007. Both severs are in same active directory and in same domain but only thing that is on my mind is if u install second exchange server 2007 in existing domain how can new exchange server 2007 transfer all mailbox to its own and why cant i see my mailbox in old EX2003 SERVER. When i try to install ex2003 again it gives out erroe mapi32.dll is not the correct version i know this is because of schema change while installing 2007. loads of problem 


    bis

    lunes, 05 de marzo de 2012 11:07