none
Outlook 2007 Exchange 2007 out of office assistant does not work for some users when using Outlook Anywhere

    Pregunta

  • We are running Exchange 2007 (Version 8.1 (Build 240.6)) on Windows server 2008 standard (64 bit). Our clients are running Windows vista business (machines are joined to the domain) with Outlook 2007 sp2. Many users are configured to use Outlook anywhere when roaming. When they are not on the network, many of them are unable to use Out of Office Assistant. They get a message that says cannot connect to the server at this time. Please try again later. They are connected to exchange when they get this message (they can send/receive...), but they cannot configure out of office.

    Any help would be greatly appreciated.

    SJ

    lunes, 27 de julio de 2009 13:22

Respuestas

  • Hi,

     

    From your Test-OutlookWebServices result, I got following info:

     

    1016                      Information [EXPR]-The AS is not configur...

     

    Looks like the external Availability service URL is not configured. I suggest you run get-webservicesvirtualdirectory to check whether the external URL is configured. If not, you need to use Set-WebServicesVirtualDirectory command with externalURL parameter to set the external URL.

     

    For your reference:

     

    Get-WebServicesVirtualDirectory

    http://technet.microsoft.com/en-us/library/aa998810.aspx

     

    Set-WebServicesVirtualDirectory

    http://technet.microsoft.com/en-us/library/aa997233.aspx

     

    In addition, you need to configure DNS in order to have the client able to resolve external URL to correct IP address. Then, please attempt to set OOF on Outlook Anywhere client again.

     

    If the issue persists, would you please run test-outlookwebservices -clientaccessserver "mail01" |fl to get detailed information?

     

    Mike

     

     

    • Marcado como respuesta slj333 miércoles, 29 de julio de 2009 15:54
    miércoles, 29 de julio de 2009 14:24
  • Hello Mike and Harpreet,
    I made the following change >Set-OutlookProvider EXPR -CertPrincipalName:"msstd:mail.mycompany.com"

    and now we pass the www.testexchangeconnectivity.com site.

    The other test also passes
    em32>test-outlookwebservices -clientaccessserver "mail01"

                                                Id                                                               Type Message
                                                --                                                               ---- -------
                                              1003                                                        Information About to test AutoDiscover with the e-mail address dseffren@de...
                                              1007                                                        Information Testing server MAIL01.mycompany.COM with the published name h...
                                              1019                                                        Information Found a valid AutoDiscover service connection point. The AutoD...
                                              1006                                                        Information The Autodiscover service was contacted at https://MAIL01.SE...
                                              1016                                                            Success [EXCH]-Successfully contacted the AS service at https://mai...
                                              1015                                                            Success [EXCH]-Successfully contacted the OAB service at https://ma...
                                              1014                                                            Success [EXCH]-Successfully contacted the UM service at https://mai...
                                              1016                                                        Information [EXPR]-The AS is not configured for this user.
                                              1015                                                            Success [EXPR]-Successfully contacted the OAB service at . The elapsed...
                                              1014                                                        Information [EXPR]-The UM is not configured for this user.
                                              1017                                                            Success [EXPR]-Successfully contacted the RPC/HTTP service at https://...
                                              1006                                                            Success The Autodiscover service was tested successfully.

    I created a new mail profile on a remote machine (not on trusted or vpn network). Outlook anwhere is happy (using msstd:mail.mycompany.com for proxy), but OUt of Office still doesn't work.

    Thank you,
    SJ

    • Marcado como respuesta slj333 miércoles, 29 de julio de 2009 15:54
    miércoles, 29 de julio de 2009 15:14

Todas las respuestas

  • Hi.

    Please very the configuration of Outlook Anywhere by testing it on with this site: https://www.testexchangeconnectivity.com/ and post the results here.

    Regards,

    Johan
    blog: www.johanveldhuis.nl
    lunes, 27 de julio de 2009 14:24
  • Hi,

    I would suggest that you check this Auto Discover White paper for Exchange 2007 - http://technet.microsoft.com/en-us/library/bb332063.aspx 

    It could be possible that you have not configured your Auto Discover Service and as a result your OOF, F/B (even OAB, if its not distributed using PF) would not work.

    Check the white paper that I have shared, and you get a basic overview Auto Discover service and its dependencies.

    You can also use the https://www.testexchangeconnectivity.com/ and click on the option for "Outlook Anywhere with Auto Discover" and check if it passes any of the 4 steps.

    If auto discover is not configured, then you can follow the same white paper and use any of the suitable scenarios
    Harpreet Singh Khandiyal (http://support.microsoft.com/kb/555375)
    lunes, 27 de julio de 2009 20:24
  • Here is a command that I tried to run, and what the result was



    [PS] C:\Windows\System32>Enable-OutlookAnywhere -Server mail01 -ExternalHostname "mail.mycompany.com" -DefaultAuthenticationMethod "Basic" -SSLOffloading:$False
    Enable-OutlookAnywhere : The virtual directory 'Rpc' already exists under 'MAIL01.mycompany.COM/Default Web Site'.
    Parameter name: VirtualDirectoryName
    At line:1 char:23
    + Enable-OutlookAnywhere  <<<< -Server mail01 -ExternalHostname "mail.mycompany.com" -DefaultAuthenticationMethod "Basic" -SSLOffloading:$False
    [PS] C:\Windows\System32>
    martes, 28 de julio de 2009 20:40
  • Please check if Outlook Anywhere is already enabled on Exchange Management Console? (not shell)
    You can find that under Server Container > Client Access > Exchange Server's properties > click on Outlook Anywhere tab
    If Outlook Anywhere is already enabled that you will get the above error.
    The issue is not with enabling or disabling Outlook Anywhere, please check the steps that I have included in my previous post
    Harpreet Singh Khandiyal (http://support.microsoft.com/kb/555375)
    martes, 28 de julio de 2009 21:51
  • Hello Harpreet and thank you for responding. I am sorry, but I don't know which item to check next (based on your previous post). We do have a UCC, and that is working well. It is only on machines that are not on the vpn that are using Outlook Anywhere that have issues with Free busy information as well as Out of the Office. Here is some additional information.

    [PS] C:\Windows\System32>test-outlookwebservices -clientaccessserver "mail01"

                                   Id                             Type Message
                                   --                             ---- -------
                                 1003                      Information About to test AutoDiscover wi...
                                 1007                      Information Testing server MAIL01.Saa...
                                 1019                      Information Found a valid AutoDiscover se...
                                 1006                      Information The Autodiscover service was ...
                                 1016                          Success [EXCH]-Successfully contacted...
                                 1015                          Success [EXCH]-Successfully contacted...
                                 1014                          Success [EXCH]-Successfully contacted...
                                 1016                      Information [EXPR]-The AS is not configur...
                                 1015                          Success [EXPR]-Successfully contacted...
                                 1014                      Information [EXPR]-The UM is not configur...
                                 1017                          Success [EXPR]-Successfully contacted...
                                 1006                          Success The Autodiscover service was ...

    martes, 28 de julio de 2009 22:04
  • OK now since you have a SAN or UCC Certificate so please check the output of https://www.testexchangeconnectivity.com/ and click on the option for "Outlook Anywhere with Auto Discover". Let me know where it failed?

    Try to browse https://<OWA URL>/autodiscover/autodiscover.xml and check if you get a XML page with "600" error in it
    Harpreet Singh Khandiyal (http://support.microsoft.com/kb/555375)
    martes, 28 de julio de 2009 22:37
  • Hi,

     

    From your Test-OutlookWebServices result, I got following info:

     

    1016                      Information [EXPR]-The AS is not configur...

     

    Looks like the external Availability service URL is not configured. I suggest you run get-webservicesvirtualdirectory to check whether the external URL is configured. If not, you need to use Set-WebServicesVirtualDirectory command with externalURL parameter to set the external URL.

     

    For your reference:

     

    Get-WebServicesVirtualDirectory

    http://technet.microsoft.com/en-us/library/aa998810.aspx

     

    Set-WebServicesVirtualDirectory

    http://technet.microsoft.com/en-us/library/aa997233.aspx

     

    In addition, you need to configure DNS in order to have the client able to resolve external URL to correct IP address. Then, please attempt to set OOF on Outlook Anywhere client again.

     

    If the issue persists, would you please run test-outlookwebservices -clientaccessserver "mail01" |fl to get detailed information?

     

    Mike

     

     

    • Marcado como respuesta slj333 miércoles, 29 de julio de 2009 15:54
    miércoles, 29 de julio de 2009 14:24
  • Hello Mike and Harpreet,
    I made the following change >Set-OutlookProvider EXPR -CertPrincipalName:"msstd:mail.mycompany.com"

    and now we pass the www.testexchangeconnectivity.com site.

    The other test also passes
    em32>test-outlookwebservices -clientaccessserver "mail01"

                                                Id                                                               Type Message
                                                --                                                               ---- -------
                                              1003                                                        Information About to test AutoDiscover with the e-mail address dseffren@de...
                                              1007                                                        Information Testing server MAIL01.mycompany.COM with the published name h...
                                              1019                                                        Information Found a valid AutoDiscover service connection point. The AutoD...
                                              1006                                                        Information The Autodiscover service was contacted at https://MAIL01.SE...
                                              1016                                                            Success [EXCH]-Successfully contacted the AS service at https://mai...
                                              1015                                                            Success [EXCH]-Successfully contacted the OAB service at https://ma...
                                              1014                                                            Success [EXCH]-Successfully contacted the UM service at https://mai...
                                              1016                                                        Information [EXPR]-The AS is not configured for this user.
                                              1015                                                            Success [EXPR]-Successfully contacted the OAB service at . The elapsed...
                                              1014                                                        Information [EXPR]-The UM is not configured for this user.
                                              1017                                                            Success [EXPR]-Successfully contacted the RPC/HTTP service at https://...
                                              1006                                                            Success The Autodiscover service was tested successfully.

    I created a new mail profile on a remote machine (not on trusted or vpn network). Outlook anwhere is happy (using msstd:mail.mycompany.com for proxy), but OUt of Office still doesn't work.

    Thank you,
    SJ

    • Marcado como respuesta slj333 miércoles, 29 de julio de 2009 15:54
    miércoles, 29 de julio de 2009 15:14
  • Hi Mike and Hapreet,
    It's working!! Thank you both. We made two changes that corrected the situation:
    1) set-WebServicesVirtualDirectory -identity MAIL01\EWS (Default Web Site) -externalurl https://mail.mycompany.com/ews/exchange.asmx

    2) Set-OutlookProvider EXPR -CertPrincipalName:"msstd:mail.mycompany.com"

    Out of office now works via outlook anwhere and Free Busy is also working!

    Again, many thanks!

    SJ
    miércoles, 29 de julio de 2009 15:54