none
Mailbox showing in Outlook 2010

    Pertanyaan

  • Hi,

    I performed the following command on my Exchange 2010 server.

    Get-MailboxDatabase -identity “[mailbox database name]” | Add-ADPermission -user [username] -AccessRights GenericAll

    It granted my account full mailbox access on all mailboxes on a specific datastore. I need to remove this permission. I launched Exchange Management Console and removed my account from one user with the Manage Full Access Permission action. Then the users account showed up on my Outlook and I can't remove from Outlook. I have tired to remove it from Mail, Account within Outlook, and I did not see it anywhere? I would like to keep full access on my account. I just need to remove it from all others on the datastore.

    Does anyone know a EMC cmd or how to remove it from Outlook?


    Wave~Chaser

    25 April 2012 16:59

Jawaban

  • Below is what I ran in the very begening.

    Get-MailboxDatabase -identity "low quota database" | Add-ADPermission -user noc -AccessRights GenericAll

    After I ran it I looked at EMC Manage full access permission setting and I am listed in there on all low quota database users.


    Wave~Chaser


    Thats why you should run the command I posted above...to remove (remove-adpermission) the permisssion you now have.

    Repeat:
    Get-MailboxDatabase “low quota database"|Remove-ADPermission -user NOC -AccessRights GenericAll

    Martina Miskovic

    • Ditandai sebagai Jawaban oleh WaveChaser 30 April 2012 16:46
    26 April 2012 19:15

Semua Balasan

  • Thanks I did that and got the below....


    Wave~Chaser


    and I'm still showing up in the manage mailbox full permisions.
    25 April 2012 18:14
  • You may have to wait for cache to refresh or you can restart the IS service (outage).

    Sukh

    25 April 2012 18:58
  •  

    I ran it on one mailbox that I have removed my account from the EMC Manage full access permission setting yesturday. It did remove it from my Outlook. Thanks!

    I still have 200 or so mailboxes that have my account in the EMC Manage full access permission setting for the users. I ran the command on one user and got the same warning message seen in the image above. When I look at the users EMC Manage full access permission setting it still had me in there? Any suggestions?


    Wave~Chaser

    26 April 2012 16:16
  • Did you just do that now?

    Can you restart the IS (outage).


    Sukh

    26 April 2012 16:20
  • I ran it about 10 minutes ago. in the EMC Manage full access permission setting it still had me in there. I can't restart the IS now I'm in productions hours. Do I need to wait for replication? Will it remove me then?

    Wave~Chaser

    26 April 2012 16:42
  • it should, can take up 2 2 hrs + AD replication.

    Sukh

    26 April 2012 16:48
  • Ok I will wait and see.... Above piture is my name "noc" still in full perm's


    Wave~Chaser

    26 April 2012 17:24
  • Thanks I did that and got the below....


    Wave~Chaser


    and I'm still showing up in the manage mailbox full permisions.

    Hi,
    You forgot to post the most imporant part here....What command did you run?

    Check the permissions you have on the database with: Get-MailboxDatabase Database | Get-ADPermission -User NOC

    Martina Miskovic

    26 April 2012 18:36
  • I ran  Remove-MailboxPermission -Identity "btegt" -User noc -AccessRights Fullaccess -InheritanceType all

    I ran this command Get-MailboxDatabase low quota database -User NOC  and it failed stating a positional parameter cannot be found that accepts argument 'quota'


    Wave~Chaser

    26 April 2012 19:00
  • Try again:
    Get-MailboxDatabase "low quota database" | get-adpermission -User NOC 

    To remove the permission you gave your self, I think this will work
    Get-MailboxDatabase “low quota database"| Remove-ADPermission -user NOC -AccessRights GenericAll



    Martina Miskovic

    26 April 2012 19:05
  • Above is the result thx

    Below is what I ran in the very begening.

    Get-MailboxDatabase -identity "low quota database" | Add-ADPermission -user noc -AccessRights GenericAll

    After I ran it I looked at EMC Manage full access permission setting and I am listed in there on all low quota database users.


    Wave~Chaser

    26 April 2012 19:11
  • Below is what I ran in the very begening.

    Get-MailboxDatabase -identity "low quota database" | Add-ADPermission -user noc -AccessRights GenericAll

    After I ran it I looked at EMC Manage full access permission setting and I am listed in there on all low quota database users.


    Wave~Chaser


    Thats why you should run the command I posted above...to remove (remove-adpermission) the permisssion you now have.

    Repeat:
    Get-MailboxDatabase “low quota database"|Remove-ADPermission -user NOC -AccessRights GenericAll

    Martina Miskovic

    • Ditandai sebagai Jawaban oleh WaveChaser 30 April 2012 16:46
    26 April 2012 19:15
  • ok I will try thx

    Wave~Chaser

    26 April 2012 19:24