none
New installation of exchange 2010 - Error when creating mailbox databases

    질문

  • I have tried setting the preferred DC from the management shell but that has not helped me. When I originally installed exchange it said it failed to install the mailbox server role because identity was/is null. There was obviously more to the error but that is what stuck out. The server allowed me to start all of the services but not everything is working as it should be. 

    Little background information:

    Single Domain

    Exchange 2010 SP1 being hosted in a windows 2008 R2 server. 

    DC's are Windows Server 2003 SP2. 

    I am attempting to migrate our Exchange 2003 Users to the 2010 server. 

    Error:

    2012년 3월 14일 수요일 오전 1:37

답변

  • For whatever reason, the new exchange server could not reach the DC that was acting as the Schema Master. I assigned the Schema Master role to the DC that exchange could communicate with and reinstalled exchange 2010 which fixed my issue. 
    2012년 3월 14일 수요일 오전 7:38

모든 응답

  • Hi,

    This might be issue of mismatching between configured Domain Controller and GlobalCatalog as you are having DCs in old and new domains. 

    If you set the preferred server as per this cmdlet, the issue can be resolved.

    Set-ADServerSettings –PreferredServer <FQDN of Domain Controller>


    Regards from www.windowsadmin.info | www.blog.windowsadmin.info

    2012년 3월 14일 수요일 오전 2:22
  • Thanks for the response. I mentioned in my original post that I already tried setting the PreferredServer and it did not solve the problem. 

    Also, There is only a single domain. 

    2012년 3월 14일 수요일 오전 2:41
  • Dear Fellow,

    Also verify if your DNS is working properly. Try to perform following actions:

    1. NSLOOKUP "Exchange" and "Exchange.domain.com" and "domain.com" from different systems (including Exchange Server itself)

    2. Try to put a hosts file entry for "Exchange" and "Exchange.domain.com"

    3. Check replication errors on your DCs (i.e. repadmin /replsum)

    Hope it helps proceeding towards resolution

    Thanks.


    Junaid Ahmed

    2012년 3월 14일 수요일 오전 6:06
  • For whatever reason, the new exchange server could not reach the DC that was acting as the Schema Master. I assigned the Schema Master role to the DC that exchange could communicate with and reinstalled exchange 2010 which fixed my issue. 
    2012년 3월 14일 수요일 오전 7:38
  • Dear Fellow,

    If this is the case you should really check the health of your Domain infrastructure and ensure it remains in good health. This might cause more problems in future if not taken care properly. Exchange Server is tightly coupled with Active Directory infrastructure and can not work without it.

    In general I would like to suggest you to keep checking for following things on your Domain infrastructure:

    1. Replication status among all the DCs

    2. FSMO Role assignment

    3. Metadata Cleanup (if you have discarded/removed/deleted any of the DC)

    4. Verify health of DNS infrastructure

    5. Network connectivity

    Thanks.


    Junaid Ahmed

    2012년 3월 14일 수요일 오전 9:03