none
Delegate is not added to mailbox or calendar

    Pergunta

  • Recently migrated users from Exchange 2003 to Exchange 2010 and have a delegate issue with one manager. Accessing the managers mailbox a user is added as a Calendar delegate at the Editor level and should receive copies of meeting related messages. Save the change in Outlook 2010. The delegate receives the Calendar requests when mailed to the manager and is able to access the Calendar, and able to adding or modifying items. When the user receives the Calendar request there will be a note at the top indicating "This meeting is not in the Calendar; it may have been moved or deleted."

    Checking the Calender permissions for the manager in EMS the user is shown with the correct permissions but when running  Get-CalendarProcessing "manager" the ResourceDelegate entry is blank. In a test, the user is added as Delegate to my Calendar, Get-CalendarProcessing shows the user as a ResourceDelegate on my calendar after about a minute.

    What might be causing the user not to be added as a delegate correctly?

    Thank you for any help.

    quarta-feira, 13 de junho de 2012 20:34

Todas as Respostas

  • Hello AllenW73,

    Please check whether the meeting has been added to manager's calendar or not?

    If meeting has been added to manager's calendar, go to check whether your manager has checked "Automatically accept meeting requests and remove canceled meetings"

    File->Options->Calendar->Resource scheduling->Resource Scheduling

    If he has checked that option, uncheck to have a try.

    If meeting was not added on manager's calendar, please go to your manager's mailbox to check for the meeting request.

    Thanks,

    Evan


    Evan Liu

    TechNet Community Support

    sexta-feira, 15 de junho de 2012 07:03
    Moderador
  • I checked the manager settings in Outlook and the "Automatically accept..." was NOT checked. The meeting request shows on the manager's Calendar as accepted. 

    Is there a way to confirm the Delegate permissions are applied for the manager's mailbox?

    Thank you

    sexta-feira, 15 de junho de 2012 17:02
  • If you want to check delegate permission on manager's calendar, you can use this command:

    Get-mailboxfolderpermission -identity manager:\Calendar

    Thanks,

    Evan


    Evan Liu

    TechNet Community Support

    quarta-feira, 20 de junho de 2012 10:05
    Moderador
  • The user does not have any issues accessing the managers calendar in Outlook and the permissions shows the user as an Editor. When meeting requests are received in the users Inbox they are not able to accept for the manager or show as already moved. If Get-CaelndarProcessing manager | fl is run the command returns no value for ResourceDelegate, any other user mailbox setup with a delegate returns the delegate's name in the ResourceDelegate field. The user has been removed and added back as a delegate and still not showing or working.

    When the user attempts to accept the meeting request for the manager they receive a message "Cannont open Calendar folder for user Manager. You do not have sufficient permission to perfom this operation on this object". The user can open the mangers Calendar and add items directly to the Calendar but is receive the message when when accepting for the manager.

    Thank You


    • Editado AllenW73 quinta-feira, 21 de junho de 2012 00:01
    quarta-feira, 20 de junho de 2012 20:34
  • Hi,

    If you want to check the delegate settings, you can check in manager's Outlook profile.

    You also can check whether there is a delegate set on the manager by using ADSI edit, use this to check the publicdelegate attribute on the manager.

    Thanks,

    Evan


    Evan Liu

    TechNet Community Support

    sexta-feira, 22 de junho de 2012 02:06
    Moderador
  • Checked the publicdelegate for the manager and the setting was blank. I have added the user to the setting and double checked the delegate configuration on the manager. Ran a test via Outlook and got the same error, "Cannot open Calendar folder for user Manager. You do not have sufficient permission to perfom this operation on this object". I had the user try from OWA and they were able to accept the meeting request and the item was added to the managers calendar showing the user accepted.

    Opened Outlook and ran another test and still did not work, create a second profile for the user in Outlook and that profile worked for a few hours and then the error appeared again with the new profile.

    sexta-feira, 22 de junho de 2012 19:29
  • Did you set the delegate in Outlook to have a try?

    Or you can follow this way to have a try:

    Add the delegate in AD, then go to manager'calendar, and give delegate permission to check on manager's calendar.

    Thanks,

    Evan


    Evan Liu

    TechNet Community Support

    quinta-feira, 28 de junho de 2012 10:50
    Moderador