none
Error when trying to run set-irmconfiguration command

    Pergunta

  • I'm trying to run the command set-irmconfiguration InternalLicensingEnable $True so that I can browse and select a RMS template when configuring a hub transport rule.

    Everytime I try and run the command I get the following error:

    Cannot process argument transformation on parameter 'ClientAccessServerEnabled'. Cannot convert value "System.String" t
    o type "System.Boolean", parameters of this type only accept booleans or numbers, use $true, $false, 1 or 0 instead.
        + CategoryInfo          : InvalidData: (:) [Set-IRMConfiguration], ParameterBindin...mationException
        + FullyQualifiedErrorId : ParameterArgumentTransformationError,Set-IRMConfiguration

    This is the output of get-irmconfiguration:

    InternalLicensingEnabled       : False
    ExternalLicensingEnabled       : False
    JournalReportDecryptionEnabled : True
    ClientAccessServerEnabled      : True
    SearchEnabled                  : True
    TransportDecryptionSetting     : Optional
    EDiscoverySuperUserEnabled     : True
    ServiceLocation                :
    PublishingLocation             :
    LicensingLocation              : {}

    Can anybody tell me where I am going wrong?

    Cheers

    Adam.

    quinta-feira, 1 de dezembro de 2011 14:49

Respostas

  • Hi adamf83,

     

    Sorry that I miss “-“ in my last post:

     

    Please use this to have a try:

     

    Set-IRMConfiguration -InternalLicensingEnable $True –ClientAccessServerEnabled $True

     

    Thanks,

     

    Evan Liu

     

    TechNet Subscriber Support in forum

    If you have any feedback on our support, please contact tngfb@microsoft.com  


    Evan Liu

    TechNet Community Support

    • Marcado como Resposta adamf83 quarta-feira, 7 de dezembro de 2011 14:42
    terça-feira, 6 de dezembro de 2011 02:31
    Moderador

Todas as Respostas

  • Hi Adam,

     

    Please check you had added the AD RMS service account to the Domain Administrators group.

     

    Run the command with Parameter ‘ClientAccessServerEnabled’ to have a try:

     

    set-irmconfiguration InternalLicensingEnable $True –ClientAccessServerEnabled $True

     

    Set-IRMConfiguration

    http://technet.microsoft.com/en-us/library/dd979792.aspx

     

    Thanks,

     

    Evan Liu

     

    TechNet Subscriber Support in forum

    If you have any feedback on our support, please contact tngfb@microsoft.com  

    sexta-feira, 2 de dezembro de 2011 08:02
    Moderador
  • Evan,

    I've tried the command you suggested and got a different error:

    An Active Directory error 0x51 occurred when trying to check the suitability of server 'InternalLicensingEnable'. Error
    : 'Active directory response: The LDAP server is unavailable.'
        + CategoryInfo          : NotSpecified: (:) [Set-IRMConfiguration], SuitabilityDirectoryException
        + FullyQualifiedErrorId : 7480D574,Microsoft.Exchange.Management.RightsManagement.SetIRMConfiguration

     

    Any ideas?

    sábado, 3 de dezembro de 2011 10:58
  • Hi adamf83,

     

    Sorry that I miss “-“ in my last post:

     

    Please use this to have a try:

     

    Set-IRMConfiguration -InternalLicensingEnable $True –ClientAccessServerEnabled $True

     

    Thanks,

     

    Evan Liu

     

    TechNet Subscriber Support in forum

    If you have any feedback on our support, please contact tngfb@microsoft.com  


    Evan Liu

    TechNet Community Support

    • Marcado como Resposta adamf83 quarta-feira, 7 de dezembro de 2011 14:42
    terça-feira, 6 de dezembro de 2011 02:31
    Moderador