none
simplify URL in Exchange 2007 sp1 on server 2008

Răspunsuri

  •  

    Hi,

     

    By default, IIS7 has built-in automatic HTTP Redirect feature which allows us to redirect to any URL without us having to write any custom scripts.

     

    To accomplish the task, you can follow these steps on the CAS server role hosting OWA:

     

    Step 1:

    1,Log on Interne Information Services (IIS) Manager

    2, Switch back to Features view of the "Default Web Site" and double click on "Error Pages".

    3, In the Actions pane, click on "Edit Feature Settings" and under "Error Responses", select: "Custom Error Pages". Then click OK

    4, In the Actions pane, click on "Add" and configure the following

    a) Status code: 403.4

    b) Click on Respond with a 302 redirect and provide the absolute URL: https://owa.mycompany.com/owa

     

    Note: Make sure you are using "https"

     

    Step 2:

    1,Open IIS 7 Manager

    2,Highlight the Default Website and ensure we are in the Features View

    3, Double click on HTTP Redirect icon

    4, Check the option "Redirect requests to this destination:" and type the absolute OWA URL: https://owa.mycompany.com/owa

    5, Under Redirect Behavior section, select the option "Only redirect requests to content in this directory (not subdirectories)"

    6, From the drop down, select the Status code: Found (302)

    7, Click Apply to save the settings

    8, Run IISRESET /noforce command in CMD for the settings to take effect.

     

    After that, please test this issue.

     

    Thanks

     

    Allen

    26 august 2008 05:18

Toate mesajele

  •  

    GetSamir,

     

    Please take a look at this post http://forums.microsoft.com/TechNet/ShowPost.aspx?PostID=3440639&SiteID=17

     

    Thanks

    ~Brian

    25 august 2008 15:15
  •  

    Hi,

     

    By default, IIS7 has built-in automatic HTTP Redirect feature which allows us to redirect to any URL without us having to write any custom scripts.

     

    To accomplish the task, you can follow these steps on the CAS server role hosting OWA:

     

    Step 1:

    1,Log on Interne Information Services (IIS) Manager

    2, Switch back to Features view of the "Default Web Site" and double click on "Error Pages".

    3, In the Actions pane, click on "Edit Feature Settings" and under "Error Responses", select: "Custom Error Pages". Then click OK

    4, In the Actions pane, click on "Add" and configure the following

    a) Status code: 403.4

    b) Click on Respond with a 302 redirect and provide the absolute URL: https://owa.mycompany.com/owa

     

    Note: Make sure you are using "https"

     

    Step 2:

    1,Open IIS 7 Manager

    2,Highlight the Default Website and ensure we are in the Features View

    3, Double click on HTTP Redirect icon

    4, Check the option "Redirect requests to this destination:" and type the absolute OWA URL: https://owa.mycompany.com/owa

    5, Under Redirect Behavior section, select the option "Only redirect requests to content in this directory (not subdirectories)"

    6, From the drop down, select the Status code: Found (302)

    7, Click Apply to save the settings

    8, Run IISRESET /noforce command in CMD for the settings to take effect.

     

    After that, please test this issue.

     

    Thanks

     

    Allen

    26 august 2008 05:18
  • Hi Allen - So far this is the clearest direction yet on this issue (2008 Server and Exchange 2007 OWA redirect).  One problem.. After following your steps, when I go to the http version of webmail.domain.com, the redirect works great and brings up the owa login screen.. the problem is when we then "Log On" it adds an extra /owa to the URL causing a 404 not found message..  ie:  URL after hitting "Log on" is https://webmail.domain.com/owa/owa

     

    Any ideas?  Your help is greatly appreciated!

     

    Thanks!

    Rob

     

    6 septembrie 2008 21:17
  •  

    Hi - An excellent answer thank you - however - I don't seem to have an HTTP Redirect icon!

     

    I have http response headers but nothing else similar

     

    any ideas

     

    thanks

     

    ed

     

    19 septembrie 2008 15:27
  • IIS7 is a modular design. In other words many features must be installed in order to show up as an icon.

     

    Regards-

     

    Kary

     

    25 septembrie 2008 19:19
  •  rperissi wrote:

    Hi Allen - So far this is the clearest direction yet on this issue (2008 Server and Exchange 2007 OWA redirect).  One problem.. After following your steps, when I go to the http version of webmail.domain.com, the redirect works great and brings up the owa login screen.. the problem is when we then "Log On" it adds an extra /owa to the URL causing a 404 not found message..  ie:  URL after hitting "Log on" is https://webmail.domain.com/owa/owa

     

    Any ideas?  Your help is greatly appreciated!

     

    Thanks!

    Rob

     

     

    Rob, removing the Require SSL option for the Default Web Site should resolve your issue.  I was having your same issue.

    12 octombrie 2008 18:14
  • Thanks Allen Song for your informative post now i can easily redirect my site from http to https

    Cheers


    feroz syed ;)

    6 iunie 2012 14:32