none
Exchange 2010 and 2007 Coexistence

    问题

  • Here is picture of our current setup.

    Site A: Exchange 2007 SP3 (Located at Site A) Single Cas/Hub and a Cluster MB Server for total of 3 boxes.

    External URL: webmail.abc.com points to Exchange 2007

    MX Records: incoming.abc.com / mail.abc.com point to webmail.abc.com

    Autodiscover URL: autodiscover.abc.com points to Exchange 2007

    Internal URL: local.abc.com

    Split DNS for External URL: All same settings as external records except doing internal IP

    Site B: Exchange 2010 SP2 (Located at Site B) Two Hub/CAS/MB/EDGE Server for total of six boxes.

    Cas Array Setup on Netscaler LB

    DAG Setup

    OWA/EDGE/Active Sync and other services are load balance on Netscaler.

    AD is single domain but multiple sites with Exchange 2007 Site A and Exchange 2010 Site B

    Presently I am trying to get the following to work.

    I like to bring the external url : webmail.abc.com to exchange 2010 side and have redirection work to exchange 2007 with the legacy.abc.com.

    We will have users mailboxes on Exchange 2007 but like to use the Excahnge 2010 CAS / HUB for all users to connect to webmail.abc.com and get redirected to Exchange 2007 for services like OWA / Active Sync.

    The problem is I have tested it and for some reason it will not redirect. I get a message on OWA about URL for users in 2007 to go too and then they can log in.

    I have read about Cross Site Redirection and was wondering do I need to set this up for silent and what do I have to do on the 2007 side for the External URL and authentication. I have read the technet and I have follow it a 100% but still does not work. I like for them to just be able to sign into OWA on 2010 side get redirected without entering username and password again.

    Both sites are internet facing btw.

    2012年5月31日 11:57

全部回复

    • legacy.domain.com needs to point to the Exchange 2007 CAS.
    • the Exchange 2007 CAS needs to have FBA enabled (it is by default)
    • webmail.domain.com needs to point to Exchange 2010 CAS (you can test this with a hosts file)
    • ExternalURL(s) need to be set on the exchange 2007 virtual directories.
    • autodiscover needs to be configured properly in general

    What is the URL you are getting prompted to go to?

    This article is the one-stop shop for this topic: http://technet.microsoft.com/en-us/library/bb310763.aspx



    Mike Crowley | MVP
    My Blog -- Planet Technologies

    2012年6月1日 2:54
  • Mike,

     Thanks for the response. Well it was doing the manual redirection and pointing the legacy and it would let me in. I am just trying to make this simple as possible as we can not have much down time. Let me explain a little more.

    Exchange 2010 - Is located in DataCenter in NJ Internet facing site with no DNS records associated with it yet. The servers are built and ready to go. All HA. We want to move everything to this side soon but would like to have no issues with the users and all the Services like OWA, AutoDiscover, AS, Outlook ANywhere and so on.

    Exchange 2007 - Is located in Office in NJ. This is a internet facing site as well. This is the main site where everyone is connection to at the moment. It has a external url associated with it webmail.abc.com. We are trying to move all the services off this box to Datacenter in NJ but want barely any down time and want people to be able to access mailboxes in this site from Exchange 2010 site. We like to set the internet facing site to legacy.abc.com and exchange 2010 to webmail.abc.com.

    AD is a Single domain of local.abc.com and has two sites in the AD Sites and Services each with different subnets.

    DataCenter - Exchange 2010 - Site A External Future URL (Webmail.abc.com)

    Main Office - Exchange 2007 - Site B External Futrue URL (legacy.abc.com)

    We just want to redirect users silenty with SSO. I was just wondering am I going to use Cross-Site Silent Redirection and set the URL on 2007 and 2010 external and same authentication of forms base on OWA.

    2012年6月1日 3:07
  • We just want to redirect users silenty with SSO. I was just wondering am I going to use Cross-Site Silent Redirection and set the URL on 2007 and 2010 external and same authentication of forms base on OWA.

    Hi,
    Why not let Exchange 2010 proxy the OWA Requests?

    For that to work, you need to:

    1. Enable Windows Authentication on the OWAVirtualdirectory in EX07
    2. Remove the ExternalUrl from EX07
    3. Copy the highest-versioned OWA Folder from EX07>EX10

    If you decide to go that way, it's important that your servers is up to date with RUs
    See: http://blogs.technet.com/b/exchange/archive/2012/02/17/exchange-2010-sp2-ru1-and-cas-to-cas-proxy-incompatibility.aspx


    Martina Miskovic

    2012年6月1日 3:22