none
Forefront Protection 2010 for Exchange Server Performance Counters Not Working

    Question

  • We are using Forefront Protection 2010 for Exchange Server on our Exchange 2007 SP3 Server running on Server 2003 SP2.  We would like to use performance counters such as \Forefront Exchange Transport Scanner(_CumulativeTotal)\File Filter Messages Detected and \Forefront Exchange Transport Scanner(_CumulativeTotal)\Malware Messages Detected to monitor this.  These counters do have values, but they do not increment when new incidents occur.  This is observable in Performance and in statistics within the Administrator Console for the product.  I have confirmed that the incidents are detected as part of the Transport scan.  They show up as incidents in the console, trigger e-mail alerts and cause items to be quarantined.  I am wondering if anyone has any ideas as to why these would stop working and how I might fix the issue.  In case anyone is wondering, my precise version of Forefront Protection 2010 for Exchange Server is 11.0.727.0

    James


    • Edited by jte369 Thursday, February 21, 2013 2:19 PM
    Thursday, February 21, 2013 2:18 PM

All replies

  • Hi,

    Thank you for the post.

    “These counters do have values, but they do not increment when new incidents occur” – what do you want to accomplish? You can monitor FPE by viewing statistics and health monitoring reports or using performance monitor: http://technet.microsoft.com/en-us/library/cc507105.aspx

    Regards,


    Nick Gu - MSFT

    Monday, February 25, 2013 9:32 AM
  • That is precisely what I would like to do, however, the performance counters for the product do not count.  That is what I am looking for help with.  Presumably they worked at some point, since they have values, but they value does not go up as new events occur.

    James

    Monday, February 25, 2013 11:23 AM
  • Hi,

    Thank you for the update.

    Please check if you have selected Enable performance counters check box.

    Regards,


    Nick Gu - MSFT

    Wednesday, February 27, 2013 7:06 AM
  • The Enable performance counters check box, under Advanced Options, is, and always was, checked.  I thought you had me there for a minute ;)

    James

    Wednesday, February 27, 2013 8:25 PM