none
Close connection when UPdate Eset remote administrator

    Question

  • Hi all, I have TMG forefront and ESET Remote administrator Antivirus  installed in other server, allow all traffic to this server and type of client is secureNAT,  when ESET Remote administrator source update appear message in TMG monitor ( 0x80074e24+fwx_e_connection_killed) close connection.


    till now cannot update the anti virus source


    Mohamed Abdelsalam
    • Edited by Mohamed2121 Thursday, January 05, 2012 2:12 PM
    Thursday, January 05, 2012 2:06 PM

All replies

  • Hi,

    you have to create new protocol definitions on your TMG Server to allow access to Eset Remote Administrator:
    http://kb.eset.com/esetkb/index?page=content&id=SOLN2221


    regards Marc Grote aka Jens Baier - www.it-training-grote.de - www.forefront-tmg.de - www.nt-faq.de
    Thursday, January 05, 2012 5:13 PM
  • Hi,

     

    Thank you for the post.

     

    According to this error message, ISA Server closed an established connection before either peer requested to close it. This typically occurs when an application filter detects a protocol violation, such as a malformed HTTP request. You can call ESET to see if this system has been tested through ISA?

     

    Regards,


    Nick Gu - MSFT
    Friday, January 06, 2012 2:28 AM
    Moderator
  • Thank you Marc.Grote, I did this and did not work
    Mohamed Abdelsalam
    • Edited by Mohamed2121 Sunday, January 08, 2012 1:24 PM
    Sunday, January 08, 2012 1:24 PM
  • thank u Nick

    Really, I've contacted ESET support and they told me, after check problem, the problem of the TMG firewall  connect to microsoft to solve it


    Mohamed Abdelsalam
    Sunday, January 08, 2012 1:28 PM
  • Hi,

    Thank you for the update.

    How do you create the access rule and what is live logging tell?

    Regards,
    Wednesday, January 11, 2012 2:55 PM
    Moderator
  • I create roll from internal to external and allow to all traffic ports , I use Logging Tasks to monitor from TMG console. 
    Mohamed Abdelsalam
    Monday, January 16, 2012 10:33 AM
  • We got this running with a default rule that allows HTTP(S) traffic from internal to external with User authentication set. Make sure you have an account in Active Directory with a password. Open the Eset ERAC and goto TOOLS-SERVER OPTIONS-UPDATES TAB. Enter your username and password you got from ESET. Now goto to ADVANCED TAB- EDIT ADVANCED SETTINGS. Open up ERA-ERA SERVER-SETUP-PROXY SERVER.

    Proxyserver : user defined proxy server

    Proxyserver : <proxyservername without domain name> like : tmgserver

    Port : 8080

    Username : <AD accountname>

    Password : <AD Password>

     

    Now it should work just fine

    regards

    richard

     

    • Proposed as answer by Richard Kok Tuesday, January 17, 2012 2:58 PM
    Tuesday, January 17, 2012 8:24 AM
  • I tray that, still same problem ( 0x80074e24+fwx_e_connection_killed) close connection.
    Mohamed Abdelsalam
    Wednesday, January 18, 2012 7:58 AM
  • I tray that, still same problem

    Mohamed Abdelsalam

    Thursday, February 09, 2012 8:08 AM