none
Error opening Office Documents thru UAG using Firefox

    Question

  • Hello,

    We are running UAG SP3 U1 with SharePoint 2010 behind it and experiencing issues with Office documents when using Firefox.  Everything works as expected using IE 8-10.

    All default Policies are being used.  No customization to the policies has been made.

    Trunk:

    Default Session Access, Default Privleged Endpoint, Always

    Application:

    Default Web Application Access, MS SharePoint Server 2010 Upload, MS SharePoint Server 2010 Download, Default Web Application Restricted

    I have tested doc, docx, xls and xlsx with similar results.

    Firefox is the current release (22) with the current Java release (7 u 25).

    I can successfully log into UAG and browse the SharePoint portal.

    When I attempt to open an Office document, I am prompted with a Windows Credentials dialog and enter my credentials.  At that point the application, Word or Excel opens and instead of the expected document, I see the UAG error message embedded.

    The error message is "You have attempted to access a restricted URL. The URL contains an invalid parameter."

    UAG logs several errors during the attempt:

    Error 65
    - A request from source IP address 10.1.1.1, user to trunk SharePoint; Secure=1 for application SharePoint of type SharePoint14AAM failed. The endpoint device does not comply with access policy settings (Hybrid_Default_Session_Access) for session 56351A8C-AE3E-4C8F-9EFC-52C0CA5D8F44. The URL is /it/IT%20Test%20Deck/IT%20Deck.xlsx.
    
    Error 51
    - A request from source IP address 10.1.1.1, user on trunk SharePoint; Secure=1 for application Internal Site of type InternalSite failed because the method used HEAD is not valid for requested URL /InternalSite/InitParams.aspx?referrer=/InternalSite/InternalError.asp&site%5Fname=SharePoint&secure=1&error%5Fcode=25&policy%5Fid=Hybrid%5FDefault%5FSession%5FAccess&ErrorType=HTMLErrorPage.
    
    Error 65
    - A request from source IP address 10.1.1.1, user to trunk SharePoint; Secure=1 for application SharePoint of type SharePoint14AAM failed. The endpoint device does not comply with access policy settings (Hybrid_Default_Session_Access) for session 56351A8C-AE3E-4C8F-9EFC-52C0CA5D8F44. The URL is /it/IT%20Test%20Deck/IT%20Deck.xlsx.
    
    Error 51
    - A request from source IP address 10.1.1.1, user on trunk SharePoint; Secure=1 for application Internal Site of type InternalSite failed because the method used PROPFIND is not valid for requested URL /InternalSite/InitParams.aspx?referrer=/InternalSite/InternalError.asp&site%5Fname=SharePoint&secure=1&error%5Fcode=25&policy%5Fid=Hybrid%5FDefault%5FSession%5FAccess&ErrorType=HTMLErrorPage.
    
    Error 65
    - A request from source IP address 10.1.1.1, user to trunk SharePoint; Secure=1 for application SharePoint of type SharePoint14AAM failed. The endpoint device does not comply with access policy settings (Hybrid_Default_Session_Access) for session 56351A8C-AE3E-4C8F-9EFC-52C0CA5D8F44. The URL is /it/IT%20Test%20Deck/IT%20Deck.xlsx.
    
    Error 45
    - A request for application Internal Site of type InternalSite on trunkSharePoint; Secure=1 failed. The URL /InternalSite/InitParams.aspx?referrer=/InternalSite/InternalError.asp&site%5Fname=SharePoint&secure=1&error%5Fcode=25&policy%5Fid=Hybrid%5FDefault%5FSession%5FAccess&ErrorType=HTMLErrorPage was rejected by the URL inspection rule InternalSite_Rule54. The reason for the failure: Parameter value failed 'Value' check. The method is GET. The source IP address is 10.1.1.1. The user is .
    
    

    Error 45 does not list a User Name -- making me think that Firefox is not passing credentials.

    Things I have tried:

    • Use "Always" Access Policy on the Application - Documents still fail to open
    • Create new Access Policy with no restrictions - Documents still fail to open
    • On the Application Properties - Web Settings Tab - check "Evaluate without enforcement" -- Documents will open

    Any ideas are appreciated.
    Thanks!



    Tuesday, July 30, 2013 3:18 PM

All replies