none
You have attempted to access a restricted URL.

    Question

  • Hello.

    I want to publishing a web application, but always get this error.

    You have attempted to access a restricted URL. (The URL contains an invalid path)

    I need some help

    Tuesday, April 13, 2010 4:39 PM

Answers

All replies

  • This should help:

    http://blogs.technet.com/ben/archive/2010/03/15/troubleshooting-ruleset-issues.aspx

    Cheers

    JJ


    Jason Jones | Forefront MVP | Silversands Ltd
    Tuesday, April 13, 2010 4:58 PM
  • Kuku,

    Please use recreate the error and without logging off...

    Go into the UAG Web Monitor  click on active session, events  and find where UAG logged the error.    You might be able to fix the error just by reading what the log tell you

    You can paste the details into this thread if you need.  

    I think one of two things went wrong,  under  application properties >> web servers >> "paths"  you might have put an invalid entry, I suggest leaving it the default for now -- "/".  Or your portal link is invalid.

    Let us know

    Thanks

    Dennis
    Celestix Networks

    Tuesday, April 13, 2010 5:03 PM
  • Thank Jason, but I try that without luck.

    Im using this path..

    The URL /gac/faces/login/Login.jsp/ contains an illegal path. The rule applied is Default rule. The method is GET.

    Tuesday, April 13, 2010 5:27 PM
  • My path is The URL /gac/faces/login/Login.jsp/ contains an illegal path. The rule applied is Default rule. The method is GET.
    Tuesday, April 13, 2010 5:28 PM
  • Please post the following into the thread.

    Under application properties:

    Web Server >> Paths

    What do you have here?  just "/" or did you add fields like /gac/

    Note:  The paths should only be directories you are publishing on the server.  for example...  http://servername/files  ... as long as everything on my website references the /files directory, then I am fine.

    Portal Link >> Application URL

    What do you have here? 

    ...

    If you are under fire at work because of this application you can do the following:

    Application Properties >> Web Settings >> Evaluate without Enforcement.  

    This "should" allow your users to continue using the application while we work on identifying the underlining issue.

     

    Regards

    Dennis

    Tuesday, April 13, 2010 5:38 PM
  • Path = /gac/faces/login/Login.jsp/

    URL = http://xxxxx:9191/gac/faces/login/Login.jsp/

     

    Tuesday, April 13, 2010 5:40 PM
  • Please change path to the following:

    Path = /

    Leave the URL as is.

    Give that a try.

    Thanks!

     

    Tuesday, April 13, 2010 6:13 PM
  • Have you tried removing the trailing "/" from the URL?  I'm guessing it's a file, not a directory.
    Tuesday, April 13, 2010 11:28 PM
  • Hi Kuky,

    i had the same issue and here the solution:

    http://thelaith.net/2011/04/01/uag-sp1-file-access-possibly-bug/

    Worked for me.

    Thanks,

    Thursday, March 29, 2012 2:27 PM