none
Forefont endpoint protection 2010 installation SCCM error

    Question

  • Hi,

    When i try to install Ms forfont Endpoint Protection 2010 Server Setup I can't get past the Prerequisite Verification

    the "verifying Configuration manager client compnents" report a error

    The following Configuration Manager client component is not installed or disabled.
    Client component name: Software Distribution.

    If I open teh SCCM Console everything seems to work fine.

    this is the complete logfile

    [31-8-2010 11:27:22] Setup Started
    [31-8-2010 11:27:22] Product ID validation succeeded (Product ID: 03116-270-0001260-04309)
    [31-8-2010 11:28:09] Setup Log has been relocated from 'C:\Users\administrator.HK\AppData\Local\Temp\2\ServerSetup_31082010_112722.log'
    [31-8-2010 11:28:09] Setup has detected that the SQL Server Analysis Services 2008 client for .NET is not installed. Details: Could not load file or assembly 'Microsoft.AnalysisServices, Version=10.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91' or one of its dependencies. The system cannot find the file specified.
    [31-8-2010 11:28:10] [31-8-2010 11:28:10] Verifications started:
    [31-8-2010 11:28:10]
    [31-8-2010 11:28:10] Verification(Verifying hardware requirements) passed
    [31-8-2010 11:28:10]
    [31-8-2010 11:28:10] Verification(Verifying .NET Framework 3.5 SP1 prerequisite) passed
    [31-8-2010 11:28:10]
    [31-8-2010 11:28:10] Verification(Verifying SQL Server prerequisite) warning
    Warning: Setup has detected that the connection to the SQL Server is not encrypted. If the SQL Server and  Forefront Endpoint Protection 2010 are not located on a shared secure subnet, transmitted data can be viewed by third parties. We recommend that you secure the connection to the SQL Server. For more information, see Securing SQL Server in the SQL Server documentation.
    [31-8-2010 11:28:19]
    [31-8-2010 11:28:19] Verification(Verifying SQL Reporting Services prerequisite) passed
    [31-8-2010 11:28:19]
    [31-8-2010 11:28:19] Verification(Verifying Configuration Manager version) passed
    About to compare required version '4.0.6487.2000' to installed version '4.0.6487.2000'
    [31-8-2010 11:28:19]
    [31-8-2010 11:28:19] Verification(Verifying Configuration Manager Site Server permissions) passed About to verify Configuration Manager Site Server permissions
    [31-8-2010 11:28:20]
    [31-8-2010 11:28:20] Verification(Verifying Configuration Manager client components) failed
    About to verify client component 'Configuration Management Agent' is enabled
    About to verify client component 'Hardware Inventory Agent' is enabled
    About to verify client component 'Software Distribution' is enabled
    The following Configuration Manager client component is not installed or disabled.
    Client component name: Software Distribution
    [31-8-2010 11:28:20]
    [31-8-2010 11:28:20] Finished running verifications.

    any info would be very welkom

    Patrick

    Tuesday, August 31, 2010 9:31 AM

Answers

All replies

  • Hi Patrick,

    Thank you for your interest in Forefront Endpoint Protection 2010. I have reviewed the information you provided and it looks like the install is missing because  Configuration Manager doesn't have all the required components installed or configured. From the product documentation this is the list of all the prerequisites for FEP 2010:

    http://technet.microsoft.com/en-us/library/ff823830.aspx

    Specifically the documentation says this about Configuration Manager

    · Microsoft System Center Configuration Manager 2007 Service Pack 2 installed with default roles, and configured to use SQL Server Reporting Services

    · Microsoft System Center Configuration Manager 2007 Release 2

    · The following features installed and configured:

    ·     Hardware Inventory

    ·     Software Distribution

    ·     Desired Configuration Management

    I would recommend checking and making sure that Windows Server 2008 is configured properly for Configuration Manager:

    http://technet.microsoft.com/en-us/library/cc431377.aspx

    Prerequisites for Software Distribution

    http://technet.microsoft.com/en-us/library/bb680335.aspx

    How to configure Software Distribution

    http://technet.microsoft.com/en-us/library/bb632986.aspx

    Thanks,

    Chris


    Forefront Client Security Support
    Friday, September 03, 2010 4:30 PM
  • Hello Crhis I have this problem when I try to install FEP

    [11/2/2010 11:43:36 AM] Setup Started
    [11/2/2010 11:43:36 AM] Product ID validation succeeded (Product ID: 03116-270-0001260-04309)
    [11/2/2010 11:44:51 AM] For security reasons, it is not recommended to use a domain administrator account 'SALONES\terminator' as the reporting account.
    [11/2/2010 11:45:41 AM] Setup Log has been relocated from 'C:\Users\terminator\AppData\Local\Temp\1\ServerSetup_02112010_114335.log'
    [11/2/2010 11:45:42 AM] [11/2/2010 11:45:42 AM] Verifications started:
    [11/2/2010 11:45:42 AM]
    [11/2/2010 11:45:42 AM] Verification(Verifying hardware requirements) passed

    [11/2/2010 11:45:42 AM]
    [11/2/2010 11:45:42 AM] Verification(Verifying .NET Framework 3.5 SP1 prerequisite) passed

    [11/2/2010 11:46:10 AM]
    [11/2/2010 11:46:10 AM] Verification(Verifying SQL Server prerequisite) failed
    Setup cannot verify the service principal name (SPN) for this account. Ensure that there is a single valid SPN entry for this account in the Active Directory Domain Services.
    Account: SALONES\terminator

    Warning: Setup has detected that the connection to the SQL Server is not encrypted. If the SQL Server and  Forefront Endpoint Protection 2010 are not located on a shared secure subnet, transmitted data can be viewed by third parties. We recommend that you secure the connection to the SQL Server. For more information, see Securing SQL Server in the SQL Server documentation.

    [11/2/2010 11:46:13 AM]
    [11/2/2010 11:46:13 AM] Verification(Verifying SQL Reporting Services prerequisite) passed

    [11/2/2010 11:46:14 AM]
    [11/2/2010 11:46:14 AM] Verification(Verifying Configuration Manager version) passed
    About to compare required version '4.0.6487.2000' to installed version '4.0.6487.2000'

    [11/2/2010 11:46:14 AM]
    [11/2/2010 11:46:14 AM] Verification(Verifying Configuration Manager Site Server permissions) passed
    About to verify Configuration Manager Site Server permissions

    [11/2/2010 11:46:15 AM]
    [11/2/2010 11:46:15 AM] Verification(Verifying Configuration Manager client components) passed
    About to verify client component 'Configuration Management Agent' is enabled

    About to verify client component 'Hardware Inventory Agent' is enabled

    About to verify client component 'Software Distribution' is enabled

    [11/2/2010 11:46:15 AM]
    [11/2/2010 11:46:15 AM] Finished running verifications.

    I ran the commands for add the SPN but i still with the problem


    MCSA+s Andrés Galván Twitter @andres_gal Blog Forefront http://agalvanked.spaces.live.com/ Blog SharePoint http://andresgalvanb.spaces.live.com
    Tuesday, November 02, 2010 5:57 PM
  • Hi Andrés,

    Your problem is solved or no ? If no, check this link http://social.technet.microsoft.com/Forums/en-US/configmgrgeneral/thread/211e9291-af57-493a-9ab1-2394156dec3f/


    Bechir Gharbi | http://myitforum.com/cs2/blogs/bgharbi/
    Thursday, December 02, 2010 11:38 AM
  • Hi!

     

    I've resolved the same problem by adding Domain Users to Users group in SCCM and assigning Read right to Advertisement class.

     

    I've installed FEP 2010 on W2K8 R2 STD + SCCM 2007 R3 + SLQ 2005 STD (on W2K8 STD x86).

     

    In my opinion logs for prerequisites is creating bad. In log I've

     

    [2011-01-07 21:58:42][Verbose] Successfully retrieved site version info: Actual: 4.0.6487.2000. Minimum: 4.0.6487.2000. Maximim: 5.0.0.0. R2 Deployed: False. Status: -1
    [2011-01-07 21:58:42][Normal] Verification(Verifying Configuration Manager version) failed
    [2011-01-07 21:58:42][Normal]> Error: Setup has detected that the version of the Configuration Manager installed on this computer does not meet the prerequisite requirements. Upgrade the Configuration Manager installation to Configuration Manager 2007 Release 2 Service Pack 2.
    [2011-01-07 21:58:42][Normal]> 
    [2011-01-07 21:58:42][Normal]> 
    [2011-01-07 21:58:42][Normal]> 
    [2011-01-07 21:58:42][Normal] About to verify Configuration Manager Site Server permissions
    [2011-01-07 21:58:42][Verbose] Validating required permissions:
    [2011-01-07 21:58:42][Verbose]> Class: Site Permission: Read; Modify; Administer; Manage status filter
    [2011-01-07 21:58:42][Verbose]> Class: Collection Permission: Read; Read resource; Modify; Modify Resource; Modify collection setting; Delete; Delete resource; Create; Advertise; Administer
    [2011-01-07 21:58:42][Verbose]> Class: Configuration items Permission: Read; Modify; Delete; Create; Distribute; Manage folder
    [2011-01-07 21:58:42][Verbose]> Class: Package Permission: Read; Modify; Delete; Create; Distribute; Manage folder; Administer
    [2011-01-07 21:58:42][Verbose]> Class: Advertisement Permission: Read; Modify; Delete; Create; Manage folder
    [2011-01-07 21:58:42][Verbose]> Class: Report Permission: Read; Modify; Delete; Create; Manage folder
    [2011-01-07 21:58:43][Normal] Verification(Verifying Configuration Manager Site Server permissions) passed


    Wojciech Sciesinski
    Friday, January 07, 2011 9:35 PM