none
UAG Authentication Timeout using RADIUS

    Question

  • I have setup a POC using Windows Multi-Factor Authentication (i.e. Phonefactor Classic - my term) as a RADIUS authentication server to one of our UAG trunks.  For the most part, everything works as expected.  However, I have a few users that have tried switching to the text messaging type of MFA authentication with some issues that have to do with timing.

    1. The user enters their uid/pwd at the UAG logon screen
    2. UAG then attempts to authenticate with the RADIUS (Phonefactor) server
    3. The user is still waiting at the logon screen.
    4. If the text message doesn't come immediately, then the user gets an "Authentication Failed" type of message from UAG

    What I need to be able to do is increase that time that UAG waits on the response from the RADIUS server, but I can't seem to find such a setting.

    Any ideas?

    Wednesday, August 14, 2013 12:22 PM

Answers

  • Hi Redparadox,

    I think what you are looking for is the following registry key: HKEY_LOCAL_MACHINE\SOFTWARE\WhaleCom\e-Gap\von\UrlFilter\Auth\Radius\UDPReqTimeout

    This is the time UAG will wait for reply from the Radius server and it default for 16 seconds. Try to increase this value (You may need to restart IIS or the UAG User Manager service if this does not work immediately).

    Hope this helps.

    Ophir.

    • Marked as answer by Redparadox Friday, August 16, 2013 1:53 PM
    Wednesday, August 14, 2013 6:22 PM
    Moderator

All replies

  • Hi Redparadox,

    I think what you are looking for is the following registry key: HKEY_LOCAL_MACHINE\SOFTWARE\WhaleCom\e-Gap\von\UrlFilter\Auth\Radius\UDPReqTimeout

    This is the time UAG will wait for reply from the Radius server and it default for 16 seconds. Try to increase this value (You may need to restart IIS or the UAG User Manager service if this does not work immediately).

    Hope this helps.

    Ophir.

    • Marked as answer by Redparadox Friday, August 16, 2013 1:53 PM
    Wednesday, August 14, 2013 6:22 PM
    Moderator
  • Thank you so much.  Yes that was the key I was looking for.  All is working well now.
    Friday, August 16, 2013 1:54 PM