none
UAG Web App Redirect

    Question

  • I am trying to publish an website through UAG and because the website has some redirect after a successful login UAG just brings you back to the login screen for the application. I realize this is a vague question so I'll do my best to provide some detail of the setup.

    UAG 2010 Sp1 on 08R2.

    Internal and external hostnames are the same for the app and the portal, and the signed SSL cert is installed on both the internal server and UAG.
    The app was configured to use the same hostname as the portal. So you see https://app.domain.com/long_personalized_code/appfolder/login.aspx  after you get past the initial UAG login. That's all very good. But when you try to login to the app it just goes back to the login screen at the address listed.

    If you are internal and you login to the app, even from the UAG server's browser, it goes right through to the app's default.aspx page.

    I guess I need to know of there is way to make UAG ignore (or process) the redirects the client can't call directly from the outside?

    thanks.

    Tuesday, April 17, 2012 8:28 PM

All replies

  • Hi Amig@. Things to bear in mind:

    • The initial request to the internal application is specified in the properties of the published application, in the Portal Link tab in the field Application URL. This info is generated automatically from the server name and the path. Having a path of "/" the info will be populated as http://internalservername/. You can change that to adapt to your needs and say for instance http://internalservername/somepath/somefile.aspx
    • If the internal application requires authentication the initial path from above could be redirected to a login page
    • If the internal application requires the same set of credentials than the ones used to authenticate to UAG you can configure SSO in the properties of the published application in the tab Authentication. If the internal application requires Basic or NTLM authentication use the "401 Request" and specify the repository from which use the credentials. If the internal application is a proprietary one and uses forms for authenticating specify "HTML Form" and configure a custom loginform.xml (http://blogs.technet.com/b/ben/archive/2010/09/02/uag-custom-form-login.aspx).

    Regards


    // Raúl - I love this game

    Wednesday, April 18, 2012 8:14 AM
  • Thanks much. That should get me moving in the right direction.

    I can tell you that even though the website in question uses AD credentials it does not use a single sign on. There is a login page (/appfolder/login.aspx). If you hit any url on that server that's not that login page, it redirects to /appfolder/login.aspx.  All of the apps web files are under /appfolder/ .  I have the website properties under the portal settings and it does specify the /appfolder/ location.

    Wednesday, April 18, 2012 1:20 PM
  • So it seems that developing a custom loginform can be the answer 

    // Raúl - I love this game

    Thursday, April 19, 2012 7:28 AM