locked
FCS 14-day history with no data

    Question

  • Hi,

    I have a FCS installation which is showing all other data on the dashboard except for the 14-day history. Please help.

    There is this message:

    "Microsoft Forefront Client Security cannot display this report. Confirm that the reporting server is available, the account name and password are correct, and the account has permissions to access the reports."

    Any help would be much appreciated.

    Thanks.

    RBO
    Friday, September 19, 2008 10:26 AM

All replies

  • Rahmah,

    You need to verify that the reporting server url is added to the "local intranet site" in internet explorer.

    The easies way to do it is to:
    1. Open the FCS management console
    2. Click on any report in the right window pane
    3. Internet explorer opens to show the report and i'm guessing you are prompted to login also (so go ahead and login)
    4. in Ie, open tools -> internet  options.
    5. select the security tab and choose Local intranet.
    6. add the url of the reporting server (just to click on the add button).

    Go back to the management console and refresh...the 14 day history should show up shortly.

    hope this helps

    /Johan


    MCSE, forefront spec | www.msforefront.com
    Saturday, September 20, 2008 3:28 PM
  • Hi,

    I'm also facing the same problem, on the dashboard "no data" in the 14-day history

    The URL of the reporting server has been added to local intranet, but it still show "no data".  

    Please help...

    Thanks.

    MHI
    Tuesday, September 23, 2008 4:16 AM
  • Hello!

    Do you have any errors in the event log? specially regarding DTS job failing. This is the scheduled job that transfers data from the collection db to the reporting db

    additionally,

    Do you have any alerts in the MOM operator console?

    /Johan

    MCSE, forefront spec | www.msforefront.com
    Tuesday, September 23, 2008 7:25 PM
  • I had this issue back in August or September and all the troubleshooting points to the Internet Explorer settings.  I don't recall the steps to resolve it but my notes point to backing up the SystemCenterReporting database on the database server.  If you look at the event logs on the database server you may see something like this...

    "Could not allocate space for object 'dbo.SC_EventFact_Table'.'EventFact_ProviderDetailFK_Index' in database 'SystemCenterReporting' because the 'PRIMARY' filegroup is full. Create disk space by deleting unneeded files, dropping objects in the filegroup, adding additional files to the filegroup, or setting autogrowth on for existing files in the filegroup."

    This issue has resurfaced on my installation this week with the same error.  Backing up the DBs did not resolve it this time.  If someone has additional information.  I'd like to resolve it as well.

    Thanks!

    Fuel
    • Proposed as answer by Fuel451 Thursday, October 30, 2008 8:23 PM
    Thursday, October 30, 2008 1:41 PM
  • Adding to the previous post... (by the way, use this at your own risk)

    Several event log instances provided information that several tables within the SystemCenterReporting database or the filegroup were full.

    I connected to my SQL 2005 server, and opened the database, then opened the dbo.SC_EventFact_Table table and cleared out all rows older than six months.  I then re-ran the scheduled task SystemCenterDTSPackage task.  Still no update on the 14-day history.  The event log showed the error and another table that was full.

    I connected to the dbo.SC_EventParameterFact_Table table and deleted about 30,000 of the oldest rows (more than 600,000 total).  I re-ran the scheduled task SystemCenterDTSPackage task.  Sure enough, my 14-day history was able to update the next day in the 14-day history.

    My first assumption is that 1. the software doesn't need more than three to six months of history and 2. it may not be able to handle the data unless the database is configured to handle more data.  Anyone have anything else to add?
    Fuel
    Thursday, October 30, 2008 8:44 PM