none
publishing https thruogh TMG doesnt work properly

    Question

  • hello ,

    im trying to publish a plan https website which is https//sof.****.***/"with whatever after here"

    the publishing to come to the first oage which is the login page is wokring fine , but there is nothing happening after i put my credentials and login

    on the tmg i tried to monitore whats going on there was no errors and everthing looks very smooth

    i have published another website from the same forest as well but nothing loading as well after the login page , is there any way solve this issue ? i beleive that the website would change its post descreptions and characters after the login happening like any other website


    Best Regards

    Monday, December 10, 2012 12:55 PM

Answers

  • Ok, to summarize:

    You don't see any problem at all and you get to the login page. When submitting your login credentials you are returned to the login page.

    If so, I would say that your application/webserver has issues. Not TMG.

    If it works internally in the exact same way as it is supposed to when the user is on the Internet, then I would use the dev tools (F12) in IE on both the internal side and external and compare the output to see what fails. Maybe a cookie that doesn't get set properly? Hard to say as I have no idea how your app works or is supposed to work.

    Sorry I can't be more helpful.


    Hth, Anders Janson Enfo Zipper

    Tuesday, December 11, 2012 6:29 PM
  • Yes. Sharepoint behaves differently if accessed externally or internally.

    See my friend Thomas Balkestahls most excellent paper on Alternate Access Mappings.


    Hth, Anders Janson Enfo Zipper

    Wednesday, January 02, 2013 2:55 PM

All replies

  • Use TMG Best Practices Analyzer and run TMG Data Packager using the Basic Repro scenario.

    When done, examine the following:

    TMG BPA Report

    WebProxy logfiles

    Network Monitor traces (as this is SSL, just verify that the traffic is flowing between the published server and TMG)

    Logs on webserver... Does the webserver register any requests?

    One thing to verify is the following, is the published webserver on a different IP subnet than the TMG server? If so verify whether the rule has "requests appear to come from client" or "requests appear to come from TMG" (maybe not the exact wording but you'll understand when you see). If the first option is selected, does the webserver route back responses to TMG or does it have another default gateway? If so, try to change this setting to "requests appear to come from TMG".


    Hth, Anders Janson Enfo Zipper

    Monday, December 10, 2012 1:23 PM
  • i have trioed the same not workinstill , i come to the first page and then nothing coming after that

    i have tried to log on the monitore logs and used the tmg best practise monitore but with no results

     the website and the tmg are located on the same subnet


    Best Regards

    Monday, December 10, 2012 2:44 PM
  • I can't help you unless you provide more detail.

    What results did the above yield?

    Is the rule created for this actually being used?

    What happens if you click "Test Rule" on the selected rule in question?

    Do you in the resulting Network Monitor log files see an actual TCP session between the TMG server and the published server?

    This, to start. Most likely more information is needed but in order to understand where to look the above is needed to know where to look.


    Hth, Anders Janson Enfo Zipper

    Monday, December 10, 2012 6:52 PM
  • i an error
    when i did test rule but even though i get usually an error as this Error
    details: 12006 -

    Action: Go to http://go.microsoft.com/fwlink/?LinkId=115965<o:p></o:p>

    on all the
    publishing rule that already working on my tmg !<o:p></o:p>

    and this publishing
    rule is working to get me the first logging page but not further <o:p></o:p>



    Best Regards

    Tuesday, December 11, 2012 8:16 AM
  • Do you have any filters such as Websense installed?

    If so, disable it and try again.

    Furthermore, check for any alerts relating to this rule and problem.


    Hth, Anders Janson Enfo Zipper

    Tuesday, December 11, 2012 1:46 PM
  • we dont have any webfilters , as well as i dont think that webfilter ld affect the publishing at all here

    i have mentioned that there is no error messages on my tmg when its regarding the publishing monitore , as the traffic seems to be very smooth and happening , no denial messages either , i just want to get the back page behind the log but cannt :(


    Best Regards

    Tuesday, December 11, 2012 2:52 PM
  • Ok, to summarize:

    You don't see any problem at all and you get to the login page. When submitting your login credentials you are returned to the login page.

    If so, I would say that your application/webserver has issues. Not TMG.

    If it works internally in the exact same way as it is supposed to when the user is on the Internet, then I would use the dev tools (F12) in IE on both the internal side and external and compare the output to see what fails. Maybe a cookie that doesn't get set properly? Hard to say as I have no idea how your app works or is supposed to work.

    Sorry I can't be more helpful.


    Hth, Anders Janson Enfo Zipper

    Tuesday, December 11, 2012 6:29 PM
  • Hi,

    Thank you for the post.

    It seems like webserver issue. You may access the website from internal client, and see if it works.

    Regards,


    Nick Gu - MSFT

    Saturday, December 29, 2012 2:14 PM
    Moderator
  • so do you mean that sharepoint has 2 interface or 2 ways of behaviour when it comes from external or comes from internal ?

    im confused as sharepoint behaves normal internally while only when im publishing it im getting this error message 

    Tuesday, January 01, 2013 11:53 AM
  • Yes. Sharepoint behaves differently if accessed externally or internally.

    See my friend Thomas Balkestahls most excellent paper on Alternate Access Mappings.


    Hth, Anders Janson Enfo Zipper

    Wednesday, January 02, 2013 2:55 PM