none
User Activity report option is not available in TMG and TMG report is giving error

    Question

  • Hi,

    I have forefront TMG Enterprise Array installed, without SP1, i dont see the user activity report option at all on the TMG Server.

    I am also having a problem in generating one time report, While generating one time repeort i receive the following error

    The report Test could not be generated. Report Server error information: System.Web.Services.Protocols.SoapException: An error occurred during rendering of the report. ---> Microsoft.ReportingServices.ReportProcessing.UnhandledReportRenderingException: An error occurred during rendering of the report. ---> Microsoft.ReportingServices.OnDemandReportRendering.ReportRenderingException: An error occurred during rendering of the report. ---> System.NullReferenceException: Object reference not set to an instance of an object.
       at Microsoft.ReportingServices.WebServer.ReportExecution2005Impl.InternalRender(String Format, String DeviceInfo, PageCountMode pageCountMode, Stream& Result, String& Extension, String& MimeType, String& Encoding, Warning[]& Warnings, String[]& StreamIds)
       at Microsoft.ReportingServices.WebServer.ReportExecution2005Impl.Render(String Format, String DeviceInfo, PageCountMode pageCountMode, Byte[]& Result, String& Extension, String& MimeType, String& Encoding, Warning[]& Warnings, String[]& StreamIds)
       at Microsoft.ReportingServices.WebServer.ReportExecutionService.Render(String Format, String DeviceInfo, Byte[]& Result, String& Extension, String& MimeType, String& Encoding, Warning[]& Warnings, String[]& StreamIds).

    The error occurred on object 'Reports' of class 'Reports Configuration' in the scope of array 'QQQQ-TMGARRAY'.

    I have also noticed that on the second TMG server sql report services stops automatically please note that this server does not act as report server

    Please help me.

    Thanks


    SKHATRI

    Monday, February 20, 2012 6:52 PM

All replies

  •  

    Hi,

    Thank you for the post.

    Please install the latest TMG SP2 Rollup1 and see if it helps. And before update Forefront TMG SP2, you should have Forefront TMG SP1 and Forefront TMG Update 1 for SP1 installed.

    Regards,


    Nick Gu - MSFT

    Tuesday, February 21, 2012 2:19 AM
    Moderator
  • Hi,

    Thanks for your answer. I  have TMG Array which means 3 servers one Enterprise management server another two are array members. Kindly let me know the procedure to install TMG SP1 and then udpate 1 and then TMG SP2

    Thanks


    SKHATRI

    Tuesday, February 21, 2012 7:26 AM
  • Hi,

    Thank you for the post.

    Please follow this guide to install the updates: http://technet.microsoft.com/en-us/library/ff717843.aspx#install_ent.

    Regards,


    Nick Gu - MSFT

    Monday, February 27, 2012 7:31 AM
    Moderator
  • Hi,

    Sorry for late reply. I went to the guide which you have posted before i have some concerns please let me know

    In the guide it is mentioned that if it is TMG Array then on first array member "Remove the server from the load-balancing configuration" how to do this i mean i dont understand that after this step i am draining and stopping the service what does it mean and from where i should remove the server from the load balancing configuration. If i remove server from load balancing configuration then i dont think i will get drain and stop service option. can we start directly with drain and stop service without removing from nlb configuration?

    Also what if we want to install sp2 at the same time can we install sp1 update 1 then sp2 on one server once it is done then we can go ahead on other one. this will save the time from doing the above thing.

    Thanks


    If answer is helpful, please hit the green arrow on the left, or mark as answer. Salahuddin | Blogs:http://salahuddinkhatri.wordpress.com | MCITP Microsoft Lync

    Wednesday, March 07, 2012 6:42 PM
  • Hi,

    The article is wrong. You do not need the first step "Remove the server from the load-balancing configuration". It doesn't make any sense.

    You should update first all servers to SP1 Update 1 (EMS first) then update to SP2 + Rollup1.

    OB

    Thursday, March 08, 2012 10:57 AM
  • your answer is not clear can you explain more in details.

    have you updated your tmg enterprise arrays to sp1 or sp2


    If answer is helpful, please hit the green arrow on the left, or mark as answer. Salahuddin | Blogs:http://salahuddinkhatri.wordpress.com | MCITP Microsoft Lync

    Thursday, March 08, 2012 12:54 PM
  • This should be more clear.

    Update path:

    1. Update EMS to SP1
    2. Update other TMG servers to SP1
    3. Update EMS to SP1 Update1
    4. Update other TMG servers to SP1 Update1
    5. Update EMS to SP2 + Rollup1
    6. Update other TMG servers to SP2 + Rollup1

    Steps to follow on the TMG servers with NLB to update:

    1. Drain existing connections that are served by the server.
    2. Set nlb to "suspended" to prevent auto-rejoin when you restart.
    3. Install the update.
    4. Restart the server if it is required.
    5. Start NLB on the updated server.

    OB


    • Edited by OB_FR Thursday, March 08, 2012 2:51 PM
    Thursday, March 08, 2012 2:50 PM