locked
FF 2010 on MOSS 2007 - Global Settings-Scan Options - Scheduled Scan - Selected 'Failed to load SharePoint site list.'

    Question

  • All Sites based on SharePoint 2007 with SP2 work fine, previously FF 2007 w/SP3 worked fine. I removed FF 2007 w/SP3 to install FF 2010 for SharePoint.

    This fresh install of FF 2010 Will not allow me to "Select San Targets" for Scheduled Scans. I receive same errors on both WFE with the FF 2010 product. I did make the change to permit powershell remote signed so no errors in eventlog.

    Any idea why "'Failed to load SharePoint site list." is occurring?

    Thanks!

    Friday, July 30, 2010 9:35 PM

All replies

  • Hello,

    Could you provide any event errors (including ID's) you're seeing in the event logs?

    When you removed Forefront, what method did you use? Are you still seeing the old directory in place or was it purged as well?

    In the Forefront console, are you seeing any data?

    Thanks!

    Tuesday, August 03, 2010 3:13 PM
  • Hello Joe,

    Here is the only error in eventlog Event 5201 FSCManualScanner Scan Error  -> Scan engine failure within Manual scan job (file "Disclosure-US-410346.doc", message "<n/a>", folder https://x.y.z/AAA/BBB/filename, engine Norman 00010025)

    These steps were followed in removing FF 2007 SP3
    1. Open Services in the Control Panel.

    2. Stop the FSCController service. This causes the SharePoint services to be stopped also.

    3. When all these services have stopped, close the Services dialog box.

    4. Open Add or Remove Programs in the Control Panel.

    5. Remove Microsoft Forefront Security for SharePoint. Click Yes to confirm the deletion.

    6. At the Uninstall Complete screen, click Finish

    The FF Admin Console comes up and works fine otherwise.

    Let me know if you need anything further.

    Thanks!

    Tuesday, August 03, 2010 8:11 PM
  • Issues like this could be due to permissions (based on my own experience especially). I would follow the article below and see if this applies.

     

    "The account used to install Forefront Protection 2010 for SharePoint (FPSP) should be entered using the Domain\Account format when the server is part of a domain. This account must be a member of the Local Administrators group on the SharePoint server and have SharePoint Farm Administrators privileges. If SharePoint is configured to connect to the database using Windows authentication, this account must also be a member of the SQL Sysadmin role on the database server."

     

    http://technet.microsoft.com/en-us/library/ee358918.aspx

    Thursday, August 05, 2010 3:53 PM
  • Thanks Joe.

    FF Service Account is a domain account and has SQL Sysadmin role and is a local admin. The account was not a SP farm admin so I updated the farm admin group to include it.  I stopped the FF Protection controller service and restarted, no difference. Next I rebooted and nothing, so then I went as far as to remove the FF product and re-install and still it errors out after "Data Loading is in progress. Please wait while the whole structure is being loaded.." tries for about 20 seconds then 'Failed to load SharePoint site list.'.  Everything else in Admin console is working correctly and doing a manual scan on all content works; I thought if I had permission problems that it would also give me access denied during the scans of all items.  Should I just disregard the message?

    Please advise.

    Thursday, August 05, 2010 10:21 PM
  • It looks like we'd need to do more intensive troubleshooting for this. I discussed this with escalations and before suggesting you open a case to continue on this, do you have any way to upload data to a site you may have control of that I could look at? I'd like to get the FSCDiag (which you run from the root of the Forefront directory).

    Thanks

    • Proposed as answer by Joe A - MSFT Monday, August 16, 2010 9:29 PM
    • Unproposed as answer by Super_SharePoint Thursday, August 19, 2010 10:48 PM
    Friday, August 06, 2010 7:11 PM
  • Hello Joe,

    I have FSCDiag Zip archive stored on a skydrive (Windows Live) as its 24Mb.

    Please provide an email address so I can give you access.

    Thanks

    Tuesday, August 17, 2010 1:09 AM
  •  

    Hi Joe,

    The Zip is ready for you.

    Thanks for your help.

    Wednesday, August 18, 2010 11:04 PM
  • Password Protected -> share
    Thursday, August 19, 2010 11:50 PM
  • Where you able to find the problem wiht the file I provided.

     

    Please advise.

    Monday, August 23, 2010 9:40 PM
  • Do you have a link for the site it's on?
    Friday, August 27, 2010 1:52 PM