locked
TMG 2010 sp1 User Activity report

    Question

  • When i view the report i find no data itis Blank

    What could have i done to make this go wrong

    Please help me get this right

    I noticed that it works for IP but could not make it work with user name and our user names consist of first.surname

    Monday, September 06, 2010 9:10 AM

Answers

  • Most times the output is blank for User Activity is because no input has been provided.

    For example, when you create a standard report you enter criteria but for the user output, you actually need to enter in the name of the user (for example) for whom you want the report generated.

    Create a user activity report definition and save it.
    then edit the properties of the report - select the content tab - highlight the user activity and click edit report details.

    Highlight the word OVERWRITE and change it to something else such as domain\username - save the changes and re-run the report. You should now see some output.

    Keith

     


    Keith Alabaster - MVP/Forum Moderator
    Sunday, September 12, 2010 8:25 AM
    Owner

All replies

  • Hi,

     

    Thank you for the post.

     

    According to your description, “find no data it is blank”, but “I noticed that it works for IP”? Would you please elaborate it? Does the TMG server deploy in a workgroup environment? If that is true, the Report Server cannot gather user activity information from other members of the array. For more information, please refer to this: http://technet.microsoft.com/en-us/library/ff686708.aspx

     

    Regards,


    Nick Gu - MSFT
    Thursday, September 09, 2010 5:42 AM
    Moderator
  • Most times the output is blank for User Activity is because no input has been provided.

    For example, when you create a standard report you enter criteria but for the user output, you actually need to enter in the name of the user (for example) for whom you want the report generated.

    Create a user activity report definition and save it.
    then edit the properties of the report - select the content tab - highlight the user activity and click edit report details.

    Highlight the word OVERWRITE and change it to something else such as domain\username - save the changes and re-run the report. You should now see some output.

    Keith

     


    Keith Alabaster - MVP/Forum Moderator
    Sunday, September 12, 2010 8:25 AM
    Owner