none
Forefront TMG with SP1 User Activity Report Blank

    Question

  • Hi,

    We have a TMG standard 64-bit, single server topology with SP1 and Update 1 for Sp1 installed. I have read up on the problem and given access to the network service for the temp folders in .net. If i try generate the report using domain\username the report is completely blank if i try generate the report using the ip address is get subreport can not be shown error. Any help woud be appreciated.

     

    best regards

    Wednesday, January 12, 2011 11:16 AM

All replies

  • Hi,

    are you using a non english TMG installation?


    regards Marc Grote aka Jens Baier - www.it-training-grote.de - www.forefront-tmg.de - www.nt-faq.de
    Wednesday, January 12, 2011 12:41 PM
  • Hi,

     

    yes it is an english copy.

    Wednesday, January 12, 2011 2:20 PM
  • Hi,

    "we" are expecting a problem with the german version of Forefront TMG and this feature. One of the posters in the german Forefront forum found a solution for this problem in the german Forefront TMG version.
    http://social.technet.microsoft.com/Forums/en-US/forefrontde/thread/03c296d5-9657-4e64-b8c6-c93b3220233f
    One "solution" is to uninstall the Forefront TMG SP1 update 1 which seems to be the root cause of the problem. The other solution is (I tried to translate it in english);

    Solution:

    change language for NT AUTHORITY\NetworkService to Swedish .

    Steps:
    -       logon on TMG as local Administrator
    -       Installation of Microsoft SQL Server 2008 Management Studio Express
    -       connect to database

    Server type: Database Engine
    Server name: Server-Name\msfw
    Authentication: Windows Authentication

    -       Expand Security
    -       Expand Logins
    -       NT AUTHORITY\NetworkService - Properties
    -       under General - default language set to Swedish
    -       restart SQL services


    regards Marc Grote aka Jens Baier - www.it-training-grote.de - www.forefront-tmg.de - www.nt-faq.de
    • Proposed as answer by Ahmet Abdagic Thursday, January 13, 2011 8:17 AM
    Wednesday, January 12, 2011 5:05 PM
  • Hi,

    uups, sorry. I read you are using a non english copy of TMG


    regards Marc Grote aka Jens Baier - www.it-training-grote.de - www.forefront-tmg.de - www.nt-faq.de
    • Proposed as answer by Ahmet Abdagic Thursday, January 13, 2011 8:17 AM
    Wednesday, January 12, 2011 5:11 PM
  • Hi !

    I have similar situation when try to generate reporting in TMG, not allways but , but some time i have blank User Activity Report Blank.

    I alone try yours sollution but not have success. Maybe to try to install update 2. On another server same configuration but work normaly with generate User Activity Report.

    Best Regards

    Wednesday, January 12, 2011 6:17 PM
  • Hi,

     

    Thank you for the post.

     

    What about other report(one-time report and recurring report)? Do you receive any error message when creating User Activity Report? Here is related post: http://social.technet.microsoft.com/Forums/en-US/ForefrontedgeIA/thread/bdb11c6e-0ac7-4337-ac2a-179dc8d66aa7

     

    Regards,


    Nick Gu - MSFT
    • Proposed as answer by Ahmet Abdagic Thursday, January 13, 2011 8:17 AM
    Thursday, January 13, 2011 4:46 AM
    Moderator
  • No it is full english version, it comes from a microsoft action pack. I tried before update 1 and it didnt work, i then installed update 1 and it still didnt work. I have uninstalled and reinstalled sp1 and update 1. same result. Sometimes i get ip addresses from certain users i enter. but those will return 3 -4 enteries for a month report. And the report looks nothing like the screen shots ive seen on some sites reviewing sp1. all i get sometimes is a table with ip addresses, no graphs of any kind. and the ont-time and recurring reports seem to be 100 %

     

    regards

    Thursday, January 13, 2011 8:12 AM
  • Hi !

    I look the post from the Nick GU post and now the solve the problem.

    St.Sparky please use this link.

    http://social.technet.microsoft.com/Forums/en-US/ForefrontedgeIA/thread/bdb11c6e-0ac7-4337-ac2a-179dc8d66aa7

    Nick in this momement not have another problem in TMG

     

    • Proposed as answer by Ahmet Abdagic Thursday, January 13, 2011 8:18 AM
    Thursday, January 13, 2011 8:17 AM
  • No that is not my problem i know how to specify the user name and/or ip address. I posted that in the first post. There is something wrong with the report itself.
    Thursday, January 13, 2011 11:12 AM
  • Is there still no answer to this? At this rate it looks like the SP1 is a complete stuff up.
    Monday, January 17, 2011 5:36 PM
  • Hi Sparky

    Really i not sure, but i solve this problem.

    Yes it look that SP1 with Update 2 is complete.

     

    Monday, January 17, 2011 8:05 PM
  • Is TMG domain joined? There is known issue with workgroup arrays.
    Alex Zvansky TMG Product Group
    Monday, January 17, 2011 11:31 PM
  • Hi,

     

    Update 2? I have only seen update 1. and yes it is joined to the domain. If i remove it from the domain you think that will fix it?

    Wednesday, January 19, 2011 7:11 AM
  • Hi,

    Try to TMG 2010 install update 2 and, if is not solve the problem, why not try to disjoin server from the domain and again join or just leave it workgroup.

    Just try.

    Best Regards

    :)

    Wednesday, January 19, 2011 9:12 AM
  • Hi Ahmet Abdagic:


    Is the TMG 2010 update 2 as follow?

    Software Update 1 - Rollup 2 - for Forefront TMG SP1 now available
    http://support.microsoft.com/kb/2475183

     


    Netfee for TMG/ISA server ---- Http://www.netfeesoftware.com
    Wednesday, January 19, 2011 12:51 PM
  • No it's the opposite. We have known issue with workgroup. Domain should work.
    Alex Zvansky TMG Product Group
    Wednesday, January 19, 2011 2:08 PM
  • Where to get TMG 2010 update 2?
    Netfee for TMG/ISA server ---- Http://www.netfeesoftware.com
    Wednesday, January 19, 2011 2:37 PM
  • I have a question... would the report be blank if we have unauthenticated internet access? I think the server should know who is access the internet despite if they are authenticating or not, but its the only thing i can think of.

    Monday, February 07, 2011 6:58 AM
  • In this location get update 2 for TMG 2010

    Software Update 1 Rollup 2 for Forefront Threat Management Gateway (TMG) 2010 Service Pack 1

    http://support.microsoft.com/kb/2475183

     

    • Proposed as answer by Ahmet Abdagic Monday, February 07, 2011 7:08 AM
    Monday, February 07, 2011 7:06 AM
  • Hi Sparky

    did you tried to monitor if client have installed firewall client

    • Proposed as answer by Ahmet Abdagic Monday, February 07, 2011 7:08 AM
    Monday, February 07, 2011 7:08 AM
  • Hi

     

    yes my work ststion has the firewall client installed, but i still only get a couple of sites reporting. Where there should be lot more. The urls are also missing. According to articles ive read on this there are suppose to be graphs and charts on the report.I have non of those and only a hyperlink to webpages in the lefthand side menu.

    Monday, February 07, 2011 12:56 PM
  • Hi Sparky !

    I know that may sound stupid attempt at a solution but in any case try.

    1. Install on another machine TMG and make the same or similar rules for
    2. The second TMG Uninstall the existing and re-install TMG

    Notice: Backup configuration, Rules (Backup All)

    Sparky I know that this is not the best and wisest decision, but in any event attempt.

    Monday, February 07, 2011 1:59 PM
  • Hi

     

    The main problem is in security rights to access SQL Server 2008 Reporting Services. By default, only BUILTIN\Administrators have full access, so when you log in as LOCAL Administrator - everything works fine, try it! There is a strange thing - even Domain Admins (who are the members of BUILTIN\Administrators group!!!) do not have full access rights to Reporting Server!  I think it's a BUG! the solution is simple - add full access rights to your domain account and everything will work as it must work. Here is the article - http://msdn.microsoft.com/en-us/library/ms156034.aspx

     

    Have a good day and sorry for my English)

    Wednesday, February 09, 2011 2:35 PM
  • Thanks for the responses i have tried both suggestions and nothing seems better. What links are suppose to be in the left hand side menu? Cause all i get is Website, i would think that even a blank report would have the links and even the axis for the graphs, and mine have neither.
    • Proposed as answer by Le Bolch Friday, February 18, 2011 2:08 PM
    • Unproposed as answer by Le Bolch Friday, February 18, 2011 2:08 PM
    Thursday, February 17, 2011 9:46 AM
  • i've got exactly the same issue than St.Sparky.

    I've tried the both suggestions too and i get always error on subreport.

     

    Thanks

    Monday, February 21, 2011 12:21 PM
  • Hi

    Is there any news on this? I am experiencing the same issue. I am using Forefront TMG Standard Edition, SP1, Update Rollup 3 (Version: 7.0.9027.400). It is an Englisch installation and it is part of a domain.

    Thanks and Regards

    stefancpt

    Thursday, July 07, 2011 10:57 AM
  • This seems to have fallen by the wayside. I will pick this up and see what I can do with it.

    The product I will be testing will be FTMG SP1 rollup 4 with fully updated Windows 2008R2 in a domain


    Keith Alabaster - MVP/Forum Moderator
    Thursday, July 07, 2011 1:16 PM
    Moderator
  • I have not given permissions to anything outside of what was granted as part of domain membership, FTMG installation plus access rules that allow all traffic between internal & localhost and vice versa.

    OK - first test - using an ip address in the user list. - user activity report

    Report settings - default using last 7 days, single instance report and for ip 192.168.0.93 (my personal workstation).

    First time I used this I also got a subreport error message displayed. i was also prompted that active-X scripts were being blocked by the browser - I allowed this option and immediately re-ran the test which successfully displayed the output but also presented me with another box stating that certain content was being blocked by the browser - again i clicked the Allow Content option (The yellow bar at the top in some versions of IE and the yellow bar at the bottom on later versions).

    The output gave User (ip address), category of site, web site and finally traffic.

    Will try users and report on that later this afternoon - going in to a meeting now.

     


    Keith Alabaster - MVP/Forum Moderator
    Thursday, July 07, 2011 1:55 PM
    Moderator
  • Hi Keith

    Thanks for your prompt reply. I also updated to SP1 Rollup 4 today. The server is a Windows 2008 R2 x64 virtual machine.

    I used the default report settings and specified my personal workstation IP as well.

    I did not have any issues with the last hour report period. The report finished successfully.

    If I change the report period to last 24 hours, last 7 days or last 30 days I usually receive the subreport error message. Most of the time I also get the prompts in IE9 you mentioned. I have to re-run the report 2 to 3 times to get results for these report periods.

    However, the results do not seem to be accurate. The total bytes value of my number one website is 34.70 MB for the last 24 hours. I changed the report period to 7 days and 30 days and this value only increased to 39.48 MB. For testing purposes, I specified another IP address. In this case, the total bytes did not change at all no matter if the report period was 24 hours, last 7 days or last 30 day.

     

    Every time I get a subreport error message, the event log reveals the following:

    SQL Server Reporting Services could not be configured for Forefront TMG. Restarting the Microsoft Forefront TMG Job Scheduler service may resolve this issue. Reporting Services error information: Configuration option 'show advanced options' changed from 1 to 1. Run the RECONFIGURE statement to install.
    Configuration option 'Ole Automation Procedures' changed from 1 to 1. Run the RECONFIGURE statement to install.
    Read From COM (URLCategory,ID) : Alcohol ,
    1
    Read From COM (URLCategory,ID) : Anonymizers ,
    2
    Read From COM (URLCategory,ID) : Art/Culture/Heritage ,
    3
    Read From COM (URLCategory,ID) : Blogs/Wiki ,
    4
    Read From COM (URLCategory,ID) : Botnet ,
    5
    Read From COM (URLCategory,ID) : Chat ,
    6
    Read From COM (URLCategory,ID) : Child Friendly Materials ,
    7
    Read From COM (URLCategory,ID) : Criminal Activities ,
    8
    Read From COM (URLCategory,ID) : Dating/Personals ,
    9
    Read From COM (URLCategory,ID) : Digital Postcards ,
    10
    Read From COM (URLCategory,ID) : Dubious ,
    11
    Read From COM (URLCategory,ID) : Edge Content Servers/Infrastructure ,
    12
    Read From COM (URLCategory,ID) : Education/Reference ,
    13
    Read From COM (URLCategory,ID) : Employment ,
    14
    Read From COM (URLCategory,ID) : Fashion/Beauty ,
    15
    Read From COM (URLCategory,ID) : Financial ,
    16
    Read From COM (URLCategory,ID) : Forum/Bulletin Boards ,
    17
    Read From COM (URLCategory,ID) : Free Hosting  ,
    18
    Read From COM (URLCategory,ID) : Gambling ,
    19
    Read From COM (URLCategory,ID) : Games ,
    20
    Read From COM (URLCategory,ID) : General Business ,
    21
    Read From COM (URLCategory,ID) : General Entertainment ,
    22
    Read From COM (URLCategory,ID) : Government/Military ,
    23
    Read From COM (URLCategory,ID) : Hacking/Computer Crime ,
    24
    Read From COM (URLCategory,ID) : Hate/Discrimination ,
    25
    Read From COM (URLCategory,ID) : Health ,
    26
    Read From COM (URLCategory,ID) : Humor/Comics ,
    27
    Read From COM (URLCategory,ID) : Illegal Drugs ,
    28
    Read From COM (URLCategory,ID) : Internet Services ,
    29
    Read From COM (URLCategory,ID) : Legal Services & Reference ,
    30
    Read From COM (URLCategory,ID) : Malicious ,
    32
    Read From COM (URLCategory,ID) : Mature Content ,
    33
    Read From COM (URLCategory,ID) : Media Sharing ,
    34
    Read From COM (URLCategory,ID) : Motor Vehicles ,
    35
    Read From COM (URLCategory,ID) : News ,
    36
    Read From COM (URLCategory,ID) : Non-Profit/Advocacy/NGO ,
    37
    Read From COM (URLCategory,ID) : Nudity ,
    38
    Read From COM (URLCategory,ID) : Obscene/Tasteless ,
    39
    Read From COM (URLCategory,ID) : Online Communities ,
    40
    Read From COM (URLCategory,ID) : Online Trading/Brokerage ,
    41
    Read From COM (URLCategory,ID) : P2P/File Sharing ,
    42
    Read From COM (URLCategory,ID) : Parked Domain ,
    43
    Read From COM (URLCategory,ID) : Personal Network Storage ,
    44
    Read From COM (URLCategory,ID) : Phishing ,
    45
    Read From COM (URLCategory,ID) : Politics/Opinion ,
    46
    Read From COM (URLCategory,ID) : Pornography ,
    47
    Read From COM (URLCategory,ID) : Portal Sites ,
    48
    Read From COM (URLCategory,ID) : Public Information ,
    49
    Read From COM (URLCategory,ID) : Real Estate ,
    50
    Read From COM (URLCategory,ID) : Recreation/Hobbies ,
    51
    Read From COM (URLCategory,ID) : Religion/Ideology ,
    52
    Read From COM (URLCategory,ID) : Remote Access ,
    53
    Read From COM (URLCategory,ID) : Restaurants/Dining ,
    54
    Read From COM (URLCategory,ID) : School Cheating Information ,
    55
    Read From COM (URLCategory,ID) : Search Engines ,
    56
    Read From COM (URLCategory,ID) : Self Defense ,
    57
    Read From COM (URLCategory,ID) : Shareware/Freeware ,
    58
    Read From COM (URLCategory,ID) : Shopping ,
    59
    Read From COM (URLCategory,ID) : Social Opinion ,
    60
    Read From COM (URLCategory,ID) : Spam URLs ,
    61
    Read From COM (URLCategory,ID) : Special Interests ,
    31
    Read From COM (URLCategory,ID) : Sports ,
    62
    Read From COM (URLCategory,ID) : Spyware/Adware ,
    63
    Read From COM (URLCategory,ID) : Streaming Media ,
    64
    Read From COM (URLCategory,ID) : Technical Information ,
    65
    Read From COM (URLCategory,ID) : Tobacco ,
    66
    Read From COM (URLCategory,ID) : Travel ,
    67
    Read From COM (URLCategory,ID) : Unknown ,
    0
    Read From COM (URLCategory,ID) : Usenet News ,
    68
    Read From COM (URLCategory,ID) : Violence ,
    69
    Read From COM (URLCategory,ID) : Weapons ,
    70
    Read From COM (URLCategory,ID) : Web Ads ,
    71
    Read From COM (URLCategory,ID) : Web E-mail ,
    72
    Read From COM (URLCategory,ID) : Web Phone ,
    73
    Read From COM (URLCategory,ID) : Web-based Productivity Applications  ,
    74
    Configuration option 'Ole Automation Procedures' changed from 1 to 0. Run the RECONFIGURE statement to install.
    Configuration option 'show advanced options' changed from 1 to 0. Run the RECONFIGURE statement to install.
    Configuration option 'Ole Automation Procedures' changed from 0 to 0. Run the RECONFIGURE statement to install.
    Configuration option 'show advanced options' changed from 0 to 0. Run the RECONFIGURE statement to install.
    Another session is executing the sp_filestream_configure stored procedure. Check the updated configuration settings and retry the operation if necessary.
    Another session is executing the sp_filestream_configure stored procedure. Check the updated configuration settings and retry the operation if necessary.
    Another session is executing the sp_filestream_configure stored procedure. Check the updated configuration settings and retry the operation if necessary.

     

    Thanks & Regards

    stefancpt

    Friday, July 08, 2011 12:00 AM
  • Stefan, I know you have probably done so already but can you just review this?

    http://technet.microsoft.com/en-us/library/ff717843.aspx


    Keith Alabaster - MVP/Forum Moderator
    Saturday, July 09, 2011 10:15 AM
    Moderator
  • Yes I reviewed this document before I installed SP1. I am not sure though how this could help me now?

    Thanks

    stefancpt

    Tuesday, July 12, 2011 9:23 AM
  • I have exactly the same error, with my user activity report.

    I follow this procedure, with no luck

     

    /******************************************************************************************************

    User Activity report for multiple users not working error 0xc0040432
    http://www.feedage.com/feeds/390212/forefront-tmg-isa-server-product-team-blog

    Sat, 26 Mar 2011 16:25:15 GMT

    The user activity report is a new feature of Forefront TMG SP1. I recently came across an issue where the customer was trying to run TMG user activity reports. When he used a single user (domainname\username) it rendered the report okay, but when we tried the same for 2 users (domainname\username1; domainname\username2) it gave the following error message after 5 minutes:

    0xc0040432
    The report TEST MS could not be generated. Report Server error information: The operation has timed out.
    The error occurred on object 'Reports' of class 'Reports Configuration' in the scope of array 'XXXXXXXXXXX’.

    As a part of the troubleshooting we tried to use the underlining SQL Server Reporting Server (SSRS) to run the same reports. This worked and we did not run into the issue.From looking at the built-in tracing in TMG, we identified that TMG failed to render the report because the operation timed out. By default the timeout for this report is 5 minutes.To fix the issue we created the following registry key:

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\RAT\Stingray\Debug\REPORTING]
    REG_DWORD: "RS_SOAP_CLIENT_TIMEOUT_IN_MILLISECONDS"
    Value: 0x000927c0

    Please note you may have to create the registry keys as they do not exist by default:

    0x000927c0 (HEX) =600000 milliseconds = 10 minutes.
    The default timeout value is 5 minutes.

    This worked for 2 users, but with 10 users it still timed out and we got the same error. We eventually fixed the issue by increasing the registry value to 20 minutes. The main reason why we had to increase the timeout value was because the machine was not powerful enough to complete the processing of multiple users within the default 5 min.

    Author
    Saurav Datta
    Security Support Escalation Engineer
    Microsoft CSS Forefront Security Edge Team

    /******************************************************************************************************

    Any news? hope TMG Sp2 resolve all this problems.

     

    Regards,


    CAS
    Monday, August 22, 2011 3:21 PM
  • Here is a tip for you all trying to use TMG reporting.

    Don't. That simple get a 3rd party program to do the reporting for you. We have been working with MS for almost 6 months to try and resolve numerous problems with TMG reporting, user activity being the main one and its still no resolved. We have now left it at that and moved on.

     

     

    Tuesday, August 23, 2011 6:19 AM
  • hi

     

    i solved this problem.only go to reporting section anc change the way that save reporting path in setting:

     

    \\server name\Share folder name

    • Proposed as answer by Ebrahim Partovi Wednesday, February 01, 2012 7:58 AM
    Wednesday, February 01, 2012 6:29 AM